<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge"/><meta charset=utf-8 /><base href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat /><meta name=keywords content="hashcat, crack, password, hack, linux, recover, test, command, security, privacy, ssl, hash, encrypt, decrypt"/><meta name=author content="Nick Congleton"/><meta name=description content=" Discover the basics of the password cracking utility, Hashcat."/><meta name=generator content="Joomla! - Open Source Content Management"/><title>Test And Recover Your Passwords By Cracking Them With Hashcat - LinuxConfig.org</title><link href="https://linuxconfig.org/component/search/?Itemid=1919&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-1919 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-498 g-standard  "> <a class="g-menu-item-container jsn-icon-contact" href=/contact-us> <span class=g-menu-item-content> <span class=g-menu-item-title>Contact us</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1577 g-standard  "> <a class=g-menu-item-container href=/write-for-us> <span class=g-menu-item-content> <span class=g-menu-item-title>Write For Us</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=#rss data-uk-tooltip="{pos:'bottom'}"> <span class="fa fa-rss"></span> <span class=g-social-text> RSS Feeds</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration"/> </a> </div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-95"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1787 g-parent  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Programming</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-2 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1789 g-parent g-menu-item-link-parent "> <a class=g-menu-item-container href=/c-programming-tutorial> <span class=g-menu-item-content> <span class=g-menu-item-title>C Programming</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-3 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1861  "> <a class=g-menu-item-container href=http://how-to.linuxcareer.com/c-development-on-linux-introduction> <span class=g-menu-item-content> <span class=g-menu-item-title>Introduction - I.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1862  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-comparison-between-c-and-other-programming-languages> <span class=g-menu-item-content> <span class=g-menu-item-title>Comparison - II.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1863  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-types-variables-operators> <span class=g-menu-item-content> <span class=g-menu-item-title>Variables - III.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1864  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-flow-control-iv> <span class=g-menu-item-content> <span class=g-menu-item-title>Flow Control - IV.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1865  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-functions-v> <span class=g-menu-item-content> <span class=g-menu-item-title>Functions - V.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1866  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-pointers-and-arrays-vi> <span class=g-menu-item-content> <span class=g-menu-item-title>Pointers and Arrays - VI.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1867  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-structures-vii> <span class=g-menu-item-content> <span class=g-menu-item-title>Structures - VII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1868  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-basic-io-viii> <span class=g-menu-item-content> <span class=g-menu-item-title>Basic I/O - VIII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1869  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-coding-style-and-recommendations-ix> <span class=g-menu-item-content> <span class=g-menu-item-title>Coding style - IX.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1870  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-building-a-program-x> <span class=g-menu-item-content> <span class=g-menu-item-title>Building a program - X.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1871  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-packaging-for-debian-and-fedora-xi> <span class=g-menu-item-content> <span class=g-menu-item-title>Packaging - XI.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1872  "> <a class=g-menu-item-container href=https://linuxconfig.org/c-development-on-linux-getting-a-package-in-the-official-debian-repositories-xii> <span class=g-menu-item-content> <span class=g-menu-item-title>Repositories - XII.</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1790 g-parent g-menu-item-link-parent "> <a class=g-menu-item-container href=/learn-python-fundamentals> <span class=g-menu-item-content> <span class=g-menu-item-title>Python Fundamentals</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-3 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1879  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-introduction-and-installation-guide> <span class=g-menu-item-content> <span class=g-menu-item-title>Introduction - I.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1880  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-files-and-the-interpreter> <span class=g-menu-item-content> <span class=g-menu-item-title>Interpreter - II.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1881  "> <a class=g-menu-item-container href=https://linuxconfig.org/experimenting-with-numbers-and-text-in-python> <span class=g-menu-item-content> <span class=g-menu-item-title>Numbers and Text - III.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1882  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-variables> <span class=g-menu-item-content> <span class=g-menu-item-title>Variables - IV.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1883  "> <a class=g-menu-item-container href=https://linuxconfig.org/working-with-number-variables-in-python> <span class=g-menu-item-content> <span class=g-menu-item-title>Number Variables - V.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1884  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-string-basics> <span class=g-menu-item-content> <span class=g-menu-item-title>String Basics - VI.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1885  "> <a class=g-menu-item-container href=https://linuxconfig.org/advanced-python-strings> <span class=g-menu-item-content> <span class=g-menu-item-title>Advanced Strings - VII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1886  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-comments> <span class=g-menu-item-content> <span class=g-menu-item-title>Comments - VIII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1887  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-lists> <span class=g-menu-item-content> <span class=g-menu-item-title>Lists - IX.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1888  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-list-methods> <span class=g-menu-item-content> <span class=g-menu-item-title>List Methods - X.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1889  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-multidimensional-lists> <span class=g-menu-item-content> <span class=g-menu-item-title>Multidimensional Lists - XI.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1890  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-tuples> <span class=g-menu-item-content> <span class=g-menu-item-title>Tuples - XII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1891  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-boolean-operators> <span class=g-menu-item-content> <span class=g-menu-item-title>Boolean Operators - XIII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1892  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-if-statements> <span class=g-menu-item-content> <span class=g-menu-item-title>If Statements - XIV.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1893  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-while-loops> <span class=g-menu-item-content> <span class=g-menu-item-title>While Loops - XV.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1894  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-for-loops> <span class=g-menu-item-content> <span class=g-menu-item-title>For Loops - XVI.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1895  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-dictionaries> <span class=g-menu-item-content> <span class=g-menu-item-title>Dictionaries - XVII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1896  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-advanced-dictionaries> <span class=g-menu-item-content> <span class=g-menu-item-title>Advanced Dictionaries - XVIII.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1897  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-functions> <span class=g-menu-item-content> <span class=g-menu-item-title>Functions - XIX.</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1908 g-parent  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Python Advanced</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-3 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1909  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-classes> <span class=g-menu-item-content> <span class=g-menu-item-title>Classes - I.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1910  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-constructors> <span class=g-menu-item-content> <span class=g-menu-item-title> Constructors - II.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1911  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-encapsulation> <span class=g-menu-item-content> <span class=g-menu-item-title>Encapsulation - III.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1912  "> <a class=g-menu-item-container href=https://linuxconfig.org/python-inheritance> <span class=g-menu-item-content> <span class=g-menu-item-title>Inheritance - IV.</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1788 g-parent  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>System Administration</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-2 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1791 g-parent g-menu-item-link-parent "> <a class=g-menu-item-container href=/wine-installation-and-configuration-tutorial-on-linux> <span class=g-menu-item-content> <span class=g-menu-item-title>WINE</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-3 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1873  "> <a class=g-menu-item-container href=/wine-installation-and-configuration-tutorial-on-linux> <span class=g-menu-item-content> <span class=g-menu-item-title>About - I.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1874  "> <a class=g-menu-item-container href=/introduction-to-wine> <span class=g-menu-item-content> <span class=g-menu-item-title>Introduction - II.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1875  "> <a class=g-menu-item-container href=/installing-wine> <span class=g-menu-item-content> <span class=g-menu-item-title>Installation - III.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1876  "> <a class=g-menu-item-container href=/configuring-wine-with-winecfg> <span class=g-menu-item-content> <span class=g-menu-item-title>Configuration - IV.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1877  "> <a class=g-menu-item-container href=/using-wine-prefixes> <span class=g-menu-item-content> <span class=g-menu-item-title>Prefixes - V.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1878  "> <a class=g-menu-item-container href=/configuring-wine-with-winetricks> <span class=g-menu-item-content> <span class=g-menu-item-title>Winetricks - VI.</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1855 g-parent  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Security</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-2 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1856 g-parent  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Burp Suite</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-3 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1857  "> <a class=g-menu-item-container href=/learn-burp-suite-on-kali-linux-part-1> <span class=g-menu-item-content> <span class=g-menu-item-title>Set up Burp Suite - I.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1858  "> <a class=g-menu-item-container href=/learn-burp-suite-on-kali-linux-part-2> <span class=g-menu-item-content> <span class=g-menu-item-title>Intercept Traffic - II.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1859  "> <a class=g-menu-item-container href=/learn-burp-suite-on-kali-linux-part-3> <span class=g-menu-item-content> <span class=g-menu-item-title>Brute Force Test - III.</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-1860  "> <a class=g-menu-item-container href=/learn-burp-suite-on-kali-linux-part-4> <span class=g-menu-item-content> <span class=g-menu-item-title>Full Suite of Tools - IV.</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> </ul> </div> </div> </li> </ul> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1766 g-parent g-standard  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Linux Distros</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1767  "> <a class=g-menu-item-container href=/linux-distros/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1768  "> <a class=g-menu-item-container href=/linux-distros/centos> <span class=g-menu-item-content> <span class=g-menu-item-title>CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1769  "> <a class=g-menu-item-container href=/linux-distros/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1771  "> <a class=g-menu-item-container href=/linux-distros/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1770  "> <a class=g-menu-item-container href=/linux-distros/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>Redhat</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-5"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/test-and-recover-your-passwords-by-cracking-them-with-hashcat method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..."/> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=1919 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h2 itemprop=name> Test And Recover Your Passwords By Cracking Them With Hashcat </h2></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Nick Congleton</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration &amp; Configuration</span> </dd><dd class=published> <time datetime=2017-04-01T17:16:39+11:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>01 April 2017 </time> </dd> </dl><div class=article-position> <center><span class=visible-desktop> <ins class=adsbygoogle style=display:inline-block;width:728px;height:90px data-ad-client=ca-pub-4906753266448300 data-ad-slot=0196793676></ins> </span> <span class=hidden-desktop> <ins class=adsbygoogle style=display:inline-block;width:320px;height:100px data-ad-client=ca-pub-4906753266448300 data-ad-slot=5317240446></ins> </span></center> </div> </div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h1-introduction class='toclink toclink-h1'>1.&nbsp;Introduction</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h2-getting-some-hashes class='toclink toclink-h1'>2.&nbsp;Getting Some Hashes</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h3-getting-a-wordlist class='toclink toclink-h1'>3.&nbsp;Getting A Wordlist</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h4-basic-cracking class='toclink toclink-h1'>4.&nbsp;Basic Cracking</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h5-options class='toclink toclink-h1'>5.&nbsp;Options</a><ul><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h5-1-hash-types class='toclink toclink-h2'>5.1.&nbsp;Hash Types</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h5-2-attack-modes class='toclink toclink-h2'>5.2.&nbsp;Attack Modes</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h5-3-rules class='toclink toclink-h2'>5.3.&nbsp;Rules</a></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h5-4-output class='toclink toclink-h2'>5.4.&nbsp;Output</a></li></ul></li><li><a href=https://linuxconfig.org/test-and-recover-your-passwords-by-cracking-them-with-hashcat#h6-closing-thoughts class='toclink toclink-h1'>6.&nbsp;Closing Thoughts</a></li></ul></li></ul></div><div itemprop=articleBody><h2 id=h1-introduction>Introduction</h2>Hashcat is a robust password cracking tool that can help you recover lost passwords, audit password security, benchmark, or just figure out what data is stored in a hash. <br><br> There are a number of great password cracking utilities out there, but Hashcat is known for being efficient, powerful, and full featured. Hashcat makes use of GPUs to accelerate hash cracking. GPUs are much better and handling cryptographic work than CPUs are, and they can be utilized in much greater numbers than CPUs. Hashcat also supports a very wide range of popular hashes, to ensure that it can handle deciphering nearly any password. <br><br> Please note that misuse of this program can be <strong>illegal</strong>. Only test on systems that you own or have written permission to test on. Don't share or post hashes or results publicly. Hashcat should be used for password recovery and professional security audits. <h2 id=h2-getting-some-hashes>Getting Some Hashes</h2>If you're going to test out Hashcat's hash cracking capabilities, you're going to need some hashes to test with. Don't do something crazy and start digging up encrypted user passwords on your computer or server. You can create some dummy ones for just this purpose. <br><br> You can use OpenSSL to create a series of password hashes that you would like to test. You don't have to go totally nuts, but you should have a few to really see what Hashcat can do. <code>cd</code> into a folder where you would like to do your testing. Then, use the command below to echo possible passwords into OpenSSL and output them into a file. The <code>sed</code> portion is just to strip away some garbage output and just get the hashes. <pre>$ echo -n "Mybadpassword123" | openssl dgst -sha512 | sed 's/^.*= //' >> hashes.txt</pre> Just run it a few times with different passwords, so you have a few in the file. <h2 id=h3-getting-a-wordlist>Getting A Wordlist</h2>For this test, you're going to need a wordlist of passwords to test against. There are tons of these online, and you can find them all over. You can also use a utility like <a href=/creating-wordlists-with-crunch-on-kali-linux>Crunch</a>, or just make one by typing a bunch of words into a text document. <br><br> To save time, just <code>wget</code> the list below. <pre>$ wget https://raw.githubusercontent.com/danielmiessler/SecLists/master/Passwords/500-worst-passwords.txt</pre><h2 id=h4-basic-cracking>Basic Cracking</h2>You can now test out Hashcat. Take a look at the following command. If you run it, Hashcat will attempt to decipher the hashes that you created. <pre>$ hashcat -m 1700 -a 1 -r /usr/share/hashcat/rules/combinator.rule hashes/hashes.txt passlists/500-worst-passwords.txt</pre> Hashcat will take some time. If you have a slow system, it will take a lot of time. Just be mindful of that. If it's taking too long, reduce the number of hashes in your list. <br><br> In the end, Hashcat should display each of your hashes along with its value. It might not get all of them, depending on which words you used. <h2 id=h5-options>Options</h2>As you have seen, Hashcat relies heavily on different flags and options to work properly. Taking it all in at once can be daunting, so this next section will break it all down. <h3 id=h5-1-hash-types>Hash Types</h3>The first flag that you see there is the <code>-m</code> flag. In the case of the example, it's set to 1700. This is a value in Hashcat that corresponds to SHA-512. To see the full list, run Hashcat's help command, <code>$ hashcat --help</code>. There are a lot there, so you can see why Hashcat has such a wide range of uses. <h3 id=h5-2-attack-modes>Attack Modes</h3>Hashcat is capable of several different attack modes. Each of these modes tests the hashes against your wordlist differently. Attack modes are specified with the <code>-a</code> flag, and take values corresponding to a list available through the help command. The example used a very common option, the combination attack. Combination attacks attempt to re-arrange words and add common numbers in places users typically would. For basic usage, this is generally the best option. <h3 id=h5-3-rules>Rules</h3>There is also a rules file specified with the <code>-r</code> command. The rules files are located at <code>/usr/share/hashcat/rules</code>, and they provide context for how Hashcat could conduct its attacks. You must specify a rules file for many of the attack modes, including the one used in the example. <h3 id=h5-4-output>Output</h3>Though it wasn't used in the example, you can specify an output file for Hashcat. Just add the <code>-o</code> flag followed by the desired location of your output file. Hashcat will save the results of its cracking session as they appear in the terminal in the file. <h2 id=h6-closing-thoughts>Closing Thoughts</h2>Hashcat is an insanely powerful tool, and it scales with the tasks that it is assigned and the hardware that it is running on. Hashcat is designed to handle large scale tasks and work through them in the most efficient way possible. This isn't some hobby tool. It is absolutely professional grade. <br><br> If you're really interested in utilizing Hashcat's full power, it's definitely worth exploring the GPU options available to people with powerful graphics cards. <br><br> Of course, remember to use Hashcat responsibly, and keep your password cracking legal. </div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <center> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4906753266448300 data-ad-slot=3873304447 data-ad-format=link></ins><hr><span class=visible-desktop> <ins class=adsbygoogle style=display:inline-block;width:728px;height:90px data-ad-client=ca-pub-4906753266448300 data-ad-slot=7045095412></ins> </span> <span class=hidden-desktop> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4906753266448300 data-ad-slot=5350037647 data-ad-format=auto></ins> </span> </center><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript rel=nofollow>comments powered by Disqus.</a></noscript></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"> <ins class=adsbygoogle style=display:inline-block;width:300px;height:600px data-ad-client=ca-pub-4906753266448300 data-ad-slot=6488865241></ins><hr style="margin: 3px";><ins class=adsbygoogle style=display:inline-block;width:300px;height:250px data-ad-client=ca-pub-4906753266448300 data-ad-slot=2463982444></ins> </span> <div id=endad style="position: absolute;bottom: 670px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>About</span></h3><div class=g-particle> LinuxConfig.org team is determined to provide you with simple to follow Linux tutorials, various tips, tricks and programming guides as well as with GNU/Linux system administration tutorials in general to help you to learn Linux faster and use it with ease. <br><br>
Any comments, constructive feedback or your <a href=floss-technical-writer-linuxconfig-org><b>involvement</b></a> is welcome. <br><br>
Contact: </div></div><div class="moduletable "><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=/floss-technical-writer-linuxconfig-org>Read More...</a> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Linux Tutorials / Configs</span></h3><div class=g-particle><div class=g-news-pro><div class=uk-slidenav-position data-uk-slideset="{duration: 200, autoplay: 'true', autoplayInterval: 7000, animation: 'fade'}"><div class=uk-slider-container><div class="uk-slideset uk-grid"><div class=g-news-pro-page><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/test-and-recover-your-passwords-by-cracking-them-with-hashcat> Test And Recover Your Passwords By Cracking Them... </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>April 01 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/encrypt-your-email-with-gpg-thunderbird-and-enigmail> Encrypt Your Email With GPG, Thunderbird, and... </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>April 01 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/how-to-securely-transfer-files-with-sftp> How to Securely Transfer Files With SFTP </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 30 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div></div><div class=g-news-pro-page><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/secure-your-ssh-with-passwordless-connection> Secure your SSH with passwordless connection </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 30 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/ansible-installation-on-centos-7-linux> Ansible installation on CentOS 7 Linux </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 27 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/protect-your-online-privacy-with-the-tor-browser-bundle> Protect Your Online Privacy With The Tor Browser... </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 26 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div></div><div class=g-news-pro-page><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/python-inheritance> Python Inheritance </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 26 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>Programming &amp; Scripting </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/ansible-installation-on-debian-9-stretch-linux-from-source> Ansible Installation on Debian 9 Stretch Linux... </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 24 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div><div class="uk-grid uk-grid-width-1-1"><div class="g-news-pro-item horizontal"><div class=g-info-container><h4 class=g-news-pro-title> <a href=/how-to-perform-a-faster-data-compression-with-pbzip2> How to perform a faster data compression with... </a> </h4><div class=g-article-details> <span class=g-article-date> <i class="fa fa-clock-o"></i>March 19 </span> <span class=g-article-category> <i class="fa fa-folder-open"></i>System Administration &amp; Configuration </span> </div></div></div></div></div></div></div></div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>RSS Feeds</span></h3><div class=g-particle> LinuxConfig.org's category RSS list: </div></div><div class="moduletable "><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=19&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>System Administration</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=17&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Programming & Scripting</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=8&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Ubuntu</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=10&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>CentOS</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=13&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Debian</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=15&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Fedora</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=14&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Redhat</span> </a> </div></div></div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2017 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/assets2/jscss.php?f=a75e7db0695c4154a124d88ec8e26f69&type=css&gz=gz&d=1&i=0';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href="/media/plg_jchoptimize/assets2/jscss.php?f=a75e7db0695c4154a124d88ec8e26f69&amp;type=css&amp;gz=gz&amp;d=1&amp;i=0"/></noscript> <script src="/media/plg_jchoptimize/assets2/jscss.php?f=48ccc6983b5f73cb7b786fdc3aa82e9c&amp;type=js&amp;gz=gz&amp;d=1&amp;i=0"></script> </body> </html>