<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/most-common-custom-ssh-configurations-of-the-openssh-server /><meta name=keywords content="ssh config, linux, ssh, server, custom, administration, secure, shell" /><meta name=author content="Egidio Docile" /><meta name=description content="In this tutorial we will see some of the most relevant parameters we can change using the ssh config file
in order to customize the behavior of the sshd daemon.
" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>Most common custom SSH Configurations of the OpenSSH Server - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/8IL00A6ZVvn8kLikKDuxLCbm0rA.js"></script><link href="https://linuxconfig.org/component/search/?Itemid=2632&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style><noscript><style>img[data-jchll=true]{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2632 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=https://bit.ly/2X5D30q rel=nofollow data-uk-tooltip="{pos:'bottom'}">Newsletter </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /> </a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://www.linuxcareers.com/jobs/alert/ alt="Linux Jobs" rel=nofollow target=_blank><img src=/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <img src=/images/new-badge-red-30.png alt="Linux Jobs" width=30 height=30 /> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/most-common-custom-ssh-configurations-of-the-openssh-server method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=2632 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> Most common custom SSH Configurations of the OpenSSH Server </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Egidio Docile</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration</span> </dd><dd class=published> <time datetime=2019-09-05T16:50:58+10:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>05 September 2019	</time> </dd> </dl><div class=article-position> <center><div id=div-gpt-ad-1407836039689-0> </center> </div> </div><div itemprop=articleBody><p>The <code>Openssh</code> set of utilities let us create secure, encrypted connections between machines. In this tutorial we will take a look at some of the most useful options we can use to change the behavior of <code>sshd</code>, the <code>Openssh</code> daemon in order to make your <a href=https://www.linuxcareers.com/jobs/job-search-results/kw-linux-system-administrator/ target=_blank>Linux system administration job</a> easier. <br><br>In this article we assume the existence of an already running and accessible server. If you want to know more about Openssh installation, you can take a look at this article <a href=https://linuxconfig.org/enable-ssh-on-ubuntu-18-04-bionic-beaver-linux>on how to install SSH server on Ubuntu Linux</a>.</p> <strong>In this tutorial you will learn:</strong> <ul> <li>How to customize the behavior of the sshd daemon by manipulating options in the main ssh config file <code>/etc/ssh/sshd_config</code></li> <li>How to change the default port(s) used by the server</li> <li>How to change the address the server listens to</li> <li>How to change the maximum SSH login time</li> <li>How to allow or deny login as root</li> <li>How to change the max login attempts and maximum number of session opened</li> <li>How to display a message when user tries to authenticate to the server</li> <li>How to Enable/Disable password and pubkey authentication</li> <li>How to Enable/Disable HostBasedAuthentication</li> <li>Enabling/Disabling X11 Forwarding</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/openssh_logo.png?5d70b062 data-lightbox-type=image data-uk-lightbox="{group:'group1'}" title="Openssh logo"> <img src=/images/openssh_logo.png?5d70b062 alt=openssh-logo width=634 height=309 /> </a> </div></div><h2>Software Requirements and Conventions Used</h2><table class="uk-table uk-table-strIPed uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption> <thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Distribution-independent</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>No additional software is required to follow this tutorial apart from Openssh</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>A running Openssh server</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td> <b>#</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</br> <b>$</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed as a regular non-privileged user<br> </td> </tr> </tbody> </table><h2>The sshd daemon config file</h2><p>By default <code>sshd</code>, the <code>Openssh</code> daemon, reads its configuration from the <code>/etc/ssh/sshd_config</code> file. A different file path can be specified by using the <code>-f</code> option when launching the daemon. There are many options we can change to alter the behavior of the daemon. While it's not possible to mention all of them here, we will see some of the most commonly used ones and what we can obtain by changing their values. Every time an option is changed, to make the changes effective the daemon should be restarted. When using systemd, the command to run is:</p><pre>$ sudo systemctl restart sshd</pre><h2>Changing the port(s) used by the server</h2><p>This is what is called a <code>security through obscurity</code> measure: by default the <code>sshd</code> daemon listens on port <code>22</code>. Changing the port in use does not improve the security per se, since it is trivial to make a port scan and see what ports are in use by a machine. More than often, however, brute force login attempts just targets the default port, so modifying the port in use can help. To instruct the daemon to listen to a specific port, we use the <code>Port</code> option and provide the port number:</p><pre>Port 1024</pre><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to Linux Career <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><p>Multiple occurrences of the option can be provided: the server will listen on all the specified ports. Before restarting the ssh server to make the change effective,  it's really important to modify the firewall rules accordingly to the change. On the client side, to connect using a specific port, we must specify the port number by using the <code>-p</code> option (short for --port). For example, to login using port 1024 we would write:</p><pre>$ ssh -p 1024 egdoc@feanor </pre><p>To avoid having to specify the port each time we connect to the server, we can setup an entry for it in the <code>~/.ssh/config</code> file (we may have to create it, since it doesn't exist by default and we must make it accessible only by the user), as in the example below:</p><pre><code>Host feanor
    HostName 192.168.0.39
    Port 1024</code></pre><p>This way, each time we will try to ssh into a matching <code>Host</code> (feanor in this case) the parameters specified in the related stanza of the ssh config file will be applied automatically.</p><h2>Changing the address the server listens to</h2><p>In addition to the port the <code>sshd</code> daemon listens to, we can also change the <code>listen address</code>. By default the server listens on all local addresses. Examples of the syntax to use with this option can already be found in the ssh configuration file:</p><pre><code>#ListenAddress 0.0.0.0
#ListenAddress ::</code></pre><p>We can specify the address in one of the following ways:</p><ul> <li>host|IPv4 address|IPv6 address</li> <li>host|IPv4 address:port</li> <li>host|IPv6 address:port</li> </ul><p>The option to use is called <code>ListenAddress</code> Multiple occurrences of the options are permitted, in order to specify multiple addresses. We can use <code>IPv4</code> or <code>IPv6</code> address, and optionally specify the port to be used. If we don't specify a port the <code>sshd</code> daemon will listen on the port(s) specified with the <code>Port</code> option we saw above.</p><h2>Changing the maximum login time</h2><p>We can configure the <code>Openssh</code> daemon to disconnect after a specified amount of time if the user does not successfully log in. In this case the option we want to change is called <code>LoginGracetime</code>. All we have to do is to provide the time limit value, for example:</p><pre>LoginGracetime 2<em>m</em></pre><p>The default value for this option is <code>120s</code> (seconds)</p><h2>Allow or deny login as root</h2><p>By using the <code>PermitRootLogin</code> option we can establish if the <code>sshd</code> daemon should allow the root user to login directly. The option accepts one of these values:</p><ul> <li>yes</li> <li>no</li> <li>prohibit-password</li> <li>forced-commands-only</li> </ul><p>The first two values are pretty self-explanatory. When using <code>yes</code> the root user is allowed to login via ssh, when using <code>no</code> this possibility is denied. The <code>prohibit-password</code> and <code>forced-commands-only</code> values are more interesting. <br><br>When the former is used as the value of the <code>PermitRootLogin</code> option, password and keyboard interactive logins are disabled, but the root user can login using a <code>public key</code>. If <code>forced-commands-only</code> is used, instead, root login via public key authentication is allowed but only if a <code>command</code> option is specified in the authorized key. For example:</p><pre>command="ls -a" ssh-rsa [...]</pre><div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><p>Above we specified <code>ls -a</code> as the command for the ssh key that will be used by root. This way when connecting using the key, the command will be executed, and then the connection to the server will be closed. Let's verify it (here I assumed the key is already in place on the client and has been authorized on the server):</p><pre><code>$ ssh root@feanor
Enter passphrase for key '/home/egdoc/.ssh/id_rsa':
.  ..  .bash_history  .bashrc  .profile  .ssh  .vim  .viminfo
Connection to feanor closed.</code></pre><h2>Changing the max login attempts and maximum number of session opened</h2><p>Another two parameters we may want to change is the number of attempted login per connection, and the number of  opened shells, login or subsystem session allowed. We can change the former parameter by using the <code>MaxAuthTries</code> option, providing the number of allowed attempts (default value is <code>6</code>). The  latter, instead, can be  modified by using the <code>MaxSessions</code> option. This option also takes an integer value, the default being <code>10</code>.</p><h2>Display a message when user tries to authenticate to the server</h2><p>We can use the <code>Banner</code> option to specify a file containing some text we want to send to the user before he authenticates to the server. The default value for the option is <code>none</code>, so no banner is displayed. Here is an example. The /etc/ssh/banner file we created contains some text we use as a message. If we set the option as below:</p><pre>Banner /etc/ssh/banner.txt</pre><p>When we try to login we get the following result:</p><pre><code>$ ssh egdoc@feanor
###############################
#         Test Banner         #
###############################
egdoc@feanor's password:
</code></pre><h2>Enabling/Disabling password and pubkey authentication.</h2><p>The <code>sshd</code> daemon provides multiple way to authenticate users. We can choose to enable or disable authentication by password or by public key using respectively the <code>PasswordAuthentication</code> and <code>PubkeyAuthentication</code> options. By default both options are usually set to <code>yes</code>: this means that the user can connect to the server by providing his password and also by using a public key he owns (the key can also be protected by a password). To disable one of the two options we simply use <code>no</code> as a value. For example, if only want to allow login by public keys we can set:</p><pre>PasswordAuthentication no</pre><p>This way only users who have a<code> public key</code> contained in the authorized keys file will be able to login in to the server. The authorized keys file is the file which contains the allowed public keys. By default the file is <code>.ssh/authorized_keys</code> in the home directory of the user on the server, but this can be changed using the <code>AuthorizedKeysFile</code> option and specifying an alternative file, providing either an <code>absolute</code> or a <code>relative</code> path. When a relative path is used, it is considered as relative to users home directory. The option can also be set to <code>none</code>: this way the server will not search for public keys in files.</p><h2>Enabling/Disabling HostBasedAuthentication</h2><p>The Openssh server can be set to accept <code>host-based</code> authentication. When using this type of authentication an host authenticates on behalf of all or some of its users. The option is set to <code>no</code> by default. Setting the option to <code>yes</code> is not enough to make host-based authentication work.</p><h2>Enabling/Disabling X11 Forwarding</h2><p>The <code>X11</code> window system has a client-server architecture: the clients are the many graphical applications requesting connection to the server which manages displays. The X11 server and its clients often run on the same machine, but this it's not necessary. It's possible to access a remote X11 server via a dedicated but unsecure protocol. <code>Openssh</code> let us run the connection securely, creating an encrypted tunnel. The option that controls this behavior is <code>X11Forwarding</code>. The feature is generally disabled by default, so it is set to <code>no</code>.<br><br> We must set the option to <code>yes</code> if we want to take advantage of it. On the client side, we enable the feature by using the <code>-X</code> option from the command line, or set <code>ForwardX11</code> to <code>yes</code> in the client configuration file. For example, say we have X11 running on the remote machine; we want to use the ssh connection to launch the "pluma" application (a lightweight text editor) and control it using X11Forwarding. We run:</p><pre>$ ssh egdoc@feanor -X pluma</pre><div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><p>The program will be launched. In the title bar, clearly we can see that it is running on "feanor", which is the name of the remote machine.</p><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/x11_forwarded_app.png?5d70b062 data-lightbox-type=image data-uk-lightbox="{group:'group1'}" title="X11 forwarded app"> <img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/x11_forwarded_app.png?5d70b062 data-jchll=true alt=x11-forwarded-app width=644 height=534 /><noscript><img src=/images/x11_forwarded_app.png?5d70b062 alt=x11-forwarded-app width=644 height=534 /></noscript></a> <div class=uk-thumbnail-caption>X11 forwarding in action</div></div></div><h2>Conclusion</h2><p>In this tutorial we saw what is the default <code>sshd</code> daemon configuration file and we learned how we can use an alternative one by specifying its path with the <code>-f</code> option when starting the service. We also took a look at some of the most useful options we can use in said file to change the behavior of sshd. We saw how to allow or deny password-based and public-key based authentications; how to enable or deny root login; how to enable or disable the X11 forwarding feature and how to make the server display a message when a user tries to authenticate on it.<br><br> We also saw how to specifiy the maximum allowed login attempts per connection and how to change the addresses and ports the server listens to. To know more about the possible server configurations, please consult the manual page for sshd and for the sshd_config configuration file.</p></div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>ARE YOU LOOKING FOR A LINUX JOB?</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed on LinuxCareers.com.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/saving-an-output-of-postgresql-query-to-a-text-file> Saving an output of PostgreSQL query to a text file </a> </li> <li> <a href=/install-nagios-on-ubuntu-18-04-bionic-beaver-linux> Install Nagios on Ubuntu 18.04 Bionic Beaver Linux </a> </li> <li> <a href=/how-to-change-system-language-on-ubuntu-18-04-bionic-beaver-linux> How to change system language on Ubuntu 18.04 Bionic Beaver Linux </a> </li> <li> <a href=/how-to-change-password-on-ubuntu-18-04-bionic-beaver-linux> How to change password on Ubuntu 18.04 Bionic Beaver Linux </a> </li> </ul> </div> </div></div><div class=platform-content><div class="moduletable "><div class=custom><h3 class=g-title><span>You may also be interested in:</span></h3><center> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-4906753266448300 data-ad-slot=5538448164></ins><hr><div id=div-gpt-ad-1407836042106-0> </div> </center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/linuxconfig-forum-logo.png data-jchll=true < img width=250 height=46 /><noscript><img src=/images/linuxconfig-forum-logo.png </img width=250 height=46 /></noscript></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div id=div-gpt-ad-1407836095114-0> </div><hr style="margin: 3px" ;><div id=div-gpt-ad-1407836250753-0> </div> </span> <div id=endad style="position: absolute;bottom: 1150px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=/media/plg_jchoptimize/cache/js/dcb27981c450384602052f629c81ea78_0.js></script> <script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/how-to-install-apache-tomcat-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install apache tomcat on Linux RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/installing-apache-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install Apache on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/install-ssh-server-on-redhat-8 itemprop=url> <span itemprop=name>Install ssh server on CentOS 8 / RHEL 8</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li> <a href=/how-to-install-puppet-on-redhat-8 itemprop=url> <span itemprop=name>How to Install Puppet on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/most-common-custom-ssh-configurations-of-the-openssh-server itemprop=url> <span itemprop=name> Most common custom SSH Configurations of the OpenSSH Server </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/install-and-configure-mysql-workbench-on-ubuntu-linux itemprop=url> <span itemprop=name> Install and Configure MySQL Workbench on Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-debug-bash-scripts itemprop=url> <span itemprop=name> How to Debug Bash Scripts </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-stream-video-from-vlc itemprop=url> <span itemprop=name> How to Stream Video From VLC </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-save-space-with-symlinks-and-mount-points itemprop=url> <span itemprop=name> How to Save Space with Symlinks and Mount Points </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-dd-command-works-in-linux-with-examples itemprop=url> <span itemprop=name> How dd command works in Linux with examples </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/introduction-to-mysql-mariadb-database-sql-views itemprop=url> <span itemprop=name> Introduction to MySQL/MariaDB database SQL views </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/executing-commands-on-a-remote-machine-from-java-with-jsch itemprop=url> <span itemprop=name> Executing commands on a remote machine from Java with JSch </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/boot-systems-into-different-targets-manually-rhcsa-objective-preparation itemprop=url> <span itemprop=name> Boot systems into different targets manually - RHCSA Objective Preparation </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/log-in-and-switch-users-in-multiuser-targets-rhcsa-objective-preparation itemprop=url> <span itemprop=name> Log in and switch users in multiuser targets - RHCSA Objective Preparation </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/raspbian-gnu-linux-upgrade-from-stretch-to-raspbian-buster-10 itemprop=url> <span itemprop=name> Raspbian GNU/Linux upgrade from Stretch to Raspbian Buster 10 </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-perform-web-requests-with-php-using-the-curl-extension itemprop=url> <span itemprop=name> How to perform web requests with PHP using the cURL extension </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-netflix-in-kodi-on-ubuntu-and-debian itemprop=url> <span itemprop=name> How to Install Netflix in Kodi on Ubuntu and Debian </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/create-hard-and-soft-links-rhcsa-exam-preparation itemprop=url> <span itemprop=name> Create hard and soft links - RHCSA Exam Preparation </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/study-objectives-for-the-rhcsa-exam-preparation-guide itemprop=url> <span itemprop=name> Study Objectives for the RHCSA Exam & Preparation Guide </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2019 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/cache/css/cbe69742ed9aea12a23dbad68fa54835_0.css';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href=/media/plg_jchoptimize/cache/css/cbe69742ed9aea12a23dbad68fa54835_0.css /></noscript> <script src=/media/plg_jchoptimize/cache/js/dcb27981c450384602052f629c81ea78_1.js></script> </body> </html>