Linux System Administration

Install prerequisites

jdownloader is a great tool to download file from share websites like rapidshare.com and many more. Here are simple steps on how to install jdownloader on Ubuntu or Debian Linux distributions:
First install all prerequisites:

apt-get install openjdk-6-jre sun-java6-jre default-jre \
zenity default-jre-headles sun-java6-bin \
openjdk-6-jre-headless

for jdownloader to work correctly you must have java installed otherwise you get a following error message:

Exception in thread "main" java.lang.NoClassDefFoundError:
jd.update.Main   at java.lang.Class.initializeClass
(libgcj.so.90)Caused by: java.lang.ClassNotFoundException:
com.sun.java.swing.plaf.windows.WindowsLookAndFeel
 not found in gnu.gcj.runtime.SystemClassLoader
{urls=[file:jdupdate.jar], parent=gnu.gcj.runtime.
ExtensionClassLoader{urls=[], parent=null}}   
at java.net.URLClassLoader.findClass(libgcj.so.90)
gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.90)
java.lang.ClassLoader.loadClass(libgcj.so.90) at java.lang.
ClassLoader.loadClass(libgcj.so.90)  at java.lang.
Class.forName(libgcj.so.90)at java.lang.Class.
initializeClass(libgcj.so.90)

Install Linux jdownloader

Next download jdownloader package from https://launchpad.net/~jd-team/+archive/jdownloader and install jdownloader all.deb package:

dpkg -i jdownloader_0.1-0jd1~lucid1_all.deb

During the installation you should not see any errors such us:

dpkg: dependency problems prevent configuration of jdownloader

Run Linux jdownloader

If you get dependencies errors install all depended packages. Once ready start jdownloader:

$ jdownloader

Wait for an update and you are done !

Installing this plugin on any Linux system should be a easy task. First download google-talkplugin_current_i386.deb package. On a Ubuntu system use:

sudo dpkg -i google-talkplugin_current_i386.deb 

on a system where sudo is not present by default first change to root:

su

and then enter:

dpkg - i google-talkplugin_current_i386.deb

To install a google talk plugin. In case that you get a following error message:

dpkg: dependency problems prevent configuration of google-talkplugin:
 google-talkplugin depends on libglew1.5 (>= 1.5.0dfsg1); however:
  Package libglew1.5 is not installed.
dpkg: error processing google-talkplugin (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 google-talkplugin

fix it with:

# apt-get install -f

No enter your gmail amount and google talk should be ready.

Introduction

This article describes installation and usage of Google Chrome web browser in conjunction with Ubuntu Linux. The article also touches on some privacy concerns in regard to Google Chrome and its restrictive license. Although, Google Chrome web browser is a multi-platform application this article will be focused solely on Google Chrome and i386 Ubuntu Linux.

What is Google Chrome

In short, a Google Chrome is a Internet web browser developed by Google, Inc .. Google Chrome is based on an open source project Chromium. On 2nd September 2008 Google chrome was released for a MS Windows operating system only and later further binaries were compiled for MAC OS as well as for Linux operating system. There are multiple privacy concerns when it comes to a Google Chrome browser such as what data are collected during the Internet browsing and using omnibox to search the Internet.

Google Chrome Privacy Concerns

Google Chrome's source code is free software but binaries which a Google chrome is distributed with are under restrictive BSD license.When it comes to a Linux operating system a Google Chrome browser comes in the form of a pre-compiled DEB or RPM packages. Installation of Google Chrome from a DEB or RPM packages requires a root password which is used to modify some crucial system configuration files such as an apt repository list as it is in case of the Ubuntu Linux System. Installation of Google Chrome browser on the Ubuntu Linux operating system also involves an injection of Google, Inc. Linux Package Signing Key into an apt key ring which gives Google a chance to install virtually anything into user's Linux operating system via google-chrome-stable package since no additional involvement by system administrator when updating this package is required. However, as shown later in this article a system administrator has an option to black list Google Chrome package from automatic updates. Surely, when it comes to a privacy Google Chrome is no match to GNU IceCat web browser.

Google Chrome browser Logo

Richard Stallman: ( Founder of a GNU Project )

This is an opinion of Richard Stallman on privacy dangers when using Google Chrome:


The license for those binaries is unacceptable for several reasons.

For instance, it says you give Google the right to change your software and requires you to accept whatever changes they decide to impose. It purports to forbid reverse engineering.

It also uses the confusing and biased propaganda term "intellectual property".

You should not agree to those terms.

Download Google Chrome for Ubuntu Linux

You can navigate to a google website, accept Google Chrome's Terms of Service to download Google Chrome Browser binary or simply download it by using wget and the link below to fetch pre-compiled "deb" package from a google mirror.

Download link for a Google Chrome stable i386 architecture:

ubuntu-chrome ~$ wget https://dl-ssl.google.com/linux/direct/google-chrome-stable_current_i386.deb

Download link for a Google Chrome stable amd64 architecture:

ubuntu-chrome ~$ wget https://dl-ssl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

Installation of Google Chrome on Ubuntu Linux

Once you have downloaded a Google chrome pre-compiled binary Deb package all what needs to be done to install it on your Ubuntu Linux is to navigate to your download directory and execute dpkg -i command and supply a Google Chrome's package name as an argument. All Google Chrome prerequisites should be already installed with your default Ubuntu installation.

Read more ...

Page 65 of 72



Free Linux eBooks

Go to top