<!DOCTYPE html><html lang=en-gb dir=ltr><head><script src="/cdn-cgi/apps/head/bXa8n0uUCb2a0SzvaCENH28oqao.js"></script><link rel=preconnect href=https://fonts.gstatic.com crossorigin /><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/linux-reset-password-expiration-age-and-history /><meta name=keywords content="linux, reset, password, expiration, age, history, manage, command, example" /><meta name=author content="Korbin Brown" /><meta name=description content="In this tutorial, we show various command line examples that Linux administrators can use to manage user passwords, including their expiration length, age, and viewing a history of password changes." /><meta name=generator content="Joomla! - Open Source Content Management" /><title>Linux - Reset password expiration, age and history - LinuxConfig.org</title><link href="https://linuxconfig.org/component/search/?Itemid=3349&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--> <script src=/media/plg_jchoptimize/cache/js/7598340cc594fdd954e07cf373904da4.js></script> <script async src=https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js></script><link rel=preload as=style href="//fonts.googleapis.com/css?family=Open Sans:300,300italic,600,600italic,700,700italic,400,400italic&display=swap" onload="this.onload=null;this.rel='stylesheet'" /><style>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</style> <script>function onUserInteract(callback){window.addEventListener('load',function(){if(window.pageYOffset!==0){callback()}});window.addEventListener('scroll',function(){callback()});document.addEventListener('DOMContentLoaded',function(){let b=document.getElementsByTagName('body')[0];b.addEventListener('mouseenter',function(){callback()});});}</script><script>(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){};}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload");}catch(e){ret=false;}
return function(){return ret;};})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener){link.removeEventListener("load",enableStylesheet);}else if(link.attachEvent){link.detachEvent("onload",enableStylesheet);}
link.setAttribute("onload",null);link.media=finalMedia;}
if(link.addEventListener){link.addEventListener("load",enableStylesheet);}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet);}
setTimeout(function(){link.rel="stylesheet";link.media="only x";});setTimeout(enableStylesheet,3000);};rp.poly=function(){if(rp.support()){return;}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",true);rp.bindMediaToggle(link);}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run);});}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run);});}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS;}
else{w.loadCSS=loadCSS;}}(typeof global!=="undefined"?global:this));</script><script>let loaded=false;onUserInteract(function(){var css_urls=["\/media\/plg_jchoptimize\/cache\/css\/760ba5ebd8545f7b3767a6874e093b9e.css"];if(!loaded){css_urls.forEach(function(url,index){let l=document.createElement('link');l.rel='stylesheet';l.href=url;let h=document.getElementsByTagName('head')[0];h.append(l);});loaded=true;}});</script><noscript><link rel=stylesheet href=/media/plg_jchoptimize/cache/css/760ba5ebd8545f7b3767a6874e093b9e.css /></noscript><noscript><style>img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-3349 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2944  "> <a class=g-menu-item-container href=/ubuntu-20-04-guide> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 20.04</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS / AlmaLinux</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a href=https://bit.ly/2X5D30q rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Newsletter </a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="noreferrer noopener nofollow"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /> </a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://bit.ly/linux-job-alert alt="Linux Jobs" rel="noreferrer noopener nofollow" target=_blank><img class=jch-lazyload src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NjgiIGhlaWdodD0iNjAiPjwvc3ZnPg==" data-src=/images/banners/linuxcareers-get-alert_optim.png alt="Linux Jobs - Linuxcareers.com" width=468 height=60 /><noscript><img src=/images/banners/linuxcareers-get-alert_optim.png alt="Linux Jobs - Linuxcareers.com" width=468 height=60 /></noscript></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Guides</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2988 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Admin</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2997 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-3001 g-standard  "> <a class=g-menu-item-container href=/multimedia-games> <span class=g-menu-item-content> <span class=g-menu-item-title>Multimedia</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/linux-reset-password-expiration-age-and-history method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=3349 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> Linux - Reset password expiration, age and history </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Korbin Brown</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration</span> </dd><dd class=modified> <time datetime=2021-05-14T12:18:49+10:00 itemprop=dateModified data-uk-tooltip title="Modified Date"> <i class="fa fa-clock-o"></i>14 May 2021	</time> </dd> </dl><div data-fuse=22189504503 class=incontent_ads></div></div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/linux-reset-password-expiration-age-and-history#h1-set-a-user-s-password-to-expire class='toclink toclink-h1'>1.&nbsp;Set a user's password to expire</a></li><li><a href=https://linuxconfig.org/linux-reset-password-expiration-age-and-history#h2-see-the-age-of-a-user-s-password class='toclink toclink-h1'>2.&nbsp;See the age of a user's password</a></li><li><a href=https://linuxconfig.org/linux-reset-password-expiration-age-and-history#h3-see-password-changes-in-log-files class='toclink toclink-h1'>3.&nbsp;See password changes in log files</a></li><li><a href=https://linuxconfig.org/linux-reset-password-expiration-age-and-history#h4-closing-thoughts class='toclink toclink-h1'>4.&nbsp;Closing Thoughts</a></li></ul></li></ul></div><div itemprop=articleBody><p>User management is an important part of Linux administration, so it's essential to know about all the user accounts on a <a href=/linux-download target=_blank>Linux system</a>. Some common user administration tasks are to <a href=/how-to-list-users-on-linux target=_blank>list users</a>, <a href=/how-to-disable-user-accounts-in-linux target=_blank>disable a user account</a>, or <a href=/how-to-create-modify-and-delete-users-account-on-linux target=_blank>create and modify user accounts</a>.</p><p>In this guide, we will be focusing on managing user passwords. It's good security practice to force users to change their password every once in a while by setting passwords to expire. In the examples below, you'll see how to reset a user's password, set their password to expire (either instantly or in the future), and see the age of a user's password. We'll also see how password changes can be seen in log files, giving us some insight into user's password change history.</p> <strong>In this tutorial you will learn:</strong> <ul> <li>How to set a user's password to expire</li> <li>How to see the age of a user's password</li> <li>How to see password changes in log files</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/03-linux-reset-password-expiration-age-and-history.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Password expiration and history information on Linux"><img class=jch-lazyload src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzY4IiBoZWlnaHQ9Ijc4MCI+PC9zdmc+ data-src=/images/03-linux-reset-password-expiration-age-and-history.png alt="Password expiration and history information on Linux" width=1368 height=780 /><noscript><img src=/images/03-linux-reset-password-expiration-age-and-history.png alt="Password expiration and history information on Linux" width=1368 height=780 /></noscript></a> <div class=uk-thumbnail-caption>Password expiration and history information on Linux</div></div></div><table class="uk-table uk-table-striped uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption> <thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td>System</td> <td>Any <a href=/linux-download target=_blank>Linux distro</a></td> </tr> <tr> <td>Software</td> <td>N/A</td> </tr> <tr> <td>Other</td> <td>Privileged access to your Linux system as root or via the <code>sudo</code> command.</td> </tr> <tr> <td>Conventions</td> <td> <b>#</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</br> <b>$</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed as a regular non-privileged user<br> </td> </tr> </tbody> </table><h2 id=h1-set-a-user-s-password-to-expire>Set a user's password to expire</h2><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to our <a href=https://bit.ly/2X5D30q target=_blank rel="noreferrer noopener nofollow">NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><div data-fuse=22189504506 class=incontent_ads></div><hr></div></div><p>As the root user, you can set a user's password to expire by executing the <code>passwd -e</code> command. The following example will expire the password for user "linuxconfig". Doing this will prompt the user to change their password the next time they try to login to the system.</p><pre>
$ sudo passwd -e linuxconfig
</pre><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/01-linux-reset-password-expiration-age-and-history.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Forcing a user password to expire with the passwd -e command"><img class=jch-lazyload src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzYxIiBoZWlnaHQ9Ijc2OSI+PC9zdmc+ data-src=/images/01-linux-reset-password-expiration-age-and-history.png alt="Forcing a user password to expire with the passwd -e command" width=1361 height=769 /><noscript><img src=/images/01-linux-reset-password-expiration-age-and-history.png alt="Forcing a user password to expire with the passwd -e command" width=1361 height=769 /></noscript></a> <div class=uk-thumbnail-caption>Forcing a user password to expire with the passwd -e command</div></div></div><p>This will force the user to choose a <b>new</b> password. When we try to go back to our old password, you can see the "Password unchanged" error that we receive in the screenshot below.</p><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/02-linux-reset-password-expiration-age-and-history.png data-lightbox-type=image data-uk-lightbox={group:group1} title="The error we receive when trying to re-use an old password"><img class=jch-lazyload src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzYwIiBoZWlnaHQ9Ijc3MCI+PC9zdmc+ data-src=/images/02-linux-reset-password-expiration-age-and-history.png alt="The error we receive when trying to re-use an old password" width=1360 height=770 /><noscript><img src=/images/02-linux-reset-password-expiration-age-and-history.png alt="The error we receive when trying to re-use an old password" width=1360 height=770 /></noscript></a> <div class=uk-thumbnail-caption>The error we receive when trying to re-use an old password</div></div></div><p>If you don't want the user's password to expire right away (that is, as soon as the command above is executed), then we can use the <code>chage</code> command. Notice this command looks a lot like the word "change," but be aware it's not a typo and it really is <code>chage</code> without the "n."</p><div class=moduletable><div class=custom><hr><div data-fuse=22189504224 class=incontent_ads></div><hr></div></div><p>Add the <code>-M</code> option to your command, and specify the length of time, in days, when a user's password should expire. The following example will make user "linuxconfig" password expire 30 days from now.</p><pre>
$ sudo chage -M 30 linuxconfig
</pre><p>We can also choose a day for the password to expire by using the <code>-E</code> option and specifying the date in a <code>YYYY-MM-DD</code> format. This command will force a user's password to expire on January 15, 2023.</p><pre>
$ sudo chage -E 2023-01-15 linuxconfig
</pre><p>Use the <code>-W</code> option to warn a user that their password will soon expire. For example, this command will warn a user 7 days in advance that their password is going to expire.</p><pre>
$ sudo chage -W 7 linuxconfig
</pre><h2 id=h2-see-the-age-of-a-user-s-password>See the age of a user's password</h2><p>We can once again turn to the <code>chage</code> command when we wish to see information about the age of a user's password. The <code>-l</code> option will list when a user's password was last change, and when their password is set to expire.</p><pre>
$ chage -l linuxconfig
</pre><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/03-linux-reset-password-expiration-age-and-history.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Seeing when the password was last changed and future expiration information"><img class=jch-lazyload src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzY4IiBoZWlnaHQ9Ijc4MCI+PC9zdmc+ data-src=/images/03-linux-reset-password-expiration-age-and-history.png alt="Seeing when the password was last changed and future expiration information" width=1368 height=780 /><noscript><img src=/images/03-linux-reset-password-expiration-age-and-history.png alt="Seeing when the password was last changed and future expiration information" width=1368 height=780 /></noscript></a> <div class=uk-thumbnail-caption>Seeing when the password was last changed and future expiration information</div></div></div><h2 id=h3-see-password-changes-in-log-files>See password changes in log files</h2><div class=moduletable><div class=custom><hr><div data-fuse=22189504509 class=incontent_ads></div><hr></div></div><p>Linux logs a lot of data, and password changes are no exception. Debian based systems such as Ubuntu will store password changes in the <code>/var/log/auth.log</code> file, and Red Hat based systems store this information in <code>/var/log/secure</code>. Use the following grep command to take a peek into the appropriate file.</p><pre>
$ grep -R -i passwd /var/log/auth.log
</pre><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/04-linux-reset-password-expiration-age-and-history.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Viewing password changes in the log file"><img class=jch-lazyload src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzY3IiBoZWlnaHQ9Ijc3NCI+PC9zdmc+ data-src=/images/04-linux-reset-password-expiration-age-and-history.png alt="Viewing password changes in the log file" width=1367 height=774 /><noscript><img src=/images/04-linux-reset-password-expiration-age-and-history.png alt="Viewing password changes in the log file" width=1367 height=774 /></noscript></a> <div class=uk-thumbnail-caption>Viewing password changes in the log file</div></div></div><p>As you can see in the screenshot above, the log shows us when our "linuxconfig" user account had their password set to expire, and it also shows when the user's password was changed.</p><h2 id=h4-closing-thoughts>Closing Thoughts</h2><p>In this guide, we saw how to manage user account passwords on Linux by forcing a password to expire, setting it to expire in the future, seeing when the password was last changed, and viewing logs to see password changes. These should be all the commands you need to know in order to manage user account passwords and keep your system secure through regularly expiring passwords.</p></div><ul class="pager pagenav"> <li class=previous> <a class=hasTooltip title="How to remove all docker containers using a single command" aria-label="Previous article: How to remove all docker containers using a single command" href=/how-to-remove-all-docker-containers-using-a-single-command rel=prev> <span class=icon-chevron-left aria-hidden=true></span> <span aria-hidden=true>Prev</span> </a> </li> <li class=next> <a class=hasTooltip title="Linux Add User To Group" aria-label="Next article: Linux Add User To Group" href=/linux-add-user-to-group rel=next> <span aria-hidden=true>Next</span> <span class=icon-chevron-right aria-hidden=true></span> </a> </li> </ul> </article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>FIND LATEST <a href=https://www.linuxcareers.com/ target=_blank rel="noreferrer noopener nofollow">LINUX JOBS</a> on LinuxCareers.com</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel="noreferrer noopener nofollow">RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel="noreferrer noopener nofollow">JOB ALERT</a>.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel="noreferrer noopener nofollow">NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank rel="noreferrer noopener nofollow">LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/batch-image-resize-using-linux-command-line> Batch image resize using Linux command line </a> </li> <li> <a href=/command-line-programs-for-everyday-use-in-linux> Command-line programs for everyday use in Linux </a> </li> <li> <a href=/how-to-check-linux-version> How to check Linux Version </a> </li> <li> <a href=/hung-linux-system-how-to-escape-to-the-command-line-and-more> Hung Linux System? How to Escape to the Command Line and More </a> </li> </ul> </div> </div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><hr><center><div data-fuse=22198552927></div></center></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div data-fuse=22189504221 class=sticky_ads></div><hr style="margin: 3px" ;><div data-fuse=22189277162></div></span> <div id=endad style="position: absolute;bottom: 1120px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <a href=https://bit.ly/2X5D30q rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Linux Career Newsletter </a> to receive latest news, jobs, career advice and featured configuration tutorials. </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/ubuntu-20-04-download itemprop=url> <span itemprop=name>Ubuntu 20.04 Download </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade Ubuntu To 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/ubuntu-20-04-guide itemprop=url> <span itemprop=name>Ubuntu 20.04 Guide</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/linux-download itemprop=url> <span itemprop=name>Linux Download</span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-connect-to-docker-container-via-ssh itemprop=url> <span itemprop=name> How to connect to Docker container via ssh </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/linux-dns-server-bind-configuration itemprop=url> <span itemprop=name> Linux DNS server BIND configuration </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-share-data-between-a-docker-container-and-host-system-using-volumes itemprop=url> <span itemprop=name> How to share data between a Docker container and host system using volumes </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/creating-a-redhat-package-repository itemprop=url> <span itemprop=name> Creating a Redhat package repository </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/linux-commands-to-backup-and-restore-mysql-database itemprop=url> <span itemprop=name> Linux commands to back up and restore MySQL database </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/docker-container-backup-and-recovery itemprop=url> <span itemprop=name> Docker container: Backup and Restore </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/collection-of-basic-linux-firewall-iptables-rules itemprop=url> <span itemprop=name> Collection of basic Linux Firewall iptables rules </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-take-screenshots-using-maim-on-linux itemprop=url> <span itemprop=name> How to take screenshots using maim on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-edit-a-system-file-with-sudoedit-preserving-the-invoking-user-environment itemprop=url> <span itemprop=name> How to edit a system file with sudoedit preserving the invoking user environment </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-configure-nfs-on-linux itemprop=url> <span itemprop=name> How to configure NFS on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/basic-example-on-how-to-link-docker-containers itemprop=url> <span itemprop=name> Basic networking example on how to connect docker containers </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-manage-dynamic-virtual-hosts-with-apache-and-the-mod-vhost-alias-module itemprop=url> <span itemprop=name> How to manage dynamic virtual hosts with Apache and the mod_vhost_alias module </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/get-started-with-android-application-development-using-linux-and-android-sdk itemprop=url> <span itemprop=name> Get Started with Android application development using Linux and Android SDK </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-mount-partition-with-ntfs-file-system-and-read-write-access itemprop=url> <span itemprop=name> How to mount partition with ntfs file system and read write access </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2021 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/plg_jchoptimize/cache/js/844e2d9ed284edae2ae825346e72cbb8.js></script> <script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"65776761fee35c6b","token":"1637300d8a394c64a4b8ffff41ff1ca8","version":"2021.5.2","si":10}'></script>
</body> </html>