<!DOCTYPE html><html lang="en-gb" dir="ltr"><head><meta name="viewport" content="width=device-width, initial-scale=1.0"><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charset="utf-8"/><base href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative"/><meta name="keywords" content="skype, alternative, ring, chat, video, audio, free, voip, open source"/><meta name="author" content="Nick Congleton"/><meta name="description" content="Ring is the FOSS alternative Skype that you've been waiting for.  Install it on Debian distros and Fedora."/><meta name="generator" content="Joomla! - Open Source Content Management"/><title>Install Ring, a FOSS VOIP Skype alternative - LinuxConfig.org</title><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><script src="/cdn-cgi/apps/head/w2kCPzPnVci3NgUFGIa4bZv6Ess.js"></script><style>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</style> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2010 outline-25 g-offcanvas-left g-default g-style-preset5"><div id="g-offcanvas" data-g-offcanvas-swipe="0" data-g-offcanvas-css3="1"><div class="g-grid"><div class="g-block size-100"><div class="g-content g-particle"><div id="g-mobilemenu-container" data-g-menu-breakpoint="60rem"></div></div></div></div></div><div id="g-page-surround"><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id="g-container-site" class="g-wrapper"><div class="g-container"><section id="g-top"><div class="g-grid"><div class="g-block size-60"><div class="g-content"><div class="moduletable "><div class="g-particle"> <nav class="g-main-nav" role="navigation" data-g-hover-expand="true"><ul class="g-toplevel"> <li class="g-menu-item g-menu-item-type-component g-menu-item-498 g-standard  "> <a class="g-menu-item-container jsn-icon-contact" href="/contact-us"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Contact us</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1577 g-standard  "> <a class="g-menu-item-container" href="/write-for-us"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Write For Us</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class="g-content"><div class="moduletable "><div class="g-particle"><div class="g-social"> <a target="_blank" href="https://twitter.com/linuxconfig" data-uk-tooltip="{pos:'bottom'}" rel="nofollow"> <span class="fa fa-twitter fa-fw"></span> <span class="g-social-text"> Twitter</span> </a> <a href="#rss" data-uk-tooltip="{pos:'bottom'}"> <span class="fa fa-rss"></span> <span class="g-social-text"> RSS Feeds</span> </a> </div></div></div></div></div></div></section></div><div class="g-container"> <header id="g-header"><div class="g-grid"><div class="g-block size-100"><div class="g-content g-particle"> <a href="/" title="Linux Tutorials - Learn Linux Configuration" rel="home" class="g-logo "> <img src="/images/linuxconfig_logo.png" alt="Linux Tutorials - Learn Linux Configuration"/> </a> </div></div></div></header> </div><div class="g-container"><section id="g-navigation" data-uk-sticky="&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;"><div class="g-grid"><div class="g-block size-95"><div class="g-content g-particle"> <nav class="g-main-nav" role="navigation" data-g-mobile-target data-g-hover-expand="true"><ul class="g-toplevel"> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href="/" title="Start here"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class="g-menu-item-container" href="/linux-tutorials"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1766 g-parent g-standard  "><div class="g-menu-item-container" data-g-menuparent> <span class="g-nav-header g-menu-item-content"> <span class="g-menu-item-title">Linux Distros</span> </span> <span class="g-menu-parent-indicator"></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class="g-dropdown-column"><div class="g-grid"><div class="g-block size-100"><ul class="g-sublevel"> <li class="g-level-1 g-go-back"> <a class="g-menu-item-container" href="#" data-g-menuparent><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1767  "> <a class="g-menu-item-container" href="/linux-distros/ubuntu"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Ubuntu</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1768  "> <a class="g-menu-item-container" href="/linux-distros/centos"> <span class="g-menu-item-content"> <span class="g-menu-item-title">CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1769  "> <a class="g-menu-item-container" href="/linux-distros/debian"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1771  "> <a class="g-menu-item-container" href="/linux-distros/fedora"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1770  "> <a class="g-menu-item-container" href="/linux-distros/redhat"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Redhat</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class="g-menu-item-container" href="/system-administration"> <span class="g-menu-item-content"> <span class="g-menu-item-title">System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class="g-menu-item-container" href="/programming-scripting"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class="g-menu-item-container" href="/linux-commands"> <span class="g-menu-item-content"> <span class="g-menu-item-title">Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-5"><div class="g-content"><div class="moduletable "><div class="g-particle"><div class="g-search-login"><div class="g-buttons"><div class="g-search-button"> <a id="header-search-toggle" href="/" data-uk-tooltip title="Search"> <i class="fa fa-search"></i> </a> </div></div><div id="header-search"><div class="g-block"><div class="g-content"> <a class="uk-close"></a> <div class="moduletable"><div class="search mod_search93"><form action="/install-ring-a-foss-voip-skype-alternative" method="post" class="form-inline"> <label for="mod-search-searchword" class="element-invisible">Search ...</label> <input autocomplete="off" name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="search" size="20" placeholder="Search ..."/> <input type="hidden" name="task" value="search"/> <input type="hidden" name="option" value="com_search"/> <input type="hidden" name="Itemid" value="2010"/> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class="g-container"><section id="g-system-messages"><div class="g-grid"><div class="g-block size-100"><div class="g-system-messages"> </div> </div> </div> </section> </div><div class="g-container"><section id="g-container-main" class="g-wrapper"><div class="g-grid"><div class="g-block size-67"><section id="g-mainbody"><div class="g-grid"><div class="g-block size-100"><div class="g-content"><div class="platform-content row-fluid"><div class="span12"><article class="item item-page" itemscope itemtype="https://schema.org/Article"><meta itemprop="inLanguage" content="en-GB"/><div class="g-article-header"><div class="page-header"><h2 itemprop="name"> Install Ring, a FOSS VOIP Skype alternative </h2></div><dl class="article-info muted"> <dt class="article-info-term"> Details </dt><dd class="createdby" itemprop="author" itemscope itemtype="http://schema.org/Person"> <span itemprop="name" data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Nick Congleton</span> </dd><dd class="category-name"> <span itemprop="genre" itemprop="genre" data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration &amp; Configuration</span> </dd><dd class="published"> <time datetime="2017-09-06T07:27:14+10:00" itemprop="datePublished" data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>06 September 2017	</time> </dd> </dl><div class="article-position"> <center><span class="visible-desktop"><div id="div-gpt-ad-1407836221062-0"> </div> </span> <span class="hidden-desktop"><div id="div-gpt-ad-1407836020382-0"> </div> </span></center> </div> </div><div class="autotoc" style="float:right;"><span>Contents</span><ul><li><ul><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h1-objective" class="toclink toclink-h1">1.&nbsp;Objective</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h2-distributions" class="toclink toclink-h1">2.&nbsp;Distributions</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h3-requirements" class="toclink toclink-h1">3.&nbsp;Requirements</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h4-difficulty" class="toclink toclink-h1">4.&nbsp;Difficulty</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h5-conventions" class="toclink toclink-h1">5.&nbsp;Conventions</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h6-introduction" class="toclink toclink-h1">6.&nbsp;Introduction</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h7-install-on-debian" class="toclink toclink-h1">7.&nbsp;Install On Debian</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h8-install-on-ubuntu" class="toclink toclink-h1">8.&nbsp;Install On Ubuntu</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h9-install-on-fedora" class="toclink toclink-h1">9.&nbsp;Install On Fedora</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h10-using-ring" class="toclink toclink-h1">10.&nbsp;Using Ring</a></li><li><a href="https://linuxconfig.org/install-ring-a-foss-voip-skype-alternative#h11-closing-thoughts" class="toclink toclink-h1">11.&nbsp;Closing Thoughts</a></li></ul></li></ul></div><div itemprop="articleBody"><h2 id="h1-objective">Objective</h2>Install the Ring Free Software VIOP client. <h2 id="h2-distributions">Distributions</h2>This guide covers Debian, Ubuntu, and Fedora, but Ring can be installed from source on other distributions. <h2 id="h3-requirements">Requirements</h2>A working Linux install with root privileges. <h2 id="h4-difficulty">Difficulty</h2>Easy <h2 id="h5-conventions">Conventions</h2><ul> <li><b>#</b> - requires given command to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</li> <li><b>$</b> - given command to be executed as a regular non-privileged user</li> </ul><h2 id="h6-introduction">Introduction</h2>If you ask just about any Linux user, they'll agree that Skype is pretty terrible. There's not a whole lot to like there, especially since the Linux client is just a poorly maintained wrapper for the web app. <br><br> There have been several attempts to create a free and open source alternative to Skype, but none have been as polished or complete as Ring. <h2 id="h7-install-on-debian">Install On Debian</h2>Before you add the Ring repository, you need to install a single dependency for Debian, so go ahead and do that. <pre># apt install dirmngr</pre> Now, you can add the repo to your <code>/etc/apt/sources.list</code> <pre>
deb https://dl.ring.cx/ring-nightly/debian_9/ ring main
</pre> Add the GPG key so <code>apt</code> doesn't complain. <pre># apt-key adv --keyserver pgp.mit.edu --recv-keys A295D773307D25A33AE72F2F64CD5FA175348F84</pre> Then, update and install Ring. <pre>
# apt update
# apt install ring
</pre><h2 id="h8-install-on-ubuntu">Install On Ubuntu</h2>Ring supports both Ubuntu LTS and the current releases. This guide is going to use 17.04, but you can replace it with your version number, and it'll work just the same. Start off by adding the repository to your <code>/etc/apt/sources.list.d</code> directory. <pre>$ sudo vim /etc/apt/sources.list.d/ring.list</pre> <pre>
deb https://dl.ring.cx/ring-nightly/ubuntu_17.04/ ring main
</pre> Add the GPG key for the repo too. <pre>$ sudo apt-key adv --keyserver pgp.mit.edu --recv-keys A295D773307D25A33AE72F2F64CD5FA175348F84</pre> Enable the "universe" repository too. <pre>$ sudo add-apt-repository universe</pre> Finally, update and install. <pre>
$ sudo apt update
$ sudo apt install ring
</pre><h2 id="h9-install-on-fedora">Install On Fedora</h2>The install process is super easy on Fedora. DNF handles just about everything for you. Use it to add the repo, and simply install Ring. <pre>
# dnf config-manager --add-repo https://dl.ring.cx/ring-nightly/fedora_26/ring-nightly.repo
# dnf install -y ring
</pre><h2 id="h10-using-ring">Using Ring</h2>When you start Ring for the first time, it will ask you to create an account. Unlike Skype, you don't need to enter any personal information here. Enter what you like, and create a password. The main purpose of creating a Ring account is to assign you a unique number for making and receiving calls. <br><br> After you create your account, you will be assigned your number. That number will be stored on your computer at <code>.config/ring/dring.yml</code>. Should you reinstall your OS or change computers, back up that file. You'll need it if you want to keep your number. <br><br> The interface that you're dropped into after logging in does look similar to existing VIOP software. You can exchange numbers with your friends and build a contact list. Ring is also available for Android, so you can send your number there and have the same number across both devices. <br><br> Ring can handle regular chat, voice calls, video calls, and even conference calls. <h2 id="h11-closing-thoughts">Closing Thoughts</h2>Ring provides a real solid alternative to terrible proprietary VOIP clients like Skype. It's simple to use and set up, so you can get your non-techie friends on it with minimal effort too. <br><br> Even though Ring hasn't been around very long, it's becoming more polished all the time, and already beats out certain poorly maintained alternatives. For Ring, the future certainly seems bright. </div></article></div></div></div></div></div><div class="g-grid"><div class="g-block size-100"><div class="g-content"><div class="platform-content"><div class="moduletable "><div class="custom"> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4906753266448300" data-ad-slot="3873304447" data-ad-format="link"></ins><hr><span class="visible-desktop"><div id="div-gpt-ad-1407836026226-0"> </div> </span> <span class="hidden-desktop"><div id="div-gpt-ad-1407836147036-0"> </div> </span> </center><div id="disqus_thread"></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript rel=nofollow>comments powered by Disqus.</a></noscript></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id="g-aside"><div class="g-grid"><div class="g-block size-100"><div class="g-content"><div class="platform-content"><div class="moduletable "><div class="custom"> <span style="margin: 0px; overflow:hidden; padding: 0px;" class="hidden-phone" data-uk-sticky="{boundary:'#endad'}"><div id="div-gpt-ad-1407836055417-0"> </div><hr style="margin: 3px" ;><div id="div-gpt-ad-1407836271993-0"> </div> </span> <div id="endad" style="position: absolute;bottom: 790px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class="g-container"><footer id="g-footer"><div class="g-grid"><div class="g-block size-25"><div class="g-content"><div class="moduletable "><h3 class="g-title"><span>About</span></h3><div class="g-particle"> LinuxConfig.org team is determined to provide you with simple to follow Linux tutorials, various tips, tricks and programming guides as well as with GNU/Linux system administration tutorials in general to help you to learn Linux faster and use it with ease. <br><br>
Any comments, constructive feedback or your <a href="floss-technical-writer-linuxconfig-org"><b>involvement</b></a> is welcome. <br><br>
Contact: </div></div><div class="moduletable "><div class="g-particle"><div class="g-contacts uk-margin-top"><div class="g-contacts-item"> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class="g-contact-value">web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class="g-content"><div class="moduletable "><h3 class="g-title"><span>Write For Us</span></h3><div class="g-particle"> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class="button" href="/floss-technical-writer-linuxconfig-org">Read More...</a> </div></div></div></div><div class="g-block size-25"><div class="g-content"><div class="platform-content"><div class="moduletable "><h3 class="g-title"><span>Featured Linux Tutorials</span></h3><ul class="mostread"> <li itemscope itemtype="https://schema.org/Article"> <a href="/bash-scripting-tutorial" itemprop="url"> <span itemprop="name"> Bash scripting Tutorial </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/howto-mount-usb-drive-in-linux" itemprop="url"> <span itemprop="name"> Howto mount USB drive in Linux </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-install-skype-on-ubuntu-16-04-xenial-xerus-linux-64-bit" itemprop="url"> <span itemprop="name"> How to install Skype on Ubuntu 16.04 Xenial Xerus Linux 64-bit </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-check-centos-version" itemprop="url"> <span itemprop="name"> How to check CentOS version </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-install-steam-on-ubuntu-16-04-xenial-xerus" itemprop="url"> <span itemprop="name"> How to install Steam on Ubuntu 16.04 Xenial Xerus </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/check-what-debian-version-you-are-running-on-your-linux-system" itemprop="url"> <span itemprop="name"> Check what Debian version you are running on your Linux system </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-stop-start-and-disable-enable-firewall-on-redhat-7-linux-system" itemprop="url"> <span itemprop="name"> How to stop/start and disable/enable Firewall on Redhat 7 Linux system </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-setup-and-use-ftp-server-in-ubuntu-linux" itemprop="url"> <span itemprop="name"> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-mount-partition-with-ntfs-file-system-and-read-write-access" itemprop="url"> <span itemprop="name"> How to mount partition with ntfs file system and read write access </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/how-to-install-the-latest-nvidia-drivers-on-ubuntu-16-04-xenial-xerus" itemprop="url"> <span itemprop="name"> How to install the latest Nvidia drivers on Ubuntu 16.04 Xenial Xerus </span> </a> </li> </ul> </div></div><div class="platform-content"><div class="moduletable "><ul class="latestnews"> <li itemscope itemtype="https://schema.org/Article"> <a href="/install-ring-a-foss-voip-skype-alternative" itemprop="url"> <span itemprop="name"> Install Ring, a FOSS VOIP Skype alternative </span> </a> </li> <li itemscope itemtype="https://schema.org/Article"> <a href="/install-riot-matrix-chat-client-on-debian-and-ubuntu" itemprop="url"> <span itemprop="name"> Install Riot Matrix Chat Client On Debian and Ubuntu </span> </a> </li> </ul> </div></div></div></div><div class="g-block size-25"><div class="g-content"><div class="moduletable "><h3 class="g-title"><span>RSS Feeds</span></h3><div class="g-particle"> LinuxConfig.org's category RSS list: </div></div><div class="moduletable "><div class="g-particle"><div class="g-contacts uk-margin-top"><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=19&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">System Administration</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=17&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">Programming & Scripting</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=8&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">Ubuntu</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=10&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">CentOS</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=13&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">Debian</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=15&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">Fedora</span> </a> </div><div class="g-contacts-item" rel="nofollow"> <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=14&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class="g-contact-value">Redhat</span> </a> </div></div></div></div></div></div></div></footer></div><div class="g-container"><section id="g-copyright"><div class="g-grid"><div class="g-block size-50"><div class="g-content"><div class="moduletable "><div class="g-particle"> &copy; 2007 - 2017 <a name="rss">LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class="g-content"><div class="moduletable "><div class="g-particle"><div class="g-social"> <a target="_blank" href="https://twitter.com/linuxconfig" data-uk-tooltip="{pos:'bottom'}" rel="nofollow"> <span class="fa fa-twitter fa-fw"></span> <span class="g-social-text"> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class="g-container"><section id="g-to-top"><div class="g-grid"><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href="#" id="g-totop-button" rel="nofollow" data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/assets2/jscss.php?f=27badfc111f5580b00fe370de429ba2f&type=css&gz=gz&d=1&i=0';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href="/media/plg_jchoptimize/assets2/jscss.php?f=27badfc111f5580b00fe370de429ba2f&amp;type=css&amp;gz=gz&amp;d=1&amp;i=0"/></noscript> <script src="/media/plg_jchoptimize/assets2/jscss.php?f=fc7ad34a868a633e8eb5ff88561d63f0&amp;type=js&amp;gz=gz&amp;d=1&amp;i=0"></script> </body> </html>