<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more /><meta name=keywords content="hung, linux, help, troubleshoot, linux, cli, access" /><meta name=author content="Roel Van de Paar" /><meta name=description content="Have you ever had your Linux Desktop hang on you? This article will show you a method to drop to a command line, which often continues to work even when your Desktop is hung. Also, learn some handy keyboard combinations at the same time!" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>Hung Linux System? How to Escape to the Command Line and More - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/bXa8n0uUCb2a0SzvaCENH28oqao.js"></script><link href="https://linuxconfig.org/component/search/?Itemid=3313&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><link href=/plugins/content/autotoc/autotoc.css rel=stylesheet /><link href=/media/plg_jchoptimize/css/pro-ls.effects.css rel=stylesheet /><link href=/templates/it_headlines/uikit/css/uikit.min.css rel=stylesheet /><link href=/media/gantry5/assets/css/font-awesome.min.css rel=stylesheet /><link href=/media/gantry5/engines/nucleus/css-compiled/nucleus.css rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/headlines_25.css rel=stylesheet /><link href=/media/gantry5/assets/css/bootstrap-gantry.css rel=stylesheet /><link href=/media/gantry5/engines/nucleus/css-compiled/joomla.css rel=stylesheet /><link href=/media/jui/css/icomoon.css rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/headlines-joomla_25.css rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/custom_25.css rel=stylesheet /><link href=/templates/it_headlines/custom/prism/prism_3.css rel=stylesheet /><style>div.mod_search93 input[type="search"]{width:auto}#header-search{background:#fff}#header-search .search input,#header-search .uk-close,#header-search .uk-close:hover{color:#444}</style> <script src=/media/jui/js/jquery.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/jquery-noconflict.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/jquery-migrate.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/bootstrap.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/system/js/caption.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/plg_jchoptimize/js/ls.loader.js></script> <script src=/media/plg_jchoptimize/js/pro-ls.unveilhooks.js></script> <script src=/media/plg_jchoptimize/js/pro-ls.loader.effects.js></script> <script src=/media/plg_jchoptimize/js/ls.autosize.js></script> <script src=/media/plg_jchoptimize/js/lazysizes.js></script> <script src=/media/system/js/html5fallback.js></script> <script src=/templates/it_headlines/custom/prism/prism_3.js></script> <script>jQuery(function($){initTooltips();$("body").on("subform-row-add",initTooltips);function initTooltips(event,container){container=container||document;$(container).find(".hasTooltip").tooltip({"html":true,"container":"body"});}});jQuery(window).on('load',function(){new JCaption('img.caption');});</script> <script src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/js/lazyloadforjoomla.min.js></script> <script>jQuery(document).ready(function(){jQuery("img").lazyload();});</script> <!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--> <script async src=https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js></script><noscript><style>img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-3313 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2944  "> <a class=g-menu-item-container href=/ubuntu-20-04-guide> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 20.04</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS / AlmaLinux</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel="nofollow noopener" data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a href=https://bit.ly/2X5D30q rel="nofollow noopener" data-uk-tooltip="{pos:'bottom'}">Newsletter </a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a target=_blank href=https://feeds.linuxconfig.org/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-rss fa-fw"></span> <span class=g-social-text> RSS</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" /><noscript><img src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /></noscript></a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://bit.ly/linux-job-alert alt="Linux Jobs" rel=nofollow target=_blank><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png><noscript><img src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></noscript></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Guides</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2988 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Admin</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2997 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-3001 g-standard  "> <a class=g-menu-item-container href=/multimedia-games> <span class=g-menu-item-content> <span class=g-menu-item-title>Multimedia</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/hung-linux-system-how-to-escape-to-the-command-line-and-more method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=3313 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> Hung Linux System? How to Escape to the Command Line and More </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Roel Van de Paar</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration</span> </dd><dd class=modified> <time datetime=2021-03-22T15:11:03+11:00 itemprop=dateModified data-uk-tooltip title="Modified Date"> <i class="fa fa-clock-o"></i>22 March 2021	</time> </dd> </dl><div data-fuse=22189504503 class=incontent_ads></div></div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h1-software-requirements-and-conventions-used class='toclink toclink-h1'>1.&nbsp;Software requirements and conventions used</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h2-a-truly-hung-system class='toclink toclink-h1'>2.&nbsp;A truly hung system?</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h3-less-hung-than-frozen class='toclink toclink-h1'>3.&nbsp;Less hung than frozen?</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h4-frozen-differently class='toclink toclink-h1'>4.&nbsp;Frozen, differently</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h5-dropping-to-the-command-line class='toclink toclink-h1'>5.&nbsp;Dropping to the command line</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h6-last-resort class='toclink toclink-h1'>6.&nbsp;Last resort</a></li><li><a href=https://linuxconfig.org/hung-linux-system-how-to-escape-to-the-command-line-and-more#h7-conclusion class='toclink toclink-h1'>7.&nbsp;Conclusion</a></li></ul></li></ul></div><div itemprop=articleBody><p>It is not much fun when your Desktop hangs. The fear of lost work, the inability to continue work, and more. But it need not always be like this. Knowing just a little extra - a few shortcut keyboard combinations and a few commands at the command line - will hopefully get you back up and running quickly. It does not always work, but it works often. </p><p><strong>In this tutorial, you will learn</strong>:</p><ul> <li>How to do basic immediate troubleshooting steps on a hung system</li> <li>How to execute a memory test using a Memtest86+ ISO image burned to disc</li> <li>A number of keyboard shortcuts that will empower you to handle hung systems better</li> <li>Information about what avenues to take to do further troubleshooting steps</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/00-hung-linux-system-how-to-escape-to-the-command-line-and-more.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Hung Linux System? How to Escape to the Command Line and More"><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/00-hung-linux-system-how-to-escape-to-the-command-line-and-more.png alt="Hung Linux System? How to Escape to the Command Line and More"><noscript><img src=https://linuxconfig.org/images/00-hung-linux-system-how-to-escape-to-the-command-line-and-more.png alt="Hung Linux System? How to Escape to the Command Line and More" width=1200 height=750 /></noscript></a> <div class=uk-thumbnail-caption>Hung Linux System? How to Escape to the Command Line and More</div></div></div><h2 id=h1-software-requirements-and-conventions-used>Software requirements and conventions used</h2><table class="uk-table uk-table-strIPed uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption><thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Linux Distribution-independent</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>Bash command line, Linux based system</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>Any utility which is not included in the Bash shell by default can be installed using <code>sudo apt-get install utility-name</code> (or <code>yum install</code> for RedHat based systems)</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td># - requires <a href=/linux-commands>linux-commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command<br>$ - requires <a href=/linux-commands>linux-commands</a> to be executed as a regular non-privileged user<br></td> </tr> </tbody> </table><h2 id=h2-a-truly-hung-system>A truly hung system?</h2><p>One of the main difficulties with system hangs is finding out what is causing the hung. It is a bit of an art, or perhaps better a skill, which will grow over time. The more system hangs you see, the more you will recognize when they happen again. If you see many, it will be easy to analyze computers from others, even with limited information like during remote phone support.</p><p>If the complete system hangs (press the <code>NUM LOCK</code> and/or <code>CAPS LOCK</code> keys a few times; does the lights still come on the keyboard indicating their turned on/off? Similarly, move the mouse around on the screen; is it stuck? </p><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert" style="background:#ff5500; color: white;text-shadow: 0px 0px;"> <i><center><b>Looking for Linux Systems Analyst !</b><br><br> The UAF Geophysical Institute, is looking for an experienced Linux Systems Analyst to join their team of research cyber infrastructure analysts and engineers. LOCATION: <b>Fairbanks, Alaska, USA</b><br> </i><br><a class=button href=http://bit.ly/2Prk1Ts rel=nofollow>APPLY NOW</a></center></div></div></div><hr><div data-fuse=22189504506 class=incontent_ads></div><hr></div></div><p>If the answer to both questions is &ldquo;no change,&rdquo; the system is highly likely completely frozen. However, you could still try - on a Linux system - <code>CTRL+ALT+F4</code> (more on this later) and <code>CTRL+ALT+BACKSPACE</code> (On some Linux systems this will reset the desktop/GUI completely) to see if it makes any difference. </p><p>On Windows, you could try <code>CTRL+ALT+DEL</code> which will hopefully bring you back to a Windows shortcut screen from where you can select <strong>Task Manager</strong> to start investigating if there is any hung process, etc. The remainder of this article will focus on Linux only. </p><p>Note that the <code>CTRL+ALT+DEL</code> sequence may also work on some Linux systems, so try it too.</p><p>If the system is genuinely hung 100%, completely frozen, and responds to nothing, there is but one solution left; press the <strong>RESET</strong> button on the computer case, or turn it off completely and then restart. After a restart, you can start looking at the logs (for example <code>dmesg</code> may show issues with a disk on reboot) to see if anything looks amiss, though it is somewhat likely that whatever made the system hung did not write output to the log before the hung/system freeze occurred.</p><p>To learn more about <code>dmesg</code>, please see our &lsquo;<a href=/what-is-dmesg-and-how-do-i-use-it>What Is Dmesg and How Do I Use It</a>&lsquo; article!</p><p>In cases like these, you will want to download a <a href=http://www.memtest.org/#downiso>Memtest86+ ISO CD Image</a> (or any similar tool) and burn it to CD, then start your system from the burned disk and start the memory testing once Memtest86+ comes up (which should be automatically the case with their ISO images). Let it do a solid test on your system&rsquo;s memory.</p><p>Full system freezes/hangs are not normal and potentially caused by faulty hardware. Memory and disk are prime suspects. As noted above, watch <code>dmesg</code> for disk (and potentially memory) issues during startup, and check your memory in full with a tool like Memtest86+. Note that you can use such a tool even if the operating system you are running is not Linux but, for example, Microsoft (or even MacOS). </p><p>The operating system never needs to (and will not) be loaded if you select the burned CD as the startup drive. A small Linux operating system will be loaded (it is part of the ISO image), after which Memtest86+ will be started from the same CD. </p><p>Note also that may need to press a key during startup, like <code>F9</code> or some other function or another keyboard key, to select the startup disk to be the CD. You may also need to enter your BIOS to select the startup disk as the CD and/or to enable booting from CD in the first place. </p><p>For the disc, make sure to use the correct burning method; you do not want to write the ISO file to a disk; you will want to use a ISO-enabled burning software and write the ISO to disc in an <strong>expanded</strong> format. Think of the ISO as a zip file that contains the files that actually need to be burned. Popular Linux burning programs like <strong>K3b</strong> have an option similar to <strong>More actions&hellip;</strong> (button in the main menu in K3b) <strong>Burn Image&hellip;</strong> that allow you to select an ISO to be burned.</p><p>Finally, your CPU, GPU, or other peripherals may be faulty. I would always approach the CPU towards the end of the troubleshooting chain unless it was improperly cooled or overclocked. The GPU is a more likely cause, especially if it is a higher-end card and/or was overclocked or poorly cooled. You can start seeing where the art, or rather the learning process comes into play.</p><div class=moduletable><div class=custom><hr><div data-fuse=22189504224 class=incontent_ads></div><hr></div></div><h2 id=h3-less-hung-than-frozen>Less hung than frozen?</h2><p>If your system is still somewhat responsive, unlike our example above, and reacts to, for example, mouse movements <strong>-or-</strong> reacts to any keyboard shortcut sequence <code>-and/or-</code> the keyboard lights still turn on/off when you press any of the <code>LOCK</code> keys as described above, then potentially more troubleshooting steps can be made.</p><p>For Linux users, the first thing to always try is to press the following keystrokes in sequence. Stop and explore when you notice that something is working.</p><p><code>ALT+TAB</code> (this keyboard sequence will change the active window you&rsquo;re working on it. Does it work? If so, can you click on another window once at least one window swap was done with <code>ALT+TAB</code>?) &gt; <code>ESC</code> (We are trying to escape whatever state a program is in. </p><p>It is unlikely to help, but we want to make sure) &gt; <code>CTRL+c</code> (This one will be especially in hung or busy shell sessions and will interrupt whatever program is running) &gt; <code>CTRL+z</code> (You can think about this one as a strong version of CTRL+c, though what it really does is place a process into the background and pauses it, it is again mostly if not only applicable to the shell).</p><p>If any of this <strong>set your system free</strong> you can keep exploring to see if anything (and what in particular) makes the system hung again. If you want to terminate any process interrupted with <code>CTRL+z</code> in the terminal/shell, you can execute <code>kill %1</code>, provided that the output generated by the <code>CTRL+z</code> stated <code>[1]</code> (in other words, match the numbers: 1-1, 2 if 2 etc. and leave the literal percentage sign).</p><h2 id=h4-frozen-differently>Frozen, differently</h2><p>If your system is responding to some keys (for example <code>ALT+TAB</code>) but is still unusable, or any such similar situation of <strong>some response, but still unusable</strong> you will want to try escaping/dropping to the command line. </p><p>Doing so will allow you to execute for example <code>ps -ef | grep &lsquo;likely_failing_process_name</code> and then <code>sudo kill -9 mypid</code> where <code>mypid</code> is the PID (process identifier) given in the second column (the first numerical column that is) in front of the likely hung process. In other words, usually, a single process is responsible for making the system semi-hung. Primary suspects are usually Firefox and Chrome, and LibreOffice Writer or Calc after this. </p><p>If it is a server, other major programs like <code>mysqld</code> may be causing the problem. It is not recommended to <code>kill -9</code> such server software instances without doing further troubleshooting with knowledge of the server process being used, how it is deployed, what fault tolerance there is etc. But for most other programs, you should be fine as per above, though note you may lose unsaved work in those processes. </p><p>That said, most programs these days have some level of crash recovery that can be enabled beforehand (when the program is functioning normally). It is a good idea to do so now in preparation for a potential crash later.</p><div class=moduletable><div class=custom><hr><div data-fuse=22189504509 class=incontent_ads></div><hr></div></div><h2 id=h5-dropping-to-the-command-line>Dropping to the command line</h2><p>Once we want to drop to the command line, simply press <code>CTRL+ALT+F4</code>. Note that <code>F4</code> here stands for the <code>F4</code> function key in the row of function keys at the top of your keyboard. Note also that we could have also used for example <code>F3</code> or <code>F5</code>, though not for example <code>F7</code>. </p><p>The reason for this is that - whilst there are various terminals available - the <code>F7</code> terminal (and sometimes <code>F2</code> from memory) are reserved for the graphical user interface, the Desktop. Thus, you could, for example, start by swapping to the terminal using <code>CTRL+ALT+F4</code> and then swap back to the Desktop (though it may have already failed to swap to the terminal to start with!) by using <code>CTRL+ALT+F7</code>. </p><p>If this did not clear the hang, login to the terminal session in the <code>CTRL+ALT+F4</code> screen (or similar), and also have a look at <code>CTRL+ALT+F1</code> which may display a system log. From within the authenticated terminal session you can use <code>ps -ef</code> etc. to kill deemed rogue processes etc., as described in the last section.</p><p>Once you are in the command line, you may like to have a look at the <code>init</code> command (by using <code>man init</code>, and referencing <a href=https://askubuntu.com/a/899162/682596>this answer</a> on AskUbuntu). For example, running <code>sudo init 3</code> followed by <code>sudo init 5</code> could restart the desktop environment (your work will be lost though). </p><p>You may also find this <code>init</code> command interesting for example installing NVIDIA GPU drivers which sometimes require one to stop the X server before installing them. To do so, you can use <code>sudo init 1</code>, then browse to the directory of the extracted drives and initiate <code>./nvidia-install</code> and follow the prompts provided. This may not always work if there are prior driver issues, but it does provide another opportunity to explore when issues arise.</p><h2 id=h6-last-resort>Last resort</h2><p>If all else fails, and the system seems semi-hung, but nothing has helped, start randomly moving the palms of your hands over many keys, randomly over and across the keyboard, pressing many keys in the process. Various keyboard combinations may potentially trigger a different state in some program or in the operating system, and this can sometimes unlock the system.</p><h2 id=h7-conclusion>Conclusion</h2><p>This article explored basic troubleshooting steps for hung/frozen systems in various degrees of being frozen. We discussed how to execute a memory test using a CD with Memtest86+ burned from an ISO image. We also looked at a number of keyboard shortcuts that will empower you to handle hung systems better, and we discussed what avenues to take to do further troubleshooting steps for previously hung systems.</p><p>I will recant from the idea to end this article with my usual <strong>enjoy!</strong>, as a hung system is no joy. Still, this article may help you a good stretch on the right way. I hope your [next] debugging session goes well!</p></div><ul class="pager pagenav"> <li class=previous> <a class=hasTooltip title="What is dmesg, And How Do I Use It?" aria-label="Previous article: What is dmesg, And How Do I Use It?" href=/what-is-dmesg-and-how-do-i-use-it rel=prev> <span class=icon-chevron-left aria-hidden=true></span> <span aria-hidden=true>Prev</span> </a> </li> <li class=next> <a class=hasTooltip title="How to disable SELinux" aria-label="Next article: How to disable SELinux" href=/how-to-disable-selinux-on-linux rel=next> <span aria-hidden=true>Next</span> <span class=icon-chevron-right aria-hidden=true></span> </a> </li> </ul> </article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>FIND LATEST <a href=https://www.linuxcareers.com/ target=_blank>LINUX JOBS</a> on LinuxCareers.com</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/filesystem-basics> Linux Filesystem Navigation Basics </a> </li> <li> <a href=/ubuntu-20-10-download> Ubuntu 20.10 Download </a> </li> <li> <a href=/how-to-check-disk-space-with-df-and-du-on-linux> How to check disk space with df and du on Linux </a> </li> <li> <a href=/how-to-compare-files-using-diff> How to compare files using diff </a> </li> </ul> </div> </div></div><div class=platform-content><div class="moduletable "><div class=custom><hr><center><div data-fuse=22198552927></div></center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/linuxconfig-forum-logo.png < img><noscript><img src=https://linuxconfig.org/images/linuxconfig-forum-logo.png </img></noscript></center><div id=discourse-comments></div> <script>DiscourseEmbed={discourseUrl:'https://forum.linuxconfig.org/',discourseEmbedUrl:window.location.href.split(/[?#]/)[0]};(function(){var d=document.createElement('script');d.type='text/javascript';d.async=true;d.src=DiscourseEmbed.discourseUrl+'javascripts/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(d);})();</script></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div data-fuse=22189504221 class=sticky_ads></div><hr style="margin: 3px" ;><div data-fuse=22189277162></div></span> <div id=endad style="position: absolute;bottom: 1120px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/ubuntu-20-04-download itemprop=url> <span itemprop=name>Ubuntu 20.04 Download </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade Ubuntu To 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/ubuntu-20-04-guide itemprop=url> <span itemprop=name>Ubuntu 20.04 Guide</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/linux-download itemprop=url> <span itemprop=name>Linux Download</span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-work-with-the-woocommerce-rest-api-with-python itemprop=url> <span itemprop=name> How to work with the Woocommerce REST API with Python </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-use-tcpdump-command-on-linux itemprop=url> <span itemprop=name> How to use tcpdump command on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-use-ps-command-beginners-guide itemprop=url> <span itemprop=name> How to use ps command: Beginners guide </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/what-is-dmesg-and-how-do-i-use-it itemprop=url> <span itemprop=name> What is dmesg, And How Do I Use It? </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/hung-linux-system-how-to-escape-to-the-command-line-and-more itemprop=url> <span itemprop=name> Hung Linux System? How to Escape to the Command Line and More </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-discover-from-inside-a-bash-script-the-path-the-script-is-in itemprop=url> <span itemprop=name> How to Discover, From Inside a Bash Script, the Path the Script Is In </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-disable-selinux-on-linux itemprop=url> <span itemprop=name> How to disable SELinux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-and-use-zstd-compression-tool-on-linux itemprop=url> <span itemprop=name> How to install and use ZSTD compression tool on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-find-large-files-on-linux itemprop=url> <span itemprop=name> How to find large files on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-check-kernel-version-on-linux itemprop=url> <span itemprop=name> How to check Kernel version on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-mount-iso-image-on-linux itemprop=url> <span itemprop=name> How to mount ISO image on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-delete-file-on-ubuntu-linux itemprop=url> <span itemprop=name> How to delete file on Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-create-a-user-with-a-custom-home-directory-on-linux itemprop=url> <span itemprop=name> How to create a user with a custom home directory on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-open-iso-files-on-ubuntu-linux itemprop=url> <span itemprop=name> How to open ISO files on Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-lemp-stack-on-almalinux itemprop=url> <span itemprop=name> How to install LEMP stack on AlmaLinux </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2021 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a target=_blank href=https://feeds.linuxconfig.org/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-rss fa-fw"></span> <span class=g-social-text> RSS</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/gantry5/assets/js/main.js></script> <script>(function($){$(document).ready(function(){$(window).scroll(function(){if($(document).scrollTop()<500||$(window).width()<767){$('#g-totop-button').removeClass('totopfixed');}else{$('#g-totop-button').addClass('totopfixed');}});});})(jQuery);</script> <script src=/templates/it_headlines/uikit/js/uikit.min.js></script> <script>(function($){$(window).load(function(){var headerSearch=$("#header-search");var headerSearchHeight=$("#g-navigation").innerHeight();var closeSearch=$("#header-search a.uk-close");var inputSearch=$("input#mod-search-searchword");var searchToggle=$("a#header-search-toggle");$(headerSearch).prependTo($("#g-navigation .g-grid:first")).css({'height':headerSearchHeight,'line-height':(headerSearchHeight)+'px'});$(closeSearch).css({'top':(headerSearchHeight/2)-10});$(inputSearch).css({'height':headerSearchHeight,'line-height':(headerSearchHeight)+'px'});$(searchToggle).on("click",function(e){e.preventDefault();$(headerSearch).fadeIn("fast");$(inputSearch).focus();});$(closeSearch).on("click",function(e){e.preventDefault();$(headerSearch).fadeOut("fast");});});})(jQuery);</script> <script src=/templates/it_headlines/js/template.js></script> <script>(function($){$(document).ready(function(){$("#g-container-site").addClass("g-container g-site-wrapper");});})(jQuery);</script> <script src=/templates/it_headlines/js/scrollReveal.min.js></script> <script>window.sr=new scrollReveal({mobile:false});</script> </body> </html>