<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux /><meta name=keywords content="UFW, debian, install, use, how, block, ip, address, allow, network, firewall, buster, 10" /><meta name=author content="Nick Congleton" /><meta name=description content="UFW takes a lot of the work out of configuring a firewall on Linux.  Get UFW set up on Debian 10 Buster." /><meta name=generator content="Joomla! - Open Source Content Management" /><title>How to Use UFW on Debian 10 Buster Linux - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/8IL00A6ZVvn8kLikKDuxLCbm0rA.js"></script><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style><noscript><style>img[data-jchll=true]{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2603 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2325 g-standard  "> <a class=g-menu-item-container href=/centos> <span class=g-menu-item-content> <span class=g-menu-item-title>CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>Redhat</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=https://bit.ly/2X5D30q rel=nofollow data-uk-tooltip="{pos:'bottom'}">Newsletter </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /> </a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://www.linuxcareers.com/jobs/alert/ alt="Linux Jobs" rel=nofollow target=_blank><img src=/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <img src=/images/new-badge-red-30.png alt="Linux Jobs" width=30 height=30 /> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/how-to-use-ufw-on-debian-10-buster-linux method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=2603 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> How to Use UFW on Debian 10 Buster Linux </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Nick Congleton</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>Debian</span> </dd><dd class=published> <time datetime=2019-06-18T18:12:29+10:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>18 June 2019	</time> </dd> </dl><div class=article-position> <center><div id=div-gpt-ad-1407836039689-0> </center> </div> </div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h1-software-requirements-and-conventions-used class='toclink toclink-h1'>1.&nbsp;Software Requirements and Conventions Used</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h2-how-to-install-ufw class='toclink toclink-h1'>2.&nbsp;How to Install UFW</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h3-how-to-set-the-defaults-on-ufw class='toclink toclink-h1'>3.&nbsp;How to Set the Defaults on UFW</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h4-how-to-allow-ports class='toclink toclink-h1'>4.&nbsp;How to Allow Ports</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h5-how-to-allow-interfaces class='toclink toclink-h1'>5.&nbsp;How to Allow Interfaces</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h6-how-to-allow-protocol class='toclink toclink-h1'>6.&nbsp;How to Allow Protocol</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h7-how-to-allow-ip-addresses class='toclink toclink-h1'>7.&nbsp;How to Allow IP Addresses</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h8-how-to-enable-ufw class='toclink toclink-h1'>8.&nbsp;How to Enable UFW</a></li><li><a href=https://linuxconfig.org/how-to-use-ufw-on-debian-10-buster-linux#h9-conclusion class='toclink toclink-h1'>9.&nbsp;Conclusion</a></li></ul></li></ul></div><div itemprop=articleBody><p>UFW is very simple to use and configure. It's available right in the Debian repositories, and it integrates well into a Debian system. The simplified controls and ability to easily start and stop your firewall make in an excellent option for desktops and small servers.</p> <strong>In this tutorial you will learn:</strong> <ul> <li>How to Install UFW</li> <li>How to Set the Defaults on UFW</li> <li>How to Allow Ports</li> <li>How to Allow Interfaces</li> <li>How to Allow Protocol</li> <li>How to Allow IP Addresses</li> <li>How to Enable UFW</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="UFW on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw.jpg data-jchll=true alt="UFW on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw.jpg alt="UFW on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>UFW on Debian 10.</div></div></div><h2 id=h1-software-requirements-and-conventions-used>Software Requirements and Conventions Used</h2><table class="uk-table uk-table-striped uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption> <thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Debian 10 Buster</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>UFW</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>Privileged access to your Linux system as root or via the <code>sudo</code> command.</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td> <b>#</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</br> <b>$</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed as a regular non-privileged user </td> </tbody> </table><h2 id=h2-how-to-install-ufw>How to Install UFW</h2><p>UFW is available right in the Debian repositories. Go ahead an install it. Unlike other Debian services, UFW won't start immediately, so you won't need to worry about getting locked out.</p><pre>$ sudo apt install ufw</pre><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to Linux Career <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><h2 id=h3-how-to-set-the-defaults-on-ufw>How to Set the Defaults on UFW</h2><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw-allow-ports.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="UFW Allow Ports on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw-allow-ports.jpg data-jchll=true alt="UFW Allow Ports on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw-allow-ports.jpg alt="UFW Allow Ports on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>UFW Allow Ports on Debian 10.</div></div></div><p>The first step in setting up any firewall is setting your default behaviors. It's generally a good idea to drop incoming requests by default and allow outgoing traffic. If you'd prefer to block everything, you can, but be cautious of that when getting set up.</p><pre class="language-bash line-numbers"><code>$ sudo ufw default deny incoming
$ sudo ufw default allow outgoing</code></pre><h2 id=h4-how-to-allow-ports>How to Allow Ports</h2><p>Now, you can start allowing certain incoming traffic. The most obvious and simplest way to do that is using ports. Start by allowing the most important port to enable access, port 22 for SSH.</p><pre>$ sudo ufw allow 22</pre><p>You can allow other common ports too. For example, on a web server, you'd want to allow HTTP and HTTPS traffic.</p><pre class="language-bash line-numbers"><code>$ sudo ufw allow 80
$ sudo ufw allow 443</code></pre><div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><p>If you have something non-standard, you can always punch that in too. In fact, you can allow arrange of ports with a colon(:).</p><pre>$ sudo ufw allow 27015:27030</pre><p>UFW also has the option of using the name of common ports instead of a number. For example, if you wanted to allow FTP:</p><pre>$ sudo ufw allow ftp</pre><p>As you may have guessed, any of these will work in reverse by using <code>deny</code> in place of <code>allow</code>.</p><pre>$ sudo ufw deny 25</pre><h2 id=h5-how-to-allow-interfaces>How to Allow Interfaces</h2><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw-allow-interface.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="UFW Allow Interface on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw-allow-interface.jpg data-jchll=true alt="UFW Allow Interface on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw-allow-interface.jpg alt="UFW Allow Interface on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>UFW Allow Interface on Debian 10.</div></div></div><p>If you want to allow traffic only on a certain interface but not another, you can specify that too.</p><pre>$ sudo ufw allow in on eth0 to any port 22</pre><p>Again, you can reverse it to deny traffic on a certain interface.</p><pre>$ sudo ufw deny in on eth0 to any port 22</pre><h2 id=h6-how-to-allow-protocol>How to Allow Protocol</h2><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw-allow-protocol.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="UFW Allow Protocol on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw-allow-protocol.jpg data-jchll=true alt="UFW Allow Protocol on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw-allow-protocol.jpg alt="UFW Allow Protocol on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>UFW Allow Protocol on Debian 10.</div></div></div><p>If you'd only like to allow a certain protocol(TCP or UDP) over a port, you can do that as well. This is great for services like Samba which operate with specific protocols.</p><pre>$ sudo ufw allow 137/udp</pre><div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><h2 id=h7-how-to-allow-ip-addresses>How to Allow IP Addresses</h2><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw-allow-ip.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="UFW Allow IP on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw-allow-ip.jpg data-jchll=true alt="UFW Allow IP on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw-allow-ip.jpg alt="UFW Allow IP on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>UFW Allow IP on Debian 10.</div></div></div><p>You can also specify certain IP addresses to allow traffic from. If you wanted to limit SSH traffic to a certain IP address for security, this would be a way to accomplish that.</p><pre>$ sudo ufw allow from ##.##.###.### to any port 22</pre><p>The same thing works with ranges of IP addresses too.</p><pre>$ sudo ufw allow from 192.168.1.0/24 to any port 445</pre><h2 id=h8-how-to-enable-ufw>How to Enable UFW</h2><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/debian-ufw-enable.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="Enable UFW on Debian 10"><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/debian-ufw-enable.jpg data-jchll=true alt="Enable UFW on Debian 10" width=816 height=463 /><noscript><img src=/images/debian-ufw-enable.jpg alt="Enable UFW on Debian 10" width=816 height=463 /></noscript></a> <div class=uk-thumbnail-caption>Enable UFW on Debian 10.</div></div></div><p>Once you have your desired ports allowed, you can start up UFW and enable it at boot.</p><pre>$ sudo ufw enable</pre><p>To check the status of your firewall and the rules in use run:</p><pre>$ sudo ufw status</pre><p>If, for some reason, you'd like to disable UFW, you can do that just as easily.</p><pre>$ sudo ufw disable</pre><h2 id=h9-conclusion>Conclusion</h2><p>You're now ready to get started with UFW. Remember that these are just the building blocks, so you can put together anything you like. UFW is simple, but it's definitely possible to combine these commands together into something altogether more complex.</p></div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>ARE YOU LOOKING FOR A LINUX JOB?</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed on LinuxCareers.com.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><h3 class=g-title><span>You may also be interested in:</span></h3><center> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-4906753266448300 data-ad-slot=5538448164></ins><hr><div id=div-gpt-ad-1407836042106-0> </div> </center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=/images/linuxconfig-forum-logo.png data-jchll=true < img width=250 height=46 /><noscript><img src=/images/linuxconfig-forum-logo.png </img width=250 height=46 /></noscript></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div id=div-gpt-ad-1407836095114-0> </div><hr style="margin: 3px" ;><div id=div-gpt-ad-1407836250753-0> </div> </span> <div id=endad style="position: absolute;bottom: 1150px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=/media/plg_jchoptimize/cache/js/ca377b8dcb90178881608d1ddb97b3e3_0.js></script> <script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-setup-amule-and-control-it-via-web-interface-on-a-raspberry-pi itemprop=url> <span itemprop=name> How to setup AMule and control it via web interface on a Raspberry Pi </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-chef-server-workstation-and-chef-client-on-ubuntu-18-04 itemprop=url> <span itemprop=name> How to install Chef Server, Workstation and Chef Client on Ubuntu 18.04 </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-use-ufw-on-debian-10-buster-linux itemprop=url> <span itemprop=name> How to Use UFW on Debian 10 Buster Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-reuse-php-code-effectively-introduction-to-php-traits itemprop=url> <span itemprop=name> How to Reuse PHP Code Effectively - Introduction to PHP traits </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-set-up-rvm-on-debian-10-buster itemprop=url> <span itemprop=name> How to Set Up RVM on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-create-package-and-sign-a-firefox-web-extension itemprop=url> <span itemprop=name> How to create, package and sign a Firefox web extension </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/introduction-to-bash-shell-parameter-expansions itemprop=url> <span itemprop=name> Introduction to Bash Shell Parameter Expansions </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name> How to install VMware Tools on RHEL 8 / CentOS 8 </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-set-up-a-python-virtual-environment-on-debian-10-buster itemprop=url> <span itemprop=name> How to Set Up a Python Virtual Environment on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-set-up-a-lamp-server-on-debian-10-buster itemprop=url> <span itemprop=name> How to Set Up a LAMP Server on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-set-up-a-samba-server-on-debian-10-buster itemprop=url> <span itemprop=name> How to Set Up a Samba Server on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-set-a-static-ip-address-on-debian-10-buster itemprop=url> <span itemprop=name> How to Set A Static IP Address on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-android-debug-tools-on-debian-10-buster itemprop=url> <span itemprop=name> How to Install Android Debug Tools on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-veracrypt-on-debian-10-buster itemprop=url> <span itemprop=name> How to Install VeraCrypt on Debian 10 Buster </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-compile-vanilla-linux-kernel-from-source-on-fedora itemprop=url> <span itemprop=name> How to compile vanilla Linux kernel from source on Fedora </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2019 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/cache/css/e16612582a79c4b39ff4853eb4bbc8b8_0.css';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href=/media/plg_jchoptimize/cache/css/e16612582a79c4b39ff4853eb4bbc8b8_0.css /></noscript> <script src=/media/plg_jchoptimize/cache/js/ca377b8dcb90178881608d1ddb97b3e3_1.js></script> </body> </html>