<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone /><meta name=keywords content="bloatware, remove, how, android, linux, commands, admin, root" /><meta name=author content="Roel Van de Paar" /><meta name=description content="Your Android mobile almost definitely came with lots of bloatware on it! Do you really need Bixby? or Bixby Vision? or Microsoft Skydrive? Likely not. And all the time this bloatware is costing you precious battery life. Find out how to remove it with this guide!" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>How to Remove Bloatware From Your Samsung Android Mobile Phone - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/bXa8n0uUCb2a0SzvaCENH28oqao.js"></script><link href="https://linuxconfig.org/component/search/?Itemid=3152&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><link href=/plugins/content/autotoc/autotoc.css rel=stylesheet /><link href=/media/plg_jchoptimize/css/pro-ls.effects.css rel=stylesheet /><link href=/templates/it_headlines/uikit/css/uikit.min.css rel=stylesheet /><link href=/media/gantry5/assets/css/font-awesome.min.css rel=stylesheet /><link href=/media/gantry5/engines/nucleus/css-compiled/nucleus.css rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/headlines_25.css?600f562b rel=stylesheet /><link href=/media/gantry5/assets/css/bootstrap-gantry.css rel=stylesheet /><link href=/media/gantry5/engines/nucleus/css-compiled/joomla.css rel=stylesheet /><link href=/media/jui/css/icomoon.css rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/headlines-joomla_25.css?600f562b rel=stylesheet /><link href=/templates/it_headlines/custom/css-compiled/custom_25.css?600f562b rel=stylesheet /><link href=/templates/it_headlines/custom/prism/prism_3.css rel=stylesheet /><style>div.mod_search93 input[type="search"]{width:auto}#header-search{background:#fff}#header-search .search input,#header-search .uk-close,#header-search .uk-close:hover{color:#444}</style> <script src=/media/jui/js/jquery.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/jquery-noconflict.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/jquery-migrate.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/jui/js/bootstrap.min.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/system/js/caption.js?6cf53c81b517ead0e72601a7e8b1e6df></script> <script src=/media/plg_jchoptimize/js/ls.loader.js></script> <script src=/media/plg_jchoptimize/js/pro-ls.unveilhooks.js></script> <script src=/media/plg_jchoptimize/js/pro-ls.loader.effects.js></script> <script src=/media/plg_jchoptimize/js/ls.autosize.js></script> <script src=/media/plg_jchoptimize/js/lazysizes.js></script> <script src=/media/system/js/html5fallback.js></script> <script src=/templates/it_headlines/custom/prism/prism_3.js></script> <script>jQuery(function($){initTooltips();$("body").on("subform-row-add",initTooltips);function initTooltips(event,container){container=container||document;$(container).find(".hasTooltip").tooltip({"html":true,"container":"body"});}});jQuery(window).on('load',function(){new JCaption('img.caption');});</script> <script src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/js/lazyloadforjoomla.min.js></script> <script>jQuery(document).ready(function(){jQuery("img").lazyload();});</script> <!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--> <script async src=https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js></script><noscript><style>img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-3152 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2944  "> <a class=g-menu-item-container href=/ubuntu-20-04-guide> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 20.04</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel="nofollow noopener" data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a href=https://bit.ly/2X5D30q rel="nofollow noopener" data-uk-tooltip="{pos:'bottom'}">Newsletter </a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a target=_blank href=https://feeds.linuxconfig.org/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-rss fa-fw"></span> <span class=g-social-text> RSS</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" /><noscript><img src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /></noscript></a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://bit.ly/linux-job-alert alt="Linux Jobs" rel=nofollow target=_blank><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png><noscript><img src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></noscript></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Guides</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2988 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Admin</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2997 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-3001 g-standard  "> <a class=g-menu-item-container href=/multimedia-games> <span class=g-menu-item-content> <span class=g-menu-item-title>Multimedia</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/how-to-remove-bloatware-from-your-samsung-android-mobile-phone method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=3152 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> How to Remove Bloatware From Your Samsung Android Mobile Phone </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Roel Van de Paar</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>Multimedia &amp; Games</span> </dd><dd class=modified> <time datetime=2020-11-17T12:57:49+11:00 itemprop=dateModified data-uk-tooltip title="Modified Date"> <i class="fa fa-clock-o"></i>17 November 2020	</time> </dd> </dl><div data-fuse=22189504503 class=incontent_ads></div></div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h1-software-requirements-and-conventions-used class='toclink toclink-h1'>1.&nbsp;Software requirements and conventions used</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h2-getting-setup class='toclink toclink-h1'>2.&nbsp;Getting setup</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h3-the-big-red-warning class='toclink toclink-h1'>3.&nbsp;The Big Red Warning</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h4-android-application-hierarchy class='toclink toclink-h1'>4.&nbsp;Android Application Hierarchy</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h5-removing-bloatware class='toclink toclink-h1'>5.&nbsp;Removing Bloatware</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h6-reinstalling-packages class='toclink toclink-h1'>6.&nbsp;Reinstalling Packages</a></li><li><a href=https://linuxconfig.org/how-to-remove-bloatware-from-your-samsung-android-mobile-phone#h7-conclusion class='toclink toclink-h1'>7.&nbsp;Conclusion</a></li></ul></li></ul></div><div itemprop=articleBody><p>Bloatware is a type of software which is installed by the product vendor (like Samsung) on top of the Android operating system in your mobile phone. But do you need all this extra software? The name clarifies; it makes your mobile bloated. Much of the utilities and services installed on your phone are simply not required, and at times may be annoying or consuming a fair bit of battery. Uninstalling a lot of these may buy you an extra day or two of battery power.</p><p>Uninstalling bloatware is made possible via ADB - the Android Debug Bridge, which is included in the stock Android SDK (Software Development Kit) and is available as an easy install on most modern Linux distributions. Setting up ADB and configuring is not the focus of this article, and you can find detailed instructions on how to do so in our <a href=/how-to-use-adb-android-debug-bridge-to-manage-your-android-mobile-phone>How to Use ADB Android Debug Bridge to Manage Your Android Mobile Phone</a> article.</p><p><strong>In this tutorial you will learn</strong>:</p><ul> <li>How to remove bloatware from your Android mobile phone via ADB</li> <li>What is likely safe to remove, and where you may run into problems</li> <li>That bloatware cleanups are generally personal, tuned to your usage</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/00-how-to-remove-bloatware-from-your-samsung-android-mobile-phone.png data-lightbox-type=image data-uk-lightbox={group:group1} title="How to Remove Bloatware From Your Samsung Android Mobile Phone"><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/00-how-to-remove-bloatware-from-your-samsung-android-mobile-phone.png alt="How to Remove Bloatware From Your Samsung Android Mobile Phone"><noscript><img src=https://linuxconfig.org/images/00-how-to-remove-bloatware-from-your-samsung-android-mobile-phone.png alt="How to Remove Bloatware From Your Samsung Android Mobile Phone" width=1200 height=717 /></noscript></a> <div class=uk-thumbnail-caption>How to Remove Bloatware From Your Samsung Android Mobile Phone</div></div></div><h2 id=h1-software-requirements-and-conventions-used>Software requirements and conventions used</h2><table class="uk-table uk-table-strIPed uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption><thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Linux Distribution-independent</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>Bash command line, Linux based system</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>Any utility which is not included in the Bash shell by default can be installed using <code>sudo apt-get install utility-name</code> (or <code>yum install</code> for RedHat based systems)</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td># - requires <a href=/linux-commands>linux-commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command<br>$ - requires <a href=/linux-commands>linux-commands</a> to be executed as a regular non-privileged user<br></td> </tr> </tbody> </table><h2 id=h2-getting-setup>Getting setup</h2><p>If you have not setup ADB yet, please read our <a href=/how-to-use-adb-android-debug-bridge-to-manage-your-android-mobile-phone>How to Use ADB Android Debug Bridge to Manage Your Android Mobile Phone</a> article first. </p><p>Once ADB setup, either using a physical USB cable or connected via your wireless network, starting a remote screen session for your Android mobile phone is exceedingly simple. The way to connect depends on whether you are connected via USB cable or via wireless.</p><p>If you are connected via USB, simple execute:</p><pre><code>$ adb devices
List of devices attached
UI84762QNI3 device
$ adb shell
z3s:/ $ 
</code></pre><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE NEWSLETTER & RSS</b><br>Subscribe to <a target=_blank href=https://feeds.linuxconfig.org/linuxconfig rel="nofollow noopener">RSS</a> and <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><div data-fuse=22189504506 class=incontent_ads></div><hr></div></div><p>The first command (<code>adb devices</code>) shows us that a single device is connected via USB (otherwise an IP address and port number would be shown). The second command (<code>adb shell</code>) brings us to the ADB shell, and it is from this ADB shell to your mobile phone that we can uninstall bloatware.</p><h2 id=h3-the-big-red-warning>The Big Red Warning</h2><p>As we alluded to in the <a href=/how-to-use-adb-android-debug-bridge-to-manage-your-android-mobile-phone>How to Use ADB Android Debug Bridge to Manage Your Android Mobile Phone</a> article, using ADB to remove bloatware is not without it&rsquo;s risks. You may (and will if you proceed) directly and substantially affect the working of your phone, and if you are not careful or understand what you are doing, you may potentially render it unusable.</p><p>I have used this procedure personally for two modern Samsung pones (S8 and S20) without any problem whatsoever, except that Facebook does not work very well. This almost surely related to the uninstallation of 3 Facebook related services/programs, and as many people use Facebook, I will list these separately in this article. I will also highlight some items that you should not uninstall.</p><p>In summary, please use the procedures here at your own risk, and any and all information is provided as-is, without warranties of any kind. Now that you have been warned, let&rsquo;s look at how to remove bloatware from your mobile phone if you like to proceed.</p><h2 id=h4-android-application-hierarchy>Android Application Hierarchy</h2><p>Each application (and likely most services) in Android are organized in a reverse hierarchical naming structure. Think about it like linuxconfig.org being written as org.linuxconfig, easy to understand but it looks a little weird the first time you see it.</p><p>So for example, one part of the Samsung Bixby service is named &lsquo;com.samsung.android.bixby.wakeup&rsquo; - i.e. the wake-up function for Bixby, in Android, in Samsung[.com]. So always read right to left if you are trying to understand what a particular service or application is or does. This reverse method is a fairly common practice in some other directory/tree based systems and software too.</p><p>To see what applications and services are currently installed on your phone, execute: <code>pm list packages</code> at the ADB shell:</p><pre><code>$ adb shell
z3s:/ $ pm list packages
package:com.samsung.android.provider.filterprovider
package:com.samsung.android.app.galaxyfinder
...long list of packages...
</code></pre><p>We can uninstall some of these packages, <em>but not all!</em>. For example, some packages which should never be removed in my opinion are <code>com.google.android.gms</code>, <code>com.google.android.gsf</code>, <code>com.google.android.tag</code>, and there are likely many more.</p><p>So what packages to remove? It depends. The Internet is quite full of all sorts of lists. I have compiled from many of these a master list if you will of many things that I consider bloatware. Let&rsquo;s discuss this next.</p><h2 id=h5-removing-bloatware>Removing Bloatware</h2><p>Cleaning up bloatware is a personal, custom to the user, experience. You may love Bixby. You may want to use full Facebook functionality, or really like full Google gaming experience. Thus, my master list of bloatware to remove is likely not your master list. </p><p>That said, you may rest assured that this master list was compiled from a good amount of resources online, often lists which were smaller or more limited. This list has also been researched to some extent, looking at what is safe and what is not. However, no guarantees are provided as stated earlier. Please do your own research.</p><p>What I would propose is to select only the packages you 1) recognize and 2) would like to remove. Copy and paste this master list, and edit it before you copy and paste your customized list to the ADB shell to execute it.</p><p>So without further ado, here is a master list of bloatware which I recommend to remove:</p><pre><code>pm uninstall -k --user 0 com.samsung.android.bixby.agent
pm uninstall -k --user 0 com.samsung.android.bixby.es.globalaction
pm uninstall -k --user 0 com.samsung.android.bixby.wakeup
pm uninstall -k --user 0 com.samsung.android.app.spage
pm uninstall -k --user 0 com.samsung.android.visionintelligence
pm uninstall -k --user 0 com.samsung.android.bixby.agent.dummy
pm uninstall -k --user 0 samsung.android.app.settings.bixby
pm uninstall -k --user 0 com.samsung.systemui.bixby2
pm uninstall -k --user 0 com.samsung.android.bixby.service
pm uninstall -k --user 0 com.samsung.android.bixby.plmsync
pm uninstall -k --user 0 com.samsung.android.bixby.voiceinput
pm uninstall -k --user 0 com.samsung.android.bixby.wakeup
pm uninstall -k --user 0 com.samsung.android.app.settings.bixby
pm uninstall -k --user 0 com.samsung.android.bixbyvision.framework
pm uninstall -k --user 0 com.samsung.android.app.routines
pm uninstall -k --user 0 com.samsung.android.aremoji
pm uninstall -k --user 0 flipboard.boxer.app
pm uninstall -k --user 0 com.sec.android.mimage.avatarstickers
pm uninstall -k --user 0 com.android.bips
pm uninstall -k --user 0 com.google.android.printservice.recommendation
pm uninstall -k --user 0 com.android.printspooler
pm uninstall -k --user 0 com.samsung.android.email.provider
pm uninstall -k --user 0 com.samsung.android.game.gamehome
pm uninstall -k --user 0 com.enhance.gameservice
pm uninstall -k --user 0 com.samsung.android.kidsinstaller
pm uninstall -k --user 0 com.samsung.android.game.gamehome
pm uninstall -k --user 0 com.samsung.android.game.gametools
pm uninstall -k --user 0 com.samsung.android.game.gos
pm uninstall -k --user 0 com.samsung.android.gametuner.thin
pm uninstall -k --user 0 com.samsung.android.app.camera.sticker.facearavatar.preload
pm uninstall -k --user 0 com.samsung.android.app.ledbackcover
pm uninstall -k --user 0 com.sec.android.cover.ledcover
pm uninstall -k --user 0 com.samsung.android.service.peoplestripe
pm uninstall -k --user 0 com.microsoft.appmanager
pm uninstall -k --user 0 com.microsoft.skydrive
pm uninstall -k --user 0 com.microsoft.office.officehubrow
pm uninstall -k --user 0 com.samsung.android.mateagent 
pm uninstall -k --user 0 com.samsung.android.app.watchmanager
pm uninstall -k --user 0 com.samsung.android.app.watchmanagerstub
pm uninstall -k --user 0 com.samsung.android.voc
pm uninstall -k --user 0 com.samsung.sree
pm uninstall -k --user 0 com.google.android.googlequicksearchbox
pm uninstall -k --user 0 com.netflix.partner.activation
pm uninstall -k --user 0 com.netflix.mediaclient
pm uninstall -k --user 0 com.samsung.android.stickercenter
pm uninstall -k --user 0 com.samsung.android.livestickers
pm uninstall -k --user 0 com.samsung.svoice.sync
pm uninstall -k --user 0 com.samsung.android.svoiceime
pm uninstall -k --user 0 com.samsung.android.svoice
pm uninstall -k --user 0 com.samsung.android.forest
pm uninstall -k --user 0 com.sec.android.app.samsungapps
pm uninstall -k --user 0 com.samsung.android.widgetapp.yahooedge.finance
pm uninstall -k --user 0 com.samsung.android.widgetapp.yahooedge.sport
pm uninstall -k --user 0 com.sec.android.widgetapp.easymodecontactswidget
pm uninstall -k --user 0 com.sec.android.widgetapp.webmanual
pm uninstall -k --user 0 com.yelp.android.samsungedge
pm uninstall -k --user 0 com.samsung.android.app.sbrowseredge
pm uninstall -k --user 0 com.cnn.mobile.android.phone.edgepanel
pm uninstall -k --user 0 com.enhance.gameservice
pm uninstall -k --user 0 com.dsi.ant.sample.acquirechannels
pm uninstall -k --user 0 com.dsi.ant.service.socket
pm uninstall -k --user 0 com.dsi.ant.server
pm uninstall -k --user 0 com.dsi.ant.plugins.antplus
pm uninstall -k --user 0 com.android.egg
pm uninstall -k --user 0 com.sec.android.easyonehand
pm uninstall -k --user 0 com.google.android.tts
pm uninstall -k --user 0 com.android.hotwordenrollment.xgoogle
pm uninstall -k --user 0 com.android.hotwordenrollment.okgoogle
pm uninstall -k --user 0 com.sec.android.app.kidshome
pm uninstall -k --user 0 com.samsung.android.fast
pm uninstall -k --user 0 com.google.android.partnersetup
pm uninstall -k --user 0 com.android.providers.partnerbookmarks
pm uninstall -k --user 0 com.google.android.videos
</code></pre><div class=moduletable><div class=custom><hr><div data-fuse=22189504224 class=incontent_ads></div><hr></div></div><p>A small note on &lsquo;com.google.android.videos&rsquo; - this not your Camera application nor Galaxy. It is rather &lsquo;Google TV&rsquo; (previously &lsquo;Play Movies &amp; TV&rsquo;). You can see how sometimes product naming can get slightly confusing.</p><p>Let&rsquo;s fist clarify what this specific uninstall command means in detail:</p><p><code>pm</code>: We are dealing with the package manager, hence <code>pm</code> <code>uninstall</code>: we will be uninstalling package(s) <code>-k</code>: as per the <code>pm</code> manual: &lsquo;keep the data and cache directories around after package removal&rsquo;. This important so we can reinstall it if necessary, though is not assured you will be able to do this. <code>--user 0</code>: only uninstall this for the specified user, typically 0 - ourselves <code>package name</code>: in reverse notation order as specified earlier</p><p>To get the full manual for <code>pm</code>, simply execute <code>pm</code> at the ADB shell.</p><p>As mentioned earlier, there are also some Facebook services which can likely be removed, though this may (or may not) affect how well Facebook applications work for you:</p><pre><code>pm uninstall -k --user 0 com.facebook.system
pm uninstall -k --user 0 com.facebook.appmanager
pm uninstall -k --user 0 com.facebook.services
</code></pre><p>There is also <code>com.facebook.katana</code> (The Facebook app) and <code>com.facebook.orca</code> (The Messenger app). </p><p>I noticed that when the 3 packages listed above (system, appmanager, services) are uninstalled, Facebook messenger sometimes fails to work well, but not always. If you do not use Facebook at all, it would seem possible to remove all the 5 related Facebook packages, though I never tried it.</p><p>Please do not blindly execute the full list at the ADB command shell without reviewing each line. Not that I believe anything would break (except Facebook as indicated if you include the second part), but simply because there are applications in there you may be using, like Bixby, Printing (printspooler), Flipboard, Google TV etc.</p><p>If you are unsure what a particular package does, simply copy and paste the full package name into your favorite search engine and you will find plenty of documentation on most of them.</p><p>When you are ready with your own list and copy/paste it in to the ADB shell, you will see output similar to the following:</p><pre><code>z3s:/ $ pm uninstall -k --user 0 com.android.egg
Success
</code></pre><p>Which means that the package was successfully uninstalled for your user id alone. As per the <code>-k</code> option, the data and cache directories are kept.</p><p>If you get the following error (ref second command output, first one is shown to highlight the situation):</p><pre><code>z3s:/ $ pm uninstall -k --user 0 com.android.egg
Success
z3s:/ $ pm uninstall -k --user 0 com.android.egg                                                                                    
Failure [not installed for 0]
</code></pre><div class=moduletable><div class=custom><hr><div data-fuse=22189504509 class=incontent_ads></div><hr></div></div><p>It simply means the package is either not present or already uninstalled. </p><h2 id=h6-reinstalling-packages>Reinstalling Packages</h2><p>If you ever need to reinstall a package, you can do so in two possible ways:</p><pre><code>z3s:/ $ cmd package install-existing com.android.egg
Package com.android.egg installed for user: 0
</code></pre><p>Or:</p><pre><code>z3s:/ $ pm install-existing --user 0 com.android.egg                                                                            
Package com.android.egg installed for user: 0
</code></pre><h2 id=h7-conclusion>Conclusion</h2><p>In this article, we learned how to remove bloatware from our Mobile Android phones. Not 100% without risk, but - at least in my view - more then safe enough to warrant the return on investment: extra battery life and no more (at times somewhat annoying) bloatware. Your phone may feel crisper, more responsive, and the battery will last longer. </p><p>While a large master list is provided for exploration, research and potential execution at the ADB shell, we also saw how removing package is a personal choice and that this choice often comes down to a package-by-package evaluation.</p><p>Leave us a comment with any things you found which are not on our master list yet, or if you have any tips to share!</p></div><ul class="pager pagenav"> <li class=previous> <a class=hasTooltip title="How to update Firefox on Linux" aria-label="Previous article: How to update Firefox on Linux" href=/how-to-update-firefox-on-linux rel=prev> <span class=icon-chevron-left aria-hidden=true></span> <span aria-hidden=true>Prev</span> </a> </li> <li class=next> <a class=hasTooltip title="How to Mirror Your Android Mobile Screen to Linux" aria-label="Next article: How to Mirror Your Android Mobile Screen to Linux" href=/how-to-mirror-your-android-mobile-screen-to-linux rel=next> <span aria-hidden=true>Next</span> <span class=icon-chevron-right aria-hidden=true></span> </a> </li> </ul> </article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>FIND LATEST <a href=https://www.linuxcareers.com/ target=_blank>LINUX JOBS</a> on LinuxCareers.com</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/install-pip-on-linux> Install pip on Linux </a> </li> <li> <a href=/how-to-rebuild-a-package-using-the-arch-linux-build-system> How to rebuild a package using the Arch Linux Build System </a> </li> <li> <a href=/install-npm-on-linux> Install npm on Linux </a> </li> <li> <a href=/manjaro-linux-kernel-headers-installation> Manjaro Linux kernel headers installation </a> </li> </ul> </div> </div></div><div class=platform-content><div class="moduletable "><div class=custom><hr><center><div data-fuse=22198552927></div></center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/src/assets/images/blank.gif data-src=https://linuxconfig.org/images/linuxconfig-forum-logo.png < img><noscript><img src=https://linuxconfig.org/images/linuxconfig-forum-logo.png </img></noscript></center><div id=discourse-comments></div> <script>DiscourseEmbed={discourseUrl:'https://forum.linuxconfig.org/',discourseEmbedUrl:window.location.href.split(/[?#]/)[0]};(function(){var d=document.createElement('script');d.type='text/javascript';d.async=true;d.src=DiscourseEmbed.discourseUrl+'javascripts/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(d);})();</script></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div data-fuse=22189504221 class=sticky_ads></div><hr style="margin: 3px" ;><div data-fuse=22189277162></div></span> <div id=endad style="position: absolute;bottom: 1120px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/ubuntu-20-04-download itemprop=url> <span itemprop=name>Ubuntu 20.04 Download </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade Ubuntu To 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/ubuntu-20-04-guide itemprop=url> <span itemprop=name>Ubuntu 20.04 Guide</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/linux-download itemprop=url> <span itemprop=name>Linux Download</span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-rip-an-audio-cd-from-the-command-line-using-cdparanoia itemprop=url> <span itemprop=name> How to rip an audio CD from the command line using cdparanoia </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-apache-on-ubuntu-20-04 itemprop=url> <span itemprop=name> How to install Apache on Ubuntu 20.04 </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/use-joomscan-to-scan-joomla-for-vulnerabilities-on-kali itemprop=url> <span itemprop=name> Use JoomScan to scan Joomla for vulnerabilities on Kali </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-change-mariadb-user-password itemprop=url> <span itemprop=name> How to change MariaDB user password </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-delete-user-on-ubuntu itemprop=url> <span itemprop=name> How to delete user on Ubuntu </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-provide-user-with-root-privileges-on-kali-linux itemprop=url> <span itemprop=name> How to provide user with root privileges on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-enable-root-login-on-kali-linux itemprop=url> <span itemprop=name> How to enable root login on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-vmware-tools-on-kali-linux itemprop=url> <span itemprop=name> How to install VMware Tools on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/introduction-to-database-normalization-the-first-three-normal-forms itemprop=url> <span itemprop=name> Introduction to database normalization: the first three normal forms </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-and-use-hex-editor-on-kali-linux itemprop=url> <span itemprop=name> How to install and use Hex editor on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-java-on-kali-linux itemprop=url> <span itemprop=name> How to install Java on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/kali-linux-keyboard-shortcuts-cheat-sheet itemprop=url> <span itemprop=name> Kali Linux keyboard shortcuts cheat sheet </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-enable-and-disable-wifi-on-kali-linux itemprop=url> <span itemprop=name> How to enable and disable WiFi on Kali Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-nvidia-drivers-on-kali-linux itemprop=url> <span itemprop=name> How to install Nvidia drivers on Kali linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/list-of-best-kali-linux-tools-for-penetration-testing-and-hacking itemprop=url> <span itemprop=name> List of best Kali Linux tools for penetration testing and hacking </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2021 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a target=_blank href=https://feeds.linuxconfig.org/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-rss fa-fw"></span> <span class=g-social-text> RSS</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/gantry5/assets/js/main.js></script> <script>(function($){$(document).ready(function(){$(window).scroll(function(){if($(document).scrollTop()<500||$(window).width()<767){$('#g-totop-button').removeClass('totopfixed');}else{$('#g-totop-button').addClass('totopfixed');}});});})(jQuery);</script> <script src=/templates/it_headlines/uikit/js/uikit.min.js></script> <script>(function($){$(window).load(function(){var headerSearch=$("#header-search");var headerSearchHeight=$("#g-navigation").innerHeight();var closeSearch=$("#header-search a.uk-close");var inputSearch=$("input#mod-search-searchword");var searchToggle=$("a#header-search-toggle");$(headerSearch).prependTo($("#g-navigation .g-grid:first")).css({'height':headerSearchHeight,'line-height':(headerSearchHeight)+'px'});$(closeSearch).css({'top':(headerSearchHeight/2)-10});$(inputSearch).css({'height':headerSearchHeight,'line-height':(headerSearchHeight)+'px'});$(searchToggle).on("click",function(e){e.preventDefault();$(headerSearch).fadeIn("fast");$(inputSearch).focus();});$(closeSearch).on("click",function(e){e.preventDefault();$(headerSearch).fadeOut("fast");});});})(jQuery);</script> <script src=/templates/it_headlines/js/template.js></script> <script>(function($){$(document).ready(function(){$("#g-container-site").addClass("g-container g-site-wrapper");});})(jQuery);</script> <script src=/templates/it_headlines/js/scrollReveal.min.js></script> <script>window.sr=new scrollReveal({mobile:false});</script> </body> </html>