<!DOCTYPE html>
<html lang="en-gb" dir="ltr">
        
<head>
            <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta http-equiv="X-UA-Compatible" content="IE=edge" />
        
            
    	<meta charset="utf-8" />
	<base href="https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2" />
	<meta name="keywords" content="data, compression, parallel, bzip2, pbzip2, tar, linux, command, fast, ratio" />
	<meta name="author" content="Lubos Rendek" />
	<meta name="description" content="How to perform a faster data compression with pbzip2" />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title>How to perform a faster data compression with pbzip2 - LinuxConfig.org</title>
	<link href="/plugins/content/autotoc/autotoc.css" rel="stylesheet" />
	<link href="/templates/it_headlines/uikit/css/uikit.min.css" rel="stylesheet" />
	<link href="/media/gantry5/assets/css/font-awesome.min.css" rel="stylesheet" />
	<link href="/media/gantry5/engines/nucleus/css-compiled/nucleus.css" rel="stylesheet" />
	<link href="/templates/it_headlines/custom/css-compiled/headlines_25.css" rel="stylesheet" />
	<link href="/media/gantry5/assets/css/bootstrap-gantry.css" rel="stylesheet" />
	<link href="/media/gantry5/engines/nucleus/css-compiled/joomla.css" rel="stylesheet" />
	<link href="/media/jui/css/icomoon.css" rel="stylesheet" />
	<link href="/templates/it_headlines/custom/css-compiled/headlines-joomla_25.css" rel="stylesheet" />
	<link href="/templates/it_headlines/custom/css-compiled/custom_25.css" rel="stylesheet" />
	<style>
div.mod_search93 input[type="search"]{ width:auto; }
			#header-search {
				background: #ffffff;
			}

			#header-search .search input, #header-search .uk-close, #header-search .uk-close:hover {
				color: #444444;
			}
		
	</style>
	<script src="/media/jui/js/jquery.min.js"></script>
	<script src="/media/jui/js/jquery-noconflict.js"></script>
	<script src="/media/jui/js/jquery-migrate.min.js"></script>
	<script src="/media/system/js/caption.js"></script>
	<script src="/media/system/js/html5fallback.js"></script>
	<script src="/media/jui/js/bootstrap.min.js"></script>
	<script>
jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});
	</script>

    <!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]-->
                        <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/180063765/LCONFIG_LEADERBOARD_TOP', [728, 90], 'div-gpt-ad-1485226089023-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
            </head>

    <body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-1904 outline-25 g-offcanvas-left g-default g-style-preset5">
        
        <div id="g-offcanvas"  data-g-offcanvas-swipe="0" data-g-offcanvas-css3="1">
                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                <div class="g-content g-particle">
                                <div id="g-mobilemenu-container" data-g-menu-breakpoint="60rem"></div>
            
    </div>
                        
    </div>
            
    </div>


    
</div>
        <div id="g-page-surround">
                        <div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div>
                                
                            

        
    
    
    
                <section id="g-container-site" class="g-wrapper">
                        


    
    
        <div class="g-container">            <section id="g-top">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-60">
                                                <div class="g-content">
                                    <div class="moduletable ">
						<div class="g-particle">
                            







<nav class="g-main-nav" role="navigation" data-g-hover-expand="true">
    <ul class="g-toplevel">
                                                                                            
        <li class="g-menu-item g-menu-item-type-component g-menu-item-498 g-standard  ">
            <a class="g-menu-item-container jsn-icon-contact" href="/contact-us">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Contact us</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1577 g-standard  ">
            <a class="g-menu-item-container" href="/write-for-us">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Write For Us</span>
            
                    </span>
                                                </a>
                                </li>
    
    
    </ul>
</nav>
            
    </div>		</div>
            
        </div>
                        
    </div>
                    

    <div         
         class="g-block hidden-phone size-40">
                                                <div class="g-content">
                                    <div class="moduletable ">
						<div class="g-particle">
                                    <div class="g-social">
                                                                        <a target="_blank" href="https://twitter.com/linuxconfig" data-uk-tooltip="{pos:'bottom'}" rel="nofollow">
                <span class="fa fa-twitter fa-fw"></span>
                <span class="g-social-text"> Twitter</span>            </a>
                                            <a  href="#rss" data-uk-tooltip="{pos:'bottom'}">
                <span class="fa fa-rss"></span>
                <span class="g-social-text"> RSS Feeds</span>            </a>
            </div>
            
    </div>		</div>
            
        </div>
                        
    </div>
            
    </div>


            
    </section>
    </div>
                    


    
    
        <div class="g-container">            <header id="g-header">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-30">
                                                <div class="g-content g-particle">
                                    
<a href="/" title="Linux Tutorials - Learn Linux Configuration" rel="home" class="g-logo ">
            <img src="/images/linuxconfig_logo.png" alt="Linux Tutorials - Learn Linux Configuration" />
    </a>
            
    </div>
                        
    </div>
                    

    <div         
         class="g-block hidden-phone size-70">
                                                <div class="g-content">
                                    <div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<!-- BuySellAds Ad Code -->
<script type="text/javascript">
(function(){
  var bsa = document.createElement('script');
     bsa.type = 'text/javascript';
     bsa.async = true;
     bsa.src = '//s3.buysellads.com/ac/bsa.js';
  (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
})();
</script>
<!-- End BuySellAds Ad Code -->
<!-- BuySellAds Zone Code -->
<div id="bsap_1305178" class="bsarocks bsap_0301574ad05d08ff34fb92f3369791d6"></div>
<!-- End BuySellAds Zone Code --></div>
		</div></div>
            
        </div>
                        
    </div>
            
    </div>


            
    </header>
    </div>
                    
                                

    
    
        <div class="g-container">            <section id="g-navigation" data-uk-sticky="">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-95">
                                                <div class="g-content g-particle">
                            







<nav class="g-main-nav" role="navigation" data-g-mobile-target data-g-hover-expand="true">
    <ul class="g-toplevel">
                                                                                            
        <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  ">
            <a class="g-menu-item-container jsn-icon-home" href="/" title="Start here">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Home</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-parent g-standard g-menu-item-link-parent ">
            <a class="g-menu-item-container" href="/linux-tutorials">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Linux Tutorials</span>
            
                    </span>
                    <span class="g-menu-parent-indicator" data-g-menuparent=""></span>                            </a>
                                                        <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-1 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-heading g-menu-item-1787 g-parent  ">
            <div class="g-menu-item-container" data-g-menuparent="">                                                                            <span class="g-nav-header g-menu-item-content">            <span class="g-menu-item-title">Programming</span>
            </span>
                                            <span class="g-menu-parent-indicator"></span>                            </div>                                            <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-2 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1789 g-parent g-menu-item-link-parent ">
            <a class="g-menu-item-container" href="/c-programming-tutorial">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">C Programming</span>
            
                    </span>
                    <span class="g-menu-parent-indicator" data-g-menuparent=""></span>                            </a>
                                                        <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-3 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1861  ">
            <a class="g-menu-item-container" href="http://how-to.linuxcareer.com/c-development-on-linux-introduction">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Introduction - I.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1862  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-comparison-between-c-and-other-programming-languages">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Comparison - II.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1863  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-types-variables-operators">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Variables - III.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1864  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-flow-control-iv">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Flow Control - IV.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1865  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-functions-v">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Functions - V.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1866  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-pointers-and-arrays-vi">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Pointers and Arrays - VI.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1867  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-structures-vii">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Structures - VII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1868  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-basic-io-viii">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Basic I/O - VIII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1869  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-coding-style-and-recommendations-ix">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Coding style - IX.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1870  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-building-a-program-x">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Building a program - X.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1871  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-packaging-for-debian-and-fedora-xi">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Packaging - XI.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1872  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/c-development-on-linux-getting-a-package-in-the-official-debian-repositories-xii">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Repositories - XII.</span>
            
                    </span>
                                                </a>
                                </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1790 g-parent g-menu-item-link-parent ">
            <a class="g-menu-item-container" href="/learn-python-fundamentals">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Python Fundamentals</span>
            
                    </span>
                    <span class="g-menu-parent-indicator" data-g-menuparent=""></span>                            </a>
                                                        <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-3 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1879  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-introduction-and-installation-guide">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Introduction - I.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1880  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-files-and-the-interpreter">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Interpreter - II.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1881  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/experimenting-with-numbers-and-text-in-python">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Numbers and Text - III.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1882  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-variables">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Variables - IV.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1883  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/working-with-number-variables-in-python">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Number Variables - V.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1884  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-string-basics">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">String Basics - VI.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1885  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/advanced-python-strings">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Advanced Strings - VII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1886  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-comments">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Comments - VIII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1887  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-lists">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Lists - IX.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1888  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-list-methods">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">List Methods - X.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1889  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-multidimensional-lists">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Multidimensional Lists - XI.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1890  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-tuples">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Tuples - XII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1891  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-boolean-operators">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Boolean Operators - XIII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1892  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-if-statements">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">If Statements - XIV.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1893  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-while-loops">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">While Loops - XV.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1894  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-for-loops">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">For Loops - XVI.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1895  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-dictionaries">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Dictionaries - XVII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1896  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-advanced-dictionaries">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Advanced Dictionaries - XVIII.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1897  ">
            <a class="g-menu-item-container" href="https://linuxconfig.org/python-functions">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Functions - XIX.</span>
            
                    </span>
                                                </a>
                                </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-heading g-menu-item-1788 g-parent  ">
            <div class="g-menu-item-container" data-g-menuparent="">                                                                            <span class="g-nav-header g-menu-item-content">            <span class="g-menu-item-title">System Administration</span>
            </span>
                                            <span class="g-menu-parent-indicator"></span>                            </div>                                            <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-2 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1791 g-parent g-menu-item-link-parent ">
            <a class="g-menu-item-container" href="/wine-installation-and-configuration-tutorial-on-linux">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">WINE</span>
            
                    </span>
                    <span class="g-menu-parent-indicator" data-g-menuparent=""></span>                            </a>
                                                        <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-3 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1873  ">
            <a class="g-menu-item-container" href="/wine-installation-and-configuration-tutorial-on-linux">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">About - I.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1874  ">
            <a class="g-menu-item-container" href="/introduction-to-wine">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Introduction - II.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1875  ">
            <a class="g-menu-item-container" href="/installing-wine">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Installation - III.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1876  ">
            <a class="g-menu-item-container" href="/configuring-wine-with-winecfg">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Configuration - IV.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1877  ">
            <a class="g-menu-item-container" href="/using-wine-prefixes">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Prefixes - V.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1878  ">
            <a class="g-menu-item-container" href="/configuring-wine-with-winetricks">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Winetricks - VI.</span>
            
                    </span>
                                                </a>
                                </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-heading g-menu-item-1855 g-parent  ">
            <div class="g-menu-item-container" data-g-menuparent="">                                                                            <span class="g-nav-header g-menu-item-content">            <span class="g-menu-item-title">Security</span>
            </span>
                                            <span class="g-menu-parent-indicator"></span>                            </div>                                            <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-2 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-heading g-menu-item-1856 g-parent  ">
            <div class="g-menu-item-container" data-g-menuparent="">                                                                            <span class="g-nav-header g-menu-item-content">            <span class="g-menu-item-title">Burp Suite</span>
            </span>
                                            <span class="g-menu-parent-indicator"></span>                            </div>                                            <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-3 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1857  ">
            <a class="g-menu-item-container" href="/learn-burp-suite-on-kali-linux-part-1">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Set up Burp Suite - I.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1858  ">
            <a class="g-menu-item-container" href="/learn-burp-suite-on-kali-linux-part-2">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Intercept Traffic - II.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1859  ">
            <a class="g-menu-item-container" href="/learn-burp-suite-on-kali-linux-part-3">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Brute Force Test - III.</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1860  ">
            <a class="g-menu-item-container" href="/learn-burp-suite-on-kali-linux-part-4">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Full Suite of Tools - IV.</span>
            
                    </span>
                                                </a>
                                </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-heading g-menu-item-1766 g-parent g-standard  ">
            <div class="g-menu-item-container" data-g-menuparent="">                                                                            <span class="g-nav-header g-menu-item-content">            <span class="g-menu-item-title">Linux Distros</span>
            </span>
                                            <span class="g-menu-parent-indicator"></span>                            </div>                                            <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
            <li class="g-dropdown-column">
                        <div class="g-grid">
                        <div class="g-block size-100">
            <ul class="g-sublevel">
                <li class="g-level-1 g-go-back">
                    <a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
                </li>
                                                                                                    
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1767  ">
            <a class="g-menu-item-container" href="/linux-distros/ubuntu">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Ubuntu</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1768  ">
            <a class="g-menu-item-container" href="/linux-distros/centos">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">CentOS</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1769  ">
            <a class="g-menu-item-container" href="/linux-distros/debian">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Debian</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1771  ">
            <a class="g-menu-item-container" href="/linux-distros/fedora">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Fedora</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1770  ">
            <a class="g-menu-item-container" href="/linux-distros/redhat">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Redhat</span>
            
                    </span>
                                                </a>
                                </li>
    
    
            </ul>
        </div>
            </div>

            </li>
        </ul>
            </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  ">
            <a class="g-menu-item-container" href="/system-administration">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">System Administration</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  ">
            <a class="g-menu-item-container" href="/programming-scripting">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Programming &amp; Scripting</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  ">
            <a class="g-menu-item-container" href="/linux-commands">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Linux Commands</span>
            
                    </span>
                                                </a>
                                </li>
    
                                                                                
        <li class="g-menu-item g-menu-item-type-url g-menu-item-1796 g-standard  ">
            <a class="g-menu-item-container" href="/write-for-us">
                                                                <span class="g-menu-item-content">
                                    <span class="g-menu-item-title">Write For Us</span>
            
                    </span>
                                                </a>
                                </li>
    
    
    </ul>
</nav>
            
    </div>
                        
    </div>
                    

    <div         
         class="g-block size-5">
                                                <div class="g-content">
                                    <div class="moduletable ">
						<div class="g-particle">
                                <div class="g-search-login" >
        <div class="g-buttons">
            
                <div class="g-search-button">
			<a id="header-search-toggle" href="/" data-uk-tooltip title="Search">
				<i class="fa fa-search"></i>
			</a>
		</div>
        
        
        

        </div>

                    	<div id="header-search">
		<div class="g-block">
			<div class="g-content">
				<a class="uk-close"></a>
											<div class="moduletable">
						<div class="search mod_search93">
	<form action="/how-to-perform-a-faster-data-compression-with-pbzip2" method="post" class="form-inline">
		<label for="mod-search-searchword" class="element-invisible">Search ...</label> <input autocomplete="off" name="searchword" id="mod-search-searchword" maxlength="200"  class="inputbox search-query" type="search" size="20" placeholder="Search ..." />		<input type="hidden" name="task" value="search" />
		<input type="hidden" name="option" value="com_search" />
		<input type="hidden" name="Itemid" value="1904" />
	</form>
</div>
		</div>
	
				
							</div>
		</div>
	</div>

        
            </div>
            
    </div>		</div>
            
        </div>
                        
    </div>
            
    </div>


            
    </section>
    </div>
                    


    
    
        <div class="g-container">            <section id="g-system-messages">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                

    <div class="g-system-messages">
                                            
            
    </div>
                        
    </div>
            
    </div>


            
    </section>
    </div>
                    

        
    
    
    
            <div class="g-container">    <section id="g-container-main" class="g-wrapper">
                    

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-67">
                                                


    
    
                    <section id="g-mainbody">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                

    <div class="g-content">
                                                            <div class="platform-content row-fluid"><div class="span12"><article class="item item-page" itemscope itemtype="https://schema.org/Article">
	<meta itemprop="inLanguage" content="en-GB" />
	
	
		
			<div class="g-article-header">
				<div class="page-header">
			<h2 itemprop="name">
				How to perform a faster data compression with pbzip2			</h2>
											</div>
									
						<dl class="article-info muted">

		
			<dt class="article-info-term">
									Details							</dt>

							<dd class="createdby" itemprop="author" itemscope itemtype="http://schema.org/Person">
					<span itemprop="name" data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Lubos Rendek</span>	</dd>			
			
							<dd class="category-name">
				<span itemprop="genre" itemprop="genre" data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration &amp; Configuration</span>	</dd>			
							<dd class="published">
	<time datetime="2017-03-10T20:12:30+11:00" itemprop="datePublished" data-uk-tooltip title="Published Date">
		<i class="fa fa-clock-o"></i>10 March 2017	</time>
</dd>					
					
			
						</dl>
			</div>
	
				
				
		<div class="autotoc" style="float:right;"><span>Contents</span><ul><li><ul><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h1-introduction' class='toclink toclink-h1'>1.&nbsp;Introduction</a></li><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h2-regular-tar-and-bzip2-compression' class='toclink toclink-h1'>2.&nbsp;Regular tar and bzip2 compression</a></li><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h3-faster-compression-with-bpzip2' class='toclink toclink-h1'>3.&nbsp;Faster compression with bpzip2</a><ul><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h3-1-reserve-resources' class='toclink toclink-h2'>3.1.&nbsp;Reserve Resources</a></li><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h3-2-compression-level' class='toclink toclink-h2'>3.2.&nbsp;Compression Level</a></li></ul></li><li><a href='https://linuxconfig.org/how-to-perform-a-faster-data-compression-with-pbzip2#h4-decopression' class='toclink toclink-h1'>4.&nbsp;Decopression</a></li></ul></li></ul></div>	<div itemprop="articleBody">
		<h2 id='h1-introduction'>Introduction</h2>
What if you would be able to perform a data compression four times faster, with the same compression ratio as you normally do. Pbzip2 command line utility can easily accomplish this as it gives you an option to select number CPU and amount of RAM to be used during the compression process. 
<h2 id='h2-regular-tar-and-bzip2-compression'>Regular tar and bzip2 compression</h2>
We all know the regular command to perform tar and bzip2 directory compression. The below command will <code>tar</code> and compress our sandbox directory <code>FOOBAR</code>. We are also prefixing the below command to get exact time for how long will it take to output compressed file <code>FOOBAR.tar.Bbz2</code> from 242MB FOOBAR  directory:
 <pre>
# time tar cjf FOOBAR1.tar.bz2 FOOBAR/

real    0m20.030s
user    0m19.828s
sys     0m0.304s
</pre>
From the above time output we can see that it took about 20 seconds to create following compressed file:
<pre>
# ls -lh FOOBAR1.tar.bz2 
-rw-r--r-- 1 root root 54M Mar 10 20:25 FOOBAR1.tar.bz2
</pre> 
<h2 id='h3-faster-compression-with-bpzip2'>Faster compression with bpzip2</h2>
<code>pbzip2</code> by default uses all available CPU's and 100MB RAM to perform compression. The following command will perform directory compression using <code>pbzip2</code>. Once again we use time to measure execution time:
<pre>
# time tar -c FOOBAR | pbzip2 -c > FOOBAR2.tar.bz2

real    0m4.777s
user    0m35.588s
sys     0m1.060s
</pre>
Alternatively, the bellow command will yield the same result:
<pre>
# time tar cf FOOBAR3.tar.bz2 --use-compress-prog=pbzip2 FOOBAR

real    0m4.764s
user    0m35.508s
sys     0m1.136s
</pre>
<h3 id='h3-1-reserve-resources'>Reserve Resources</h3>
As already mentioned, <code>pbzip2</code> allows user to select number of CPU's and amount of RAM to be dedicated to the compression. Below example is using only single CPU to perform requested compression:
<pre>
# time tar -c FOOBAR | pbzip2 -c -p1 > FOOBAR4.tar.bz2

real    0m20.348s
user    0m19.972s
sys     0m0.648s
</pre>
In order to dedicate selected amount of RAM use <code>-m</code> switch. By default pbzip2 uses 100MB. Example below performs compression using 1 CPU and 10MB of RAM:
<pre>
# time tar -c FOOBAR | pbzip2 -c -p1 -m10 > FOOBAR5.tar.bz2

real    0m20.362s
user    0m19.932s
sys     0m0.704s
</pre>
<h3 id='h3-2-compression-level'>Compression Level</h3>
As it is usually the case with any compression utilities, <code>pbzip2</code> also allows for compression ratio settings. The compression range is from 1 to 9, where default is 9 which is also the best compression ratio. To change compression rate to eg. <code>1</code> use <code>-1</code>:
<pre>
 time tar -c FOOBAR | pbzip2 -c -1 > FOOBAR6.tar.bz2

real    0m3.786s
user    0m28.612s
sys     0m0.364s
</pre>
Using the above example you will end up with a faster execution time but larger file name:
<pre>
 # ls -lh *.bz2
-rw-r--r-- 1 root root 54M Mar 10 20:02 FOOBAR1.tar.bz2
-rw-r--r-- 1 root root 54M Mar 10 20:41 FOOBAR2.tar.bz2
-rw-r--r-- 1 root root 54M Mar 10 20:43 FOOBAR3.tar.bz2
-rw-r--r-- 1 root root 54M Mar 10 20:48 FOOBAR4.tar.bz2
-rw-r--r-- 1 root root 54M Mar 10 20:54 FOOBAR5.tar.bz2
-rw-r--r-- 1 root root 67M Mar 10 21:00 FOOBAR6.tar.bz2
</pre>
<h2 id='h4-decopression'>Decopression</h2>
To preform a decompression using  <code>pbzip2</code> does to produce significant, if any,  time saving in comparison with <code>bzip2</code>. The following commands can be used to decompress bzip2 compressed data using <code>pbzip2</code> utility:
<pre>
# tar xf FOOBAR1.tar.bz2 --use-compress-prog=pbzip2
OR
# pbzip2 -dc FOOBAR1.tar.bz2 | tar x
</pre>
	</div>

	
	
							</article></div></div>
    
            
    </div>
                        
    </div>
            
    </div>


                    

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                <div class="g-content">
                                    <div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LINUXCONFIG-REPONSIVE-BOTTOM-LINKS -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="3873304447"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Bottom Under Links -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="7045095412"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center>
<div id="disqus_thread"></div>
<script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        this.page.url = PAGE_URL;  // Replace PAGE_URL with your page's canonical URL variable
        this.page.identifier = PAGE_IDENTIFIER; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
    };
    */
    (function() {  // DON'T EDIT BELOW THIS LINE
        var d = document, s = d.createElement('script');
        
        s.src = '//linuxconfig.disqus.com/embed.js';
        
        s.setAttribute('data-timestamp', +new Date());
        (d.head || d.body).appendChild(s);
    })();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>



</div>
		</div></div>
            
        </div>
                        
    </div>
            
    </div>


            
    </section>
    
                            
    </div>
                    

    <div         
         class="g-block size-33">
                                                


    
    
                    <aside id="g-aside">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                <div class="g-content">
                                    <div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ADS -Top right banner Advertisement (1) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="6488865241"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></div><div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<p>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ADS -Top right banner Advertisement (2) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="9551408045"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</p></div>
		</div></div><div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<p>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:300px"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="8135664842"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</p></div>
		</div></div><div class="platform-content"><div class="moduletable ">
						

<div class="custom"  >
	<p>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ADS -Top right banner Advertisement (3) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4906753266448300"
     data-ad-slot="2811998046"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</p></div>
		</div></div><div class="moduletable ">
							<h3 class="g-title"><span>Linux Tutorials / Configurations</span></h3>
						<div class="g-particle">
                            	<div class="g-news-pro" >
				<div class="uk-slidenav-position" data-uk-slideset="{duration: 200,  animation: 'fade'}">
						<div class="uk-slider-container">
				<div class="uk-slideset uk-grid">
								<div class="g-news-pro-page">
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/how-to-perform-a-faster-data-compression-with-pbzip2">
													How to perform a faster data compression with pbzip2
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/manage-vim-plugins-with-pathogen">
													Manage Vim Plugins With Pathogen
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/how-to-install-latest-firefox-browser-on-debian-9-stretch-linux">
													How to install latest Firefox Browser on Debian 9 Stretch Linux
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/tweet-from-the-linux-command-line-with-rainbow-stream">
													Tweet From the Linux Command Line With Rainbow Stream
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/python-encapsulation">
													Python Encapsulation
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-4">
													Learn Burp Suite on Kali Linux: Part 4
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-3">
													Learn Burp Suite on Kali Linux: Part 3
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-2">
													Learn Burp Suite on Kali Linux: Part 2
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-1">
													Learn Burp Suite on Kali Linux: Part 1
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/python-constructors">
													Python Constructors
												</a>
											</h4>
																																																	</div>
															</div>
						

									</div>
					</div>
	
				</div>
			</div>
				
					</div>
	</div>
            
    </div>		</div>
            
        </div>
                        
    </div>
            
    </div>


            
    </aside>
    
                            
    </div>
            
    </div>


    
    </section>
    </div>
                    


    
    
        <div class="g-container">            <footer id="g-footer">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-25">
                                                <div class="g-content">
                                    <div class="moduletable ">
							<h3 class="g-title"><span>About</span></h3>
						<div class="g-particle">
                                    LinuxConfig.org team is determined to provide you with simple to follow Linux tutorials, various tips, tricks and programming guides as well as with GNU/Linux system administration tutorials in general to help you to learn Linux faster and use it with ease. 
<br><br>
Any comments, constructive feedback or your <a href=floss-technical-writer-linuxconfig-org><b>involvement</b></a> is welcome. 
<br><br>
Contact:

            
    </div>		</div><div class="moduletable ">
						<div class="g-particle">
                                <div class="g-contacts uk-margin-top" >
                				        	<div class="g-contacts-item" >
                				<span class="g-contacts-icon fa fa-envelope-o"></span>				<span class="g-contact-value">web ( at ) linuxconfig ( dot ) org</span>                            </div>
            </div>
            
    </div>		</div>
            
        </div>
                        
    </div>
                    

    <div         
         class="g-block size-25">
                                                <div class="g-content">
                                    <div class="moduletable ">
							<h3 class="g-title"><span>Write For Us</span></h3>
						<div class="g-particle">
                                    LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. 
<br><br>


<a class="button" href="/floss-technical-writer-linuxconfig-org">Read More...</a>

            
    </div>		</div>
            
        </div>
                        
    </div>
                    

    <div         
         class="g-block size-25">
                                                <div class="g-content">
                                    <div class="moduletable ">
							<h3 class="g-title"><span>Linux Tutorials / Configs</span></h3>
						<div class="g-particle">
                            	<div class="g-news-pro" >
				<div class="uk-slidenav-position" data-uk-slideset="{duration: 200, autoplay: 'true', autoplayInterval: 7000, animation: 'fade'}">
						<div class="uk-slider-container">
				<div class="uk-slideset uk-grid">
								<div class="g-news-pro-page">
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/how-to-perform-a-faster-data-compression-with-pbzip2">
													How to perform a faster data compression with...
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>March 10
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/manage-vim-plugins-with-pathogen">
													Manage Vim Plugins With Pathogen
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>March 05
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/how-to-install-latest-firefox-browser-on-debian-9-stretch-linux">
													How to install latest Firefox Browser on Debian...
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>March 02
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
					</div>
			<div class="g-news-pro-page">
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																	<div class="g-news-pro-image image-link" style="															background-image: url(/images/rainbowstream.jpg)
													; 							width: 120px
						; 							height: 75px
						;">
																					<a href="/tweet-from-the-linux-command-line-with-rainbow-stream"></a>
																			</div>
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/tweet-from-the-linux-command-line-with-rainbow-stream">
													Tweet From the Linux Command Line With Rainbow...
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 28
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/python-encapsulation">
													Python Encapsulation
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 27
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>Programming &amp; Scripting
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																	<div class="g-news-pro-image image-link" style="															background-image: url(/images/burp-intruder-target.jpg)
													; 							width: 120px
						; 							height: 75px
						;">
																					<a href="/learn-burp-suite-on-kali-linux-part-4"></a>
																			</div>
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-4">
													Learn Burp Suite on Kali Linux: Part 4
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 26
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
					</div>
			<div class="g-news-pro-page">
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																	<div class="g-news-pro-image image-link" style="															background-image: url(/images/burp-unsuccessful-wp-params.jpg)
													; 							width: 120px
						; 							height: 75px
						;">
																					<a href="/learn-burp-suite-on-kali-linux-part-3"></a>
																			</div>
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-3">
													Learn Burp Suite on Kali Linux: Part 3
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 26
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																	<div class="g-news-pro-image image-link" style="															background-image: url(/images/burp-proxy-capture.jpg)
													; 							width: 120px
						; 							height: 75px
						;">
																					<a href="/learn-burp-suite-on-kali-linux-part-2"></a>
																			</div>
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-2">
													Learn Burp Suite on Kali Linux: Part 2
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 26
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
							<div class="uk-grid uk-grid-width-1-1">
					
						
						
						
						
													<div class="g-news-pro-item horizontal">
																	<div class="g-news-pro-image image-link" style="															background-image: url(/images/burp-proxy-ff.jpg)
													; 							width: 120px
						; 							height: 75px
						;">
																					<a href="/learn-burp-suite-on-kali-linux-part-1"></a>
																			</div>
																									<div class="g-info-container">
																					<h4 class="g-news-pro-title">
												<a href="/learn-burp-suite-on-kali-linux-part-1">
													Learn Burp Suite on Kali Linux: Part 1
												</a>
											</h4>
																															<div class="g-article-details">
																									<span class="g-article-date">
																													<i class="fa fa-clock-o"></i>February 26
																											</span>
												
												
																																						<span class="g-article-category">
																																											<i class="fa fa-folder-open"></i>System Administration &amp; Configuration
																											</span>
												
																							</div>
																																							</div>
															</div>
						

									</div>
					</div>
	
				</div>
			</div>
				
					</div>
	</div>
            
    </div>		</div>
            
        </div>
                        
    </div>
                    

    <div         
         class="g-block size-25">
                                                <div class="g-content">
                                    <div class="moduletable ">
							<h3 class="g-title"><span>RSS Feeds</span></h3>
						<div class="g-particle">
                                    LinuxConfig.org's category RSS list:
            
    </div>		</div><div class="moduletable ">
						<div class="g-particle">
                                <div class="g-contacts uk-margin-top" >
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=19&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">System Administration</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=17&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">Programming & Scripting</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=8&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">Ubuntu</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=10&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">CentOS</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=13&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">Debian</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=15&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">Fedora</span>                </a>            </div>
                											        	<div class="g-contacts-item"  rel="nofollow">
                <a target="_blank" href="https://linuxconfig.org/index.php?format=feed&amp;id=14&amp;option=com_content&amp;type=rss&amp;view=category">				<span class="g-contacts-icon fa fa-rss-square"></span>				<span class="g-contact-value">Redhat</span>                </a>            </div>
            </div>
            
    </div>		</div>
            
        </div>
                        
    </div>
            
    </div>


            
    </footer>
    </div>
                    


    
    
        <div class="g-container">            <section id="g-copyright">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-50">
                                                <div class="g-content">
                                    <div class="moduletable ">
						<div class="g-particle">
                                &copy;
    2007 -     2017
    <a name=rss>LinuxConfig.org</a>
            
    </div>		</div>
            
        </div>
                        
    </div>
                    

    <div         
         class="g-block size-50">
                                                <div class="g-content">
                                    <div class="moduletable ">
						<div class="g-particle">
                                    <div class="g-social">
                                                                        <a target="_blank" href="https://twitter.com/linuxconfig" data-uk-tooltip="{pos:'bottom'}" rel="nofollow">
                <span class="fa fa-twitter fa-fw"></span>
                <span class="g-social-text"> Twitter</span>            </a>
                                            
            </div>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-40602308-3', 'auto');
  ga('send', 'pageview');

</script>


            
    </div>		</div>
            
        </div>
                        
    </div>
            
    </div>


            
    </section>
    </div>
        
    </section>
    
                    


    
    
        <div class="g-container">            <section id="g-to-top">
                                

    <div          
         class="g-grid">
                              

    <div         
         class="g-block size-100">
                                                <div class="g-content g-particle">
                            <div class=" g-particle">
    <div class="g-totop style1">
        <a href="#" id="g-totop-button" rel="nofollow" data-uk-smooth-scroll>
            <i class="fa fa-angle-up"></i>                    </a>
    </div>
</div>
            
    </div>
                        
    </div>
            
    </div>


            
    </section>
    </div>
            
                    
        </div>
        <script type="text/javascript" src="/media/gantry5/assets/js/main.js"></script>
                        <script type="text/javascript">
		(function($) {
			$(document).ready(function() {
				$(window).scroll(function() {
					if ($(document).scrollTop() < 500 || $(window).width() < 767) {
				        $('#g-totop-button').removeClass('totopfixed');

				    } else {
				        $('#g-totop-button').addClass('totopfixed');

				    }
				});
			});
		})(jQuery);
	</script>
    <script type="text/javascript" src="/templates/it_headlines/uikit/js/uikit.min.js"></script>
    <script type="text/javascript">
			(function($) {
				// Header Search
				$(window).load(function() {
					var headerSearch = $("#header-search");
					var headerSearchHeight = $("#g-navigation").innerHeight();
					var closeSearch = $("#header-search a.uk-close");
					var inputSearch = $("input#mod-search-searchword");
					var searchToggle = $("a#header-search-toggle");

					$(headerSearch).prependTo($("#g-navigation .g-grid:first")).css({
						'height' : headerSearchHeight,
						'line-height' : (headerSearchHeight) + 'px'
					});

					$(closeSearch).css({
						'top' : (headerSearchHeight / 2) - 10 
					});

					$(inputSearch).css({
						'height' : headerSearchHeight,
						'line-height' : (headerSearchHeight) + 'px'
					});

					$(searchToggle).on("click", function(e) {
						e.preventDefault();
						$(headerSearch).fadeIn("fast");
						$(inputSearch).focus();
					});

					$(closeSearch).on("click", function(e) {
						e.preventDefault();
						$(headerSearch).fadeOut("fast");
					});
				});
			})(jQuery);
		</script>
    <script type="text/javascript" src="/templates/it_headlines/js/template.js"></script>
    <script type="text/javascript">
	        	(function($) {
					// Add a wrapping DIV (Wrapper) to the site
					$(document).ready(function() {
						$("#g-container-site").addClass("g-container g-site-wrapper");
					});
				})(jQuery);
	        </script>
    <script type="text/javascript" src="/templates/it_headlines/js/scrollReveal.min.js"></script>
    <script type="text/javascript">
			window.sr = new scrollReveal({ mobile: false });
		</script>
    

    

        
    </body>
</html>
