<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/how-to-install-kafka-on-redhat-8 /><meta name=keywords content="install, kafka, redhat, rhel, 8, linux, how to" /><meta name=author content=admin /><meta name=description content="Installing Apache Kafka on Red Hat Enterprise Linux 8, creating systemd service files, and testing with command line clients" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>How to install kafka on RHEL 8 - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/8IL00A6ZVvn8kLikKDuxLCbm0rA.js"></script><link href="https://linuxconfig.org/component/search/?Itemid=2488&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style><link rel=preload href=/media/plg_jchoptimize/cache/css/b2be613ade7f39f1fa7bc709d16fbe02_0.css as=style onload="this.onload=null;this.rel='stylesheet'"><noscript><link rel=stylesheet href=/media/plg_jchoptimize/cache/css/b2be613ade7f39f1fa7bc709d16fbe02_0.css></noscript> <script>(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){};}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload");}catch(e){ret=false;}
return function(){return ret;};})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener){link.removeEventListener("load",enableStylesheet);}else if(link.attachEvent){link.detachEvent("onload",enableStylesheet);}
link.setAttribute("onload",null);link.media=finalMedia;}
if(link.addEventListener){link.addEventListener("load",enableStylesheet);}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet);}
setTimeout(function(){link.rel="stylesheet";link.media="only x";});setTimeout(enableStylesheet,3000);};rp.poly=function(){if(rp.support()){return;}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",true);rp.bindMediaToggle(link);}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run);});}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run);});}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS;}
else{w.loadCSS=loadCSS;}}(typeof global!=="undefined"?global:this));</script><noscript><style>.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2488 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=https://bit.ly/2X5D30q rel=nofollow data-uk-tooltip="{pos:'bottom'}">Newsletter </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" /><noscript><img src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /></noscript></a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://bit.ly/linux-job-alert alt="Linux Jobs" rel=nofollow target=_blank><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png><noscript><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png class=jch-lazyload width=468 height=60 /><noscript><img src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></noscript></noscript></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org//images/new-badge-red-30.png alt="Linux Jobs" /><noscript><img src=https://linuxconfig.org//images/new-badge-red-30.png alt="Linux Jobs" width=30 height=30 /></noscript> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/how-to-install-kafka-on-redhat-8 method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=2488 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> How to install kafka on RHEL 8 </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>admin</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>Redhat / CentOS</span> </dd><dd class=published> <time datetime=2020-01-10T11:38:05+11:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>10 January 2020	</time> </dd> </dl><div class=article-position> <center><div id=div-gpt-ad-1407836039689-0> </center> </div> </div><div itemprop=articleBody><p>Apache Kafka is a distributed streaming platform. With it's rich API (Application Programming Interface) set, we can connect mostly anything to Kafka as source of data, and on the other end, we can set up a large number of consumers that will receive the steam of records for processing. Kafka is highly scaleable, and stores the streams of data in a reliable and fault-tolerant way. From the connectivity perspective, Kafka can serve as a bridge between many heterogeneous systems, which in turn can rely on it's capabilities to transfer and persist the data provided.</p><p>In this tutorial we will install Apache Kafka on a Red Hat Enterprise Linux 8, create the <code>systemd</code> unit files for ease of management, and test the functionality with the shipped command line tools.</p> <strong>In this tutorial you will learn:</strong> <ul> <li>How to install Apache Kafka</li> <li>How to create systemd services for Kafka and Zookeeper</li> <li>How to test Kafka with command line clients</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/01-install-kafka-on-redhat-8.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Consuming messages on Kafka topic from the command line."><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/01-install-kafka-on-redhat-8.png alt="Consuming messages on Kafka topic from the command line."><noscript><img src=https://linuxconfig.org/images/01-install-kafka-on-redhat-8.png alt="Consuming messages on Kafka topic from the command line." width=1421 height=756 /></noscript></a> <div class=uk-thumbnail-caption>Consuming messages on Kafka topic from the command line.</div></div></div><h2>Software Requirements and Conventions Used</h2><table class="uk-table uk-table-striped uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption> <thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Red Hat Enterprise Linux 8</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>Apache Kafka 2.11</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>Privileged access to your Linux system as root or via the <code>sudo</code> command.</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td> <b>#</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</br> <b>$</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed as a regular non-privileged user </td> </tbody> </table><h2>How to install kafka on Redhat 8 step by step instructions</h2><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to Linux Career <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><p>Apache Kafka is written in Java, so all we need is <a href=/how-to-install-java-on-redhat-8-linux target=_blank>OpenJDK 8 installed</a> to proceed with the installation. Kafka relies on Apache Zookeeper, a distributed coordination service, that is also written in Java, and is shipped with the package we will download. While installing HA (High Availability) services to a single node does kill their purpose, we'll install and run Zookeeper for Kafka's sake.</p><ol class=steps> <li>To download Kafka from the closest mirror, we need to consult the <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.1.0/kafka_2.11-2.1.0.tgz" target=_blank>official download site</a>. We can copy the URL of the <code>.tar.gz</code> file from there. We'll use <code>wget</code>, and the URL pasted to download the package to the target machine: <pre><code># wget https://www-eu.apache.org/dist/kafka/2.1.0/kafka_2.11-2.1.0.tgz -O /opt/kafka_2.11-2.1.0.tgz</code></pre></li> <li>We enter the <code>/opt</code> directory, and extract the archive: <pre><code># cd /opt
# tar -xvf kafka_2.11-2.1.0.tgz</code></pre> And create a symlink called <code>/opt/kafka</code> that points to the now created <code>/opt/kafka_2_11-2.1.0</code> directory to make our lives easier. <pre><code>ln -s /opt/kafka_2.11-2.1.0 /opt/kafka</code></pre></li> <li>We create a non-privileged user that will run both <code>zookeeper</code> and <code>kafka</code> service. <pre><code># useradd kafka</code></pre></li> <li>And set the new user as owner of the whole directory we extracted, recursively: <pre><code># chown -R kafka:kafka /opt/kafka*</code></pre></li> <li>We create the unit file <code>/etc/systemd/system/zookeeper.service</code> with the following content: <div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><pre class="language-bash line-numbers"><code>[Unit]
Description=zookeeper
After=syslog.target network.target

[Service]
Type=simple

User=kafka
Group=kafka

ExecStart=/opt/kafka/bin/zookeeper-server-start.sh /opt/kafka/config/zookeeper.properties
ExecStop=/opt/kafka/bin/zookeeper-server-stop.sh

[Install]
WantedBy=multi-user.target</code></pre> Note that we don't need to write the version number three times because of the symlink we created. The same applies to the next unit file for Kafka, <code>/etc/systemd/system/kafka.service</code>, that contains the following lines of configuration: <pre class="language-bash line-numbers"><code>[Unit]
Description=Apache Kafka
Requires=zookeeper.service
After=zookeeper.service

[Service]
Type=simple

User=kafka
Group=kafka

ExecStart=/opt/kafka/bin/kafka-server-start.sh /opt/kafka/config/server.properties
ExecStop=/opt/kafka/bin/kafka-server-stop.sh

[Install]
WantedBy=multi-user.target</code></pre></li> <li>We need to reload <code>systemd</code> to get it read the new unit files: <div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><pre><code># systemctl daemon-reload</code></pre></li> <li>Now we can start our new services (in this order): <pre><code># systemctl start zookeeper
# systemctl start kafka</code></pre> If all goes well, <code>systemd</code> should report running state on both service's status, similar to the outputs below: <pre><code># systemctl status zookeeper.service
  zookeeper.service - zookeeper
   Loaded: loaded (/etc/systemd/system/zookeeper.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-01-10 20:44:37 CET; 6s ago
 Main PID: 11628 (java)
    Tasks: 23 (limit: 12544)
   Memory: 57.0M
   CGroup: /system.slice/zookeeper.service
            11628 java -Xmx512M -Xms512M -server [...]

# systemctl status kafka.service
  kafka.service - Apache Kafka
   Loaded: loaded (/etc/systemd/system/kafka.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-01-10 20:45:11 CET; 11s ago
 Main PID: 11949 (java)
    Tasks: 64 (limit: 12544)
   Memory: 322.2M
   CGroup: /system.slice/kafka.service
            11949 java -Xmx1G -Xms1G -server [...]</code></pre></li> <li>Optionally we can enable automatic start on boot for both services: <pre><code># systemctl enable zookeeper.service
# systemctl enable kafka.service</code></pre></li> <li>To test functionality, we'll connect to Kafka with one producer and one consumer client. The messages provided by the producer should appear on the console of the consumer. But before this we need a medium these two exchange messages on. We create a new channel of data called <code>topic</code> in Kafka's terms, where the provider will publish, and where the consumer will subscribe to. We'll call the topic <code>FirstKafkaTopic</code>. We'll use the <code>kafka</code> user to create the topic: <pre><code>$ /opt/kafka/bin/kafka-topics.sh --create --zookeeper localhost:2181 --replication-factor 1 --partitions 1 --topic FirstKafkaTopic</code></pre></li><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to Linux Career <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><li>We start a consumer client from the command line that will subscribe to the (at this point empty) topic created in the previous step: <pre><code>$ /opt/kafka/bin/kafka-console-consumer.sh --bootstrap-server localhost:9092 <b>--topic FirstKafkaTopic</b> --from-beginning</code></pre> We leave the console and the client running in it open. This console is where we will receive the message we publish with the producer client.</li> <li>On another terminal, we start a producer client, and publish some messages to the topic we created. We can query Kafka for available topics: <pre><code>$ /opt/kafka/bin/kafka-topics.sh --list --zookeeper localhost:2181
FirstKafkaTopic</code></pre> And connect to the one the consumer is subscribed, then send a message: <pre><code>$ /opt/kafka/bin/kafka-console-producer.sh --broker-list localhost:9092 --topic FirstKafkaTopic
&gt; new message published by producer from console #2</code></pre> At the consumer terminal, the message should appear shortly: <pre><code>$ /opt/kafka/bin/kafka-console-consumer.sh --bootstrap-server localhost:9092 --topic FirstKafkaTopic --from-beginning
 new message published by producer from console #2</code></pre> If the message appears, our test is successful, and our Kafka installation is working as intended. Many clients could provide and consume one or more topic records the same way, even with a single node setup we created in this tutorial.</li> </ol> </div> </article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>ARE YOU LOOKING FOR A LINUX JOB?</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed on LinuxCareers.com.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><h3 class=g-title><span>You may also be interested in:</span></h3><center> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-4906753266448300 data-ad-slot=5538448164></ins><hr><div id=div-gpt-ad-1407836042106-0> </div> </center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/linuxconfig-forum-logo.png < img><noscript><img src=https://linuxconfig.org/images/linuxconfig-forum-logo.png </img width=250 height=46 /></noscript></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div id=div-gpt-ad-1407836095114-0> </div><hr style="margin: 3px" ;><div id=div-gpt-ad-1407836250753-0> </div> </span> <div id=endad style="position: absolute;bottom: 1400px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=/media/plg_jchoptimize/cache/js/e4219312b1707fa5d28f497ae74cf407_0.js></script> <script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/how-to-install-apache-tomcat-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install apache tomcat on Linux RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/installing-apache-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install Apache on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/install-ssh-server-on-redhat-8 itemprop=url> <span itemprop=name>Install ssh server on CentOS 8 / RHEL 8</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-check-and-monitor-cpu-utilization-on-linux itemprop=url> <span itemprop=name> How to Check and Monitor CPU utilization on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-atom-text-editor-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to Install Atom Text Editor on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/list-of-latex-editors-and-compilers-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> List of LaTeX editors and compilers on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-latex-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to install LaTex on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-schedule-tasks-with-systemd-timers-in-linux itemprop=url> <span itemprop=name> How to schedule tasks with systemd timers in Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-hibernate-ubuntu-20-04-focal-fossa-linux-desktop itemprop=url> <span itemprop=name> How to hibernate Ubuntu 20.04 Focal Fossa Linux Desktop </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-aws-cli-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to Install AWS CLI on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-kotlin-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to install Kotlin on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-android-studio-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to Install Android Studio on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-suspend-ubuntu-20-04-focal-fossa-linux-desktop itemprop=url> <span itemprop=name> How to suspend Ubuntu 20.04 Focal Fossa Linux Desktop </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/disable-turn-off-lock-screen-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> Disable / Turn Off Lock Screen on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-change-fqdn-domain-name-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to change FQDN ( domain name ) on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-change-hostname-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to change hostname on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-test-microphone-on-ubuntu-20-04-focal-fossa itemprop=url> <span itemprop=name> How to test microphone on Ubuntu 20.04 Focal Fossa </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-test-webcam-on-ubuntu-20-04-focal-fossa itemprop=url> <span itemprop=name> How to test webcam on Ubuntu 20.04 Focal Fossa </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2020 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/plg_jchoptimize/cache/js/e4219312b1707fa5d28f497ae74cf407_1.js></script> </body> </html>