<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge"/><meta charset=utf-8 /><base href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux /><meta name=keywords content="debian, install, gitlab, server, linux, stretch, 9, command, system, git"/><meta name=author content="Nick Congleton"/><meta name=description content="Install Gitlab version control on Debian Stretch."/><meta name=generator content="Joomla! - Open Source Content Management"/><title>How to Install Gitlab On Debian 9 Stretch Linux - LinuxConfig.org</title><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><script type="text/javascript">
//<![CDATA[
var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-40602308-3']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();(function(b){(function(a){"__CF"in b&&"DJS"in b.__CF?b.__CF.DJS.push(a):"addEventListener"in b?b.addEventListener("load",a,!1):b.attachEvent("onload",a)})(function(){"FB"in b&&"Event"in FB&&"subscribe"in FB.Event&&(FB.Event.subscribe("edge.create",function(a){_gaq.push(["_trackSocial","facebook","like",a])}),FB.Event.subscribe("edge.remove",function(a){_gaq.push(["_trackSocial","facebook","unlike",a])}),FB.Event.subscribe("message.send",function(a){_gaq.push(["_trackSocial","facebook","send",a])}));"twttr"in b&&"events"in twttr&&"bind"in twttr.events&&twttr.events.bind("tweet",function(a){if(a){var b;if(a.target&&a.target.nodeName=="IFRAME")a:{if(a=a.target.src){a=a.split("#")[0].match(/[^?=&]+=([^&]*)?/g);b=0;for(var c;c=a[b];++b)if(c.indexOf("url")===0){b=unescape(c.split("=")[1]);break a}}b=void 0}_gaq.push(["_trackSocial","twitter","tweet",b])}})})})(window);//]]>
</script><script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:0,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"98af843ffa60a95a43e5b5afe7298d1c",petok:"58cd1f5ed986db35783fbc79b156ef69eb586dac-1498826749-86400",zone:"linuxconfig.org",rocket:"0",apps:{"ga_key":{"ua":"UA-40602308-3","ga_bs":"2"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=85b614c0f6/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>
</script>
<style>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</style> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-1979 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-498 g-standard  "> <a class="g-menu-item-container jsn-icon-contact" href=/contact-us> <span class=g-menu-item-content> <span class=g-menu-item-title>Contact us</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1577 g-standard  "> <a class=g-menu-item-container href=/write-for-us> <span class=g-menu-item-content> <span class=g-menu-item-title>Write For Us</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=#rss data-uk-tooltip="{pos:'bottom'}"> <span class="fa fa-rss"></span> <span class=g-social-text> RSS Feeds</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration"/> </a> </div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-95"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1766 g-parent g-standard  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Linux Distros</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1767  "> <a class=g-menu-item-container href=/linux-distros/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1768  "> <a class=g-menu-item-container href=/linux-distros/centos> <span class=g-menu-item-content> <span class=g-menu-item-title>CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1769  "> <a class=g-menu-item-container href=/linux-distros/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1771  "> <a class=g-menu-item-container href=/linux-distros/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1770  "> <a class=g-menu-item-container href=/linux-distros/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>Redhat</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-5"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/how-to-install-gitlab-on-debian-9-stretch-linux method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..."/> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=1979 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h2 itemprop=name> How to Install Gitlab On Debian 9 Stretch Linux </h2></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Nick Congleton</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>Debian</span> </dd><dd class=published> <time datetime=2017-06-30T05:28:41+10:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>30 June 2017 </time> </dd> </dl><div class=article-position> <center><span class=visible-desktop><div id=div-gpt-ad-1407836221062-0> </div> </span> <span class=hidden-desktop><div id=div-gpt-ad-1407836020382-0> </div> </span></center> </div> </div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h1-objective class='toclink toclink-h1'>1.&nbsp;Objective</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h2-distributions class='toclink toclink-h1'>2.&nbsp;Distributions</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h3-requirements class='toclink toclink-h1'>3.&nbsp;Requirements</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h4-difficulty class='toclink toclink-h1'>4.&nbsp;Difficulty</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h5-conventions class='toclink toclink-h1'>5.&nbsp;Conventions</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h6-introduction class='toclink toclink-h1'>6.&nbsp;Introduction</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h7-install-the-dependencies class='toclink toclink-h1'>7.&nbsp;Install The Dependencies</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h8-add-the-repository-and-install class='toclink toclink-h1'>8.&nbsp;Add The Repository and Install</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h9-reconfigure-and-start class='toclink toclink-h1'>9.&nbsp;Reconfigure And Start</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h10-first-run-and-setup class='toclink toclink-h1'>10.&nbsp;First Run And Setup</a></li><li><a href=https://linuxconfig.org/how-to-install-gitlab-on-debian-9-stretch-linux#h11-closing-thoughts class='toclink toclink-h1'>11.&nbsp;Closing Thoughts</a></li></ul></li></ul></div><div itemprop=articleBody><h2 id=h1-objective>Objective</h2>Install Gitlab on Debian 9 Stretch <h2 id=h2-distributions>Distributions</h2>Debian 9 Stretch <h2 id=h3-requirements>Requirements</h2>A working installation of Debian Stretch with root access. <h2 id=h4-difficulty>Difficulty</h2>Easy <h2 id=h5-conventions>Conventions</h2><ul> <li><b>#</b> - requires given command to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</li> <li><b>$</b> - given command to be executed as a regular non-privileged user</li> </ul><h2 id=h6-introduction>Introduction</h2>Gitlab is an awesome free software alternative to Github. It allows teams and individual developers to host and manage their own projects on servers that they control. Debian Stretch provides a stable foundation for Gitlab and can make for an excellent code repository server. Plus, Gitlab's Omnibus Package makes installation super simple. <h2 id=h7-install-the-dependencies>Install The Dependencies</h2>There are a couple of dependencies that you need to install on Debian before you can set up Gitlab. The only thing that might seem out of the ordinary is Postfix. Gitlab uses it to send emails about the repository. During the install, Postfix will ask you which type of configuration to use, select "Internet Site." <pre>
# apt install curl openssh-server ca-certificates postfix
</pre><h2 id=h8-add-the-repository-and-install>Add The Repository and Install</h2>Gitlab provides a convenient script that adds the Gitlab repository to Debian and installs Gitlab. Grab the script with <code>curl</code> and run it as root. <pre>
#curl -sS https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | bash
</pre> When the script finishes, you can install Gitlab with <code>apt</code>. <pre># apt install gitlab-ce</pre><h2 id=h9-reconfigure-and-start>Reconfigure And Start</h2> <code>gitlab-ctl</code> is the command line utility that you'll use to manage Gitlab. In this case, you need to use it to generate your configuration. <pre># gitlab-ctl reconfigure</pre> The script will run and set up your configuration for Gitlab. It will also start up Gitlab when it's done. In the future, when you want to start and stop Gitlab, you can use the following commands. <pre>
# gitlab-ctl start

# gitlab-ctl stop
</pre><h2 id=h10-first-run-and-setup>First Run And Setup</h2><br><center><img src=/images/debian-gitlab-firstlogin.jpg?5954861a alt="First Login To Gitlab On Debian Stretch"></center><br> Since Gitlab is running, browse to your server's IP or domain name in your browser. Gitlab will greet you with a screen asking you to create a password for your administrative user. For now, that user is called "root," but you can change it when you log in. <br><br><center><img src=/images/debian-gitlab-admin.jpg?5954861a alt="Gitlab Admin Interface on Debian Stretch"></center><br> After you enter your new password, Gitlab will ask you to log in. Enter your login credentials and you'll gain access to the admin panel of Gitlab. There are a ton of options there. It's best if you take a look around and explore. It should look somewhat familiar to you if you're used to Github. <h2 id=h11-closing-thoughts>Closing Thoughts</h2>Gitlab is a powerful piece of software, and it comes completely "batteries included." There are probably more features than you'll ever need, but if you are looking to host a larger project or are working with a team, Gitlab will easily meet your needs. As an added bonus, if you are a free software supporter or you're concerned with privacy, Gitlab is the perfect option. </div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <center> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4906753266448300 data-ad-slot=3873304447 data-ad-format=link></ins><hr><span class=visible-desktop><div id=div-gpt-ad-1407836026226-0> </div> </span> <span class=hidden-desktop><div id=div-gpt-ad-1407836147036-0> </div> </span> </center><div id=disqus_thread></div><noscript>Please enable JavaScript to view the <a href=https://disqus.com/?ref_noscript rel=nofollow>comments powered by Disqus.</a></noscript></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"> <ins class=adsbygoogle style=display:inline-block;width:300px;height:600px data-ad-client=ca-pub-4906753266448300 data-ad-slot=6488865241></ins><hr style="margin: 3px";><div id=div-gpt-ad-1407836271993-0> </div> </span> <div id=endad style="position: absolute;bottom: 790px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>About</span></h3><div class=g-particle> LinuxConfig.org team is determined to provide you with simple to follow Linux tutorials, various tips, tricks and programming guides as well as with GNU/Linux system administration tutorials in general to help you to learn Linux faster and use it with ease. <br><br>
Any comments, constructive feedback or your <a href=floss-technical-writer-linuxconfig-org><b>involvement</b></a> is welcome. <br><br>
Contact: </div></div><div class="moduletable "><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=/floss-technical-writer-linuxconfig-org>Read More...</a> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><ul class=mostread> <li itemscope itemtype=https://schema.org/Article> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-skype-on-ubuntu-16-04-xenial-xerus-linux-64-bit itemprop=url> <span itemprop=name> How to install Skype on Ubuntu 16.04 Xenial Xerus Linux 64-bit </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-steam-on-ubuntu-16-04-xenial-xerus itemprop=url> <span itemprop=name> How to install Steam on Ubuntu 16.04 Xenial Xerus </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-stop-start-and-disable-enable-firewall-on-redhat-7-linux-system itemprop=url> <span itemprop=name> How to stop/start and disable/enable Firewall on Redhat 7 Linux system </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-mount-partition-with-ntfs-file-system-and-read-write-access itemprop=url> <span itemprop=name> How to mount partition with ntfs file system and read write access </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-the-latest-nvidia-drivers-on-ubuntu-16-04-xenial-xerus itemprop=url> <span itemprop=name> How to install the latest Nvidia drivers on Ubuntu 16.04 Xenial Xerus </span> </a> </li> </ul> </div></div><div class=platform-content><div class="moduletable "><ul class=latestnews> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-the-latest-mesa-version-on-debian-9-stretch-linux itemprop=url> <span itemprop=name> How to Install The Latest Mesa Version On Debian 9 Stretch Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-upgrade-debian-9-stretch-to-debian-10-buster itemprop=url> <span itemprop=name> How to upgrade Debian 9 Stretch to Debian 10 Buster </span> </a> </li> </ul> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>RSS Feeds</span></h3><div class=g-particle> LinuxConfig.org's category RSS list: </div></div><div class="moduletable "><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=19&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>System Administration</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=17&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Programming & Scripting</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=8&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Ubuntu</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=10&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>CentOS</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=13&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Debian</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=15&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Fedora</span> </a> </div><div class=g-contacts-item rel=nofollow> <a target=_blank href="https://linuxconfig.org/index.php?format=feed&amp;id=14&amp;option=com_content&amp;type=rss&amp;view=category"> <span class="g-contacts-icon fa fa-rss-square"></span> <span class=g-contact-value>Redhat</span> </a> </div></div></div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2017 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/assets2/jscss.php?f=9e97d4e0bda8d8ddb2c8e0886c314f98&type=css&gz=gz&d=1&i=0';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href="/media/plg_jchoptimize/assets2/jscss.php?f=9e97d4e0bda8d8ddb2c8e0886c314f98&amp;type=css&amp;gz=gz&amp;d=1&amp;i=0"/></noscript> <script src="/media/plg_jchoptimize/assets2/jscss.php?f=e901c94f330654382aa8de0470a34f16&amp;type=js&amp;gz=gz&amp;d=1&amp;i=0"></script> </body> </html>