<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<script src="/cdn-cgi/apps/head/bXa8n0uUCb2a0SzvaCENH28oqao.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">

<title>How to crash Linux - Linux Tutorials - Learn Linux Configuration</title>
<meta name="description" content="In this tutorial, we show several different methods that can be used to crash a Linux system. We also show how to prevent these exploits and secure your system." />
<link rel="canonical" href="https://linuxconfig.org/how-to-crash-linux" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to crash Linux" />
<meta property="og:description" content="In this tutorial, we show several different methods that can be used to crash a Linux system. We also show how to prevent these exploits and secure your system." />
<meta property="og:url" content="https://linuxconfig.org/how-to-crash-linux" />
<meta property="og:site_name" content="Linux Tutorials - Learn Linux Configuration" />
<meta property="article:modified_time" content="2021-12-20T04:18:14+00:00" />
<meta property="og:image" content="https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="654" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Korbin Brown" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://linuxconfig.org/#website","url":"https://linuxconfig.org/","name":"Linux Tutorials - Learn Linux Configuration","description":"LinuxConfig.org","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://linuxconfig.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://linuxconfig.org/how-to-crash-linux#primaryimage","inLanguage":"en-US","url":"https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux.png","contentUrl":"https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux.png","width":1200,"height":654,"caption":"How to crash Linux"},{"@type":"WebPage","@id":"https://linuxconfig.org/how-to-crash-linux#webpage","url":"https://linuxconfig.org/how-to-crash-linux","name":"How to crash Linux - Linux Tutorials - Learn Linux Configuration","isPartOf":{"@id":"https://linuxconfig.org/#website"},"primaryImageOfPage":{"@id":"https://linuxconfig.org/how-to-crash-linux#primaryimage"},"author":{"@id":"https://linuxconfig.org/#/schema/person/b538f20c50cb7683e67f21564484011a"},"description":"In this tutorial, we show several different methods that can be used to crash a Linux system. We also show how to prevent these exploits and secure your system.","breadcrumb":{"@id":"https://linuxconfig.org/how-to-crash-linux#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://linuxconfig.org/how-to-crash-linux"]}]},{"@type":"BreadcrumbList","@id":"https://linuxconfig.org/how-to-crash-linux#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://linuxconfig.org/"},{"@type":"ListItem","position":2,"name":"How to crash Linux"}]},{"@type":"Person","@id":"https://linuxconfig.org/#/schema/person/b538f20c50cb7683e67f21564484011a","name":"Korbin Brown","image":{"@type":"ImageObject","@id":"https://linuxconfig.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0636599fa2866f59be46578fd6118bb8?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/0636599fa2866f59be46578fd6118bb8?s=96&d=mm&r=g","caption":"Korbin Brown"},"url":"https://linuxconfig.org/author/korbinpublisher"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; Feed" href="https://linuxconfig.org/feed" />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; Comments Feed" href="https://linuxconfig.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; How to crash Linux Comments Feed" href="https://linuxconfig.org/how-to-crash-linux/feed" />
<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxconfig.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Source+Serif+Pro:regular,600,700|Oswald:200,300,regular,500,600,700' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css' href='https://linuxconfig.org/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.1.0' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://linuxconfig.org/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.1.0' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='generate-blog-images-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/blog/functions/css/featured-images.min.css?ver=2.1.1' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/secondary-nav/functions/css/main.min.css?ver=2.1.1' media='all' />
<style id='generate-secondary-nav-inline-css'>
.secondary-navigation{background-color:#636363;}.secondary-nav-below-header .secondary-navigation .inside-navigation.grid-container, .secondary-nav-above-header .secondary-navigation .inside-navigation.grid-container{padding:0px;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;font-weight:bold;font-size:14px;line-height:27px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;font-size:14px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:40px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:13px;}.secondary-navigation .main-nav ul li:not([class*="current-menu-"]):hover > a, .secondary-navigation .main-nav ul li:not([class*="current-menu-"]):focus > a, .secondary-navigation .main-nav ul li.sfHover:not([class*="current-menu-"]) > a, .secondary-menu-bar-items .menu-bar-item:hover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):hover > a,.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):focus > a,.secondary-navigation .main-nav ul ul li.sfHover:not([class*="current-menu-"]) > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a{color:#222222;background-color:#ffffff;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#474747;}.secondary-navigation.toggled .dropdown-menu-toggle:before{display:none;}@media (max-width: 1040px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/secondary-nav/functions/css/main-mobile.min.css?ver=2.1.1' media='all' />
<link rel='stylesheet' id='generate-offside-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/menu-plus/functions/css/offside.min.css?ver=2.1.1' media='all' />
<style id='generate-offside-inline-css'>
.slideout-navigation.main-navigation{background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul li a{color:#ffffff;font-weight:500;text-transform:none;font-size:18px;}.slideout-navigation.main-navigation ul ul{background-color:#222222;}.slideout-navigation.main-navigation .main-nav ul ul li a{color:#ffffff;}.slideout-navigation.main-navigation.do-overlay .main-nav ul ul li a{font-size:1em;font-size:17px;}@media (max-width:768px){.slideout-navigation.main-navigation .main-nav ul li a{font-size:18px;}.slideout-navigation.main-navigation .main-nav ul ul li a{font-size:17px;}}.slideout-navigation.main-navigation .main-nav ul li:not([class*="current-menu-"]):hover > a, .slideout-navigation.main-navigation .main-nav ul li:not([class*="current-menu-"]):focus > a, .slideout-navigation.main-navigation .main-nav ul li.sfHover:not([class*="current-menu-"]) > a{color:#f7f7f7;background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul ul li:not([class*="current-menu-"]):hover > a, .slideout-navigation.main-navigation .main-nav ul ul li:not([class*="current-menu-"]):focus > a, .slideout-navigation.main-navigation .main-nav ul ul li.sfHover:not([class*="current-menu-"]) > a{color:#fafafa;background-color:#222222;}.slideout-navigation.main-navigation .main-nav ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#222222;}.slideout-navigation, .slideout-navigation a{color:#ffffff;}.slideout-navigation button.slideout-exit{color:#ffffff;padding-left:20px;padding-right:20px;}.slide-opened nav.toggled .menu-toggle:before{display:none;}@media (max-width: 1040px){.menu-bar-item.slideout-toggle{display:none;}}
</style>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxconfig.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxconfig.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://linuxconfig.org/?p=12465' />
<link rel="alternate" type="application/json+oembed" href="https://linuxconfig.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconfig.org%2Fhow-to-crash-linux" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxconfig.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconfig.org%2Fhow-to-crash-linux&#038;format=xml" />
<link rel="pingback" href="https://linuxconfig.org/xmlrpc.php">
<style id="generateblocks-css">.gb-button-wrapper{display:flex;flex-wrap:wrap;align-items:flex-start;justify-content:flex-start;clear:both;}.gb-icon{display:inline-flex;line-height:0;}.gb-icon svg{height:1em;width:1em;fill:currentColor;}.gb-button-wrapper .gb-button{display:inline-flex;align-items:center;justify-content:center;text-align:center;text-decoration:none;transition:.2s background-color ease-in-out, .2s color ease-in-out, .2s border-color ease-in-out, .2s opacity ease-in-out, .2s box-shadow ease-in-out;}.gb-button-wrapper .gb-button .gb-icon{align-items:center;}.gb-button-wrapper a.gb-button-ac59105c,.gb-button-wrapper a.gb-button-ac59105c:visited{background-color:#0366d6;color:#ffffff;padding:15px 20px;}.gb-button-wrapper a.gb-button-ac59105c:hover,.gb-button-wrapper a.gb-button-ac59105c:active,.gb-button-wrapper a.gb-button-ac59105c:focus{background-color:#222222;color:#ffffff;}.gb-button-wrapper a.gb-button-9e8d3737,.gb-button-wrapper a.gb-button-9e8d3737:visited{background-color:#0366d6;color:#ffffff;padding:15px 20px;}.gb-button-wrapper a.gb-button-9e8d3737:hover,.gb-button-wrapper a.gb-button-9e8d3737:active,.gb-button-wrapper a.gb-button-9e8d3737:focus{background-color:#222222;color:#ffffff;}.gb-highlight{background:none;color:unset;}</style><BASE href="/">
<script async src="https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js"></script><style>
.posted-on .updated:before {
content: "Last Updated: ";
}
</style><link rel="icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-270x270.png" />
<style id="wp-custom-css">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</style>
</head>
<body class="post-template-default single single-post postid-12465 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-left slideout-enabled slideout-mobile sticky-menu-slide page-id-12465 right-sidebar nav-float-right one-container nav-search-enabled header-aligned-left dropdown-hover" itemtype="https://schema.org/Blog" itemscope>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <nav id="secondary-navigation" class="secondary-navigation grid-container" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
<div class="inside-navigation grid-container grid-parent">
<button class="menu-toggle secondary-menu-toggle">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span> </button>
<div class="main-nav"><ul id="menu-top-bar-menu" class=" secondary-menu sf-menu"><li id="menu-item-9806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9806"><a href="https://linuxconfig.org/ubuntu">Ubuntu<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-9807" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9807"><a href="https://linuxconfig.org/ubuntu-20-04-guide">Ubuntu 20.04 Guide</a></li>
<li id="menu-item-9814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9814"><a href="https://linuxconfig.org/ubuntu-18-04">Ubuntu 18.04</a></li>
</ul>
</li>
<li id="menu-item-9808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9808"><a href="https://linuxconfig.org/debian">Debian</a></li>
<li id="menu-item-9809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9809"><a href="https://linuxconfig.org/redhat">Redhat / CentOS / AlmaLinux</a></li>
<li id="menu-item-9817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9817"><a href="https://linuxconfig.org/fedora">Fedora</a></li>
<li id="menu-item-9810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9810"><a href="https://linuxconfig.org/kali-linux">Kali Linux</a></li>
</ul></div> </div>
</nav>
<header class="site-header has-inline-mobile-toggle" id="masthead" aria-label="Site" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container">
<div class="site-logo">
<a href="https://linuxconfig.org/" title="Linux Tutorials &#8211; Learn Linux Configuration" rel="home">
<img class="header-image is-logo-image" alt="Linux Tutorials &#8211; Learn Linux Configuration" src="https://linuxconfig.org/wp-content/uploads/2021/07/logo-lc.png" title="Linux Tutorials &#8211; Learn Linux Configuration" width="250" height="70" />
</a>
</div> <nav class="main-navigation mobile-menu-control-wrapper" id="mobile-menu-control-wrapper" aria-label="Mobile Toggle">
<div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div> <button data-nav="site-navigation" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
</nav>
<nav class="main-navigation has-menu-bar-items sub-menu-right" id="site-navigation" aria-label="Primary" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation">
<form method="get" class="search-form navigation-search" action="https://linuxconfig.org/">
<input type="search" class="search-field" value="" name="s" title="Search" />
</form> <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-top-main-menu" class=" menu sf-menu"><li id="menu-item-9640" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9640"><a href="https://linuxconfig.org/linux-tutorials">Linux Tutorials</a></li>
<li id="menu-item-8425" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8425"><a href="https://linuxconfig.org/system-administration-configuration">System Admin</a></li>
<li id="menu-item-8426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8426"><a href="https://linuxconfig.org/programming-scripting">Programming</a></li>
<li id="menu-item-8427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8427"><a href="https://linuxconfig.org/multimedia-games">Multimedia</a></li>
<li id="menu-item-8525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8525"><a rel="nofollow noopener noreferrer" href="https://forum.linuxconfig.org/">Forum</a></li>
<li id="menu-item-9641" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9641"><a href="https://linuxconfig.org/linux-commands">Linux Commands</a></li>
<li id="menu-item-8526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8526"><a rel="nofollow noopener noreferrer" href="https://linuxconfig.org/linuxcareers-com-linux-job-portal">Linux Jobs</a></li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div><div class="leaderboard-ad-wrapper" data-fuse="22413944646"></div> </div>
</nav>
<div class="header-widget">
</div>
</div>
</header>
<div class="site grid-container container hfeed" id="page">
<div class="site-content" id="content">
<div class="content-area" id="primary">
<main class="site-main" id="main">
<article id="post-12465" class="post-12465 post type-post status-publish format-standard has-post-thumbnail hentry category-system-administration-configuration tag-administration tag-commands tag-hacking tag-security wpautop" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header" aria-label="Content">
<h1 class="entry-title" itemprop="headline">How to crash Linux</h1> <div class="entry-meta">
<span class="posted-on"><time class="entry-date updated-date" datetime="2021-12-20T15:18:14+11:00" itemprop="dateModified">20 December 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://linuxconfig.org/author/korbinpublisher" title="View all posts by Korbin Brown" rel="author" itemprop="url"><span class="author-name" itemprop="name">Korbin Brown</span></a></span></span> </div>
<div data-fuse="22189504503" class="incontent_ads"></div>
</header>
<div class="entry-content" itemprop="text">
<p>There are a number of dangerous commands that can be executed to crash a <a href="https://linuxconfig.org/linux-download" target="_blank" rel="noopener">Linux system</a>. You may find a nefarious user executing these commands on a system you manage, or someone may send you a seemingly harmless command, hoping that you will run it and crash your computer.<br />
<span id="more-12465"></span><br />
It is important for system administrators to be aware of these commands, and run them on their own systems to ensure that they have taken the proper measures to prevent these attacks. Then again, maybe you are just a curious user and you want to crash your virtual machine for fun. That is fine, too.</p>
<p>Just be careful about executing these commands on production systems and computers that you do not own. Crashing someone else&#8217;s system can land you in trouble, so exercise caution when running the commands covered below. In this tutorial, we show several different methods that can be used to crash a Linux system.</p>
<p><strong>In this tutorial you will learn:</strong></p>
<ul>
<li>How to crash Linux</li>
<li>How to prevent Linux crashes</li>
</ul>
<figure id="attachment_12466" aria-describedby="caption-attachment-12466" style="width: 1190px" class="wp-caption alignnone"><img loading="lazy" src="https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux.png" alt="How to crash Linux" width="1200" height="654" class="size-full wp-image-12466" srcset="https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux.png 1200w, https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux-300x164.png 300w, https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux-1024x558.png 1024w, https://linuxconfig.org/wp-content/uploads/2021/12/00-how-to-crash-linux-768x419.png 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption id="caption-attachment-12466" class="wp-caption-text">How to crash Linux</figcaption></figure>
<table class="uk-table uk-table-striped uk-table-condensed">
<caption>Software Requirements and Linux Command Line Conventions</caption>
<thead>
<tr>
<th>Category</th>
<th>Requirements, Conventions or Software Version Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>Any <a href="https://linuxconfig.org/linux-download" target="_blank" rel="noopener">Linux system</a></td>
</tr>
<tr>
<td>Software</td>
<td>N/A</td>
</tr>
<tr>
<td>Other</td>
<td>Privileged access to your Linux system as root or via the <code>sudo</code> command.</td>
</tr>
<tr>
<td>Conventions</td>
<td>
<b>#</b> &#8211; requires given <a href="linux-commands" target="_blank" rel="noopener">linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command<br />
<b>$</b> &#8211; requires given <a href="linux-commands" target="_blank" rel="noopener">linux commands</a> to be executed as a regular non-privileged user
</td>
</tr>
</tbody>
</table>
<h2>How to crash a Linux system</h2>
<hr><div class="incontent_ads" data-fuse="22189504506"></div><hr>
<div class="uk-alert uk-alert-danger">
<center><b>WARNING</b><br />Be sure to only test this code on a test machine or virtual machine. Using it on another system, even for testing purposes, will make you look like an attacker that is trying to crash the system. And, in some cases, you might succeed. </center></div>
<ol class="examples">
<li>The following line of code is a short and sweet fork bomb for the Bash shell. A fork bomb is effective because it is able to spawn an unlimited number of processes. Eventually, your system can&#8217;t process all of them, and will crash. One big advantage of a fork bomb is that you do not need root permissions to execute it and get the desired effect.
<pre>
$ :(){ :|:& };:
</pre>
<p>Check out our guide on <a href="https://linuxconfig.org/how-to-crash-your-linux-system-with-fork-bomb" target="_blank" rel="noopener">Linux fork bombs</a> to learn how they work and how you can prevent them from crashing your system.</p>
</li>
<li>Here is another fork bomb, but this time it is written in Perl. This is just as effective as the Bash fork bomb. Try running both to see how your test system responds (or doesn&#8217;t respond).
<pre>
$ perl -e "fork while fork" &
</pre>
</li>
<li>You can delete your entire root directory with a simple <code>rm</code> command. This will be hard to recover from, and a simple reboot is not going to fix it, so run it with caution.
<pre>
$ sudo rm -rf / --no-preserve-root
rm: it is dangerous to operate recursively on '/'
rm: use --no-preserve-root to override this failsafe
</pre>
<p>As you can see, our system is smart enough to warn us about this command. Let&#8217;s ignore the warning and kiss our virtual machine goodbye.</p>
<pre>
$ sudo rm -rf / --no-preserve-root
</pre>
</li>
<li>We can also write zeros to our entire hard drive with a simple <code>dd</code> command. This one is especially nasty because it can overwrite data on other partitions, outside of your Linux environment. And, even worse, we don&#8217;t get any kind of warning about the dangers of the command, or a confirmation prompt.
<pre>
$ sudo dd if=/dev/zero of=/dev/sda5
</pre>
<p>Replace <code>/dev/sda5</code> with the device or partition that you wish to obliterate. It only took our test system a few seconds to shut down and be irrecoverable after executing this command.</p>
</li>
</ol>
<h2>How to prevent Linux crashes</h2>
<p>Fork bombs work by spawning endless processes. Therefore, we can prevent fork bomb crashes by just limiting the number of open processes that a user or group of users can have open simultaneously. Check out our guide on <a href="https://linuxconfig.org/how-to-crash-your-linux-system-with-fork-bomb" target="_blank" rel="noopener">Linux fork bombs</a> to learn how they work and how you can prevent them from crashing your system.</p>
<p>For other commands, such as those where tons of system files are deleted, or the hard drive partition is overwritten, there is no easy way to prevent all of these outside of restricting root access to only trusted users. On top of that, your users need to have secure passwords, and you should put proper file permissions on important files.</p>
<p>Still, people are always susceptible to phishing and social engineering. If someone gains access to the root account, there will be little that you can do to prevent them from taking down the system. In that case, you better have a backup.</p>
<h2>Closing Thoughts</h2>
<p><hr><div class="incontent_ads" data-fuse="22189504224"></div><hr><br />
In this tutorial, we saw several different methods to crash a Linux system, as well as some advice on how to prevent these exploits in the first place. Every system administrator should be familiar with such commands, as its their job to defend against them. Apart from that, it&#8217;s just plain fun to execute some of these on test systems and virtual machines.</p>
<div class="crp_related  "><h3>Related Linux Tutorials:</h3><ul><li><a href="https://linuxconfig.org/install-arch-linux-in-vmware-workstation" target="_blank" class="crp_link post-2291"><span class="crp_title">Install Arch Linux in VMware Workstation</span></a></li><li><a href="https://linuxconfig.org/how-to-install-ubuntu-20-04-on-virtualbox" target="_blank" class="crp_link post-2092"><span class="crp_title">How to install Ubuntu 20.04 on VirtualBox</span></a></li><li><a href="https://linuxconfig.org/things-to-install-on-ubuntu-20-04" target="_blank" class="crp_link post-2035"><span class="crp_title">Things to install on Ubuntu 20.04</span></a></li><li><a href="https://linuxconfig.org/how-to-manage-dynamic-virtual-hosts-with-apache-and-the-mod-vhost-alias-module" target="_blank" class="crp_link post-2502"><span class="crp_title">How to manage dynamic virtual hosts with Apache and&hellip;</span></a></li><li><a href="https://linuxconfig.org/big-data-manipulation-for-fun-and-profit-part-3" target="_blank" class="crp_link post-2301"><span class="crp_title">Big Data Manipulation for Fun and Profit Part 3</span></a></li><li><a href="https://linuxconfig.org/apache-ip-and-name-based-virtual-hosts-explained" target="_blank" class="crp_link post-2052"><span class="crp_title">Apache IP and Name Based Virtual Hosts Explained</span></a></li><li><a href="https://linuxconfig.org/big-data-manipulation-for-fun-and-profit-part-1" target="_blank" class="crp_link post-2280"><span class="crp_title">Big Data Manipulation for Fun and Profit Part 1</span></a></li><li><a href="https://linuxconfig.org/how-to-install-kali-linux-in-vmware" target="_blank" class="crp_link post-2366"><span class="crp_title">How to install Kali Linux in VMware</span></a></li><li><a href="https://linuxconfig.org/things-to-do-after-installing-ubuntu-20-04-focal-fossa-linux" target="_blank" class="crp_link post-2072"><span class="crp_title">Things to do after installing Ubuntu 20.04 Focal Fossa Linux</span></a></li><li><a href="https://linuxconfig.org/how-to-make-the-most-of-openssh" target="_blank" class="crp_link post-2161"><span class="crp_title">How to make the most of OpenSSH</span></a></li></ul><div class="crp_clear"></div></div> </div>
<footer class="entry-meta" aria-label="Entry meta">
<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://linuxconfig.org/system-administration-configuration" rel="category tag">System Administration</a></span> <span class="tags-links"><span class="gp-icon icon-tags"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M20 39.5c-8.836 0-16 7.163-16 16v176c0 4.243 1.686 8.313 4.687 11.314l224 224c6.248 6.248 16.378 6.248 22.626 0l176-176c6.244-6.244 6.25-16.364.013-22.615l-223.5-224A15.999 15.999 0 00196.5 39.5H20zm56 96c0-13.255 10.745-24 24-24s24 10.745 24 24-10.745 24-24 24-24-10.745-24-24z" /><path d="M259.515 43.015c4.686-4.687 12.284-4.687 16.97 0l228 228c4.686 4.686 4.686 12.284 0 16.97l-180 180c-4.686 4.687-12.284 4.687-16.97 0-4.686-4.686-4.686-12.284 0-16.97L479.029 279.5 259.515 59.985c-4.686-4.686-4.686-12.284 0-16.97z" /></svg></span><span class="screen-reader-text">Tags </span><a href="https://linuxconfig.org/tag/administration" rel="tag">administration</a>, <a href="https://linuxconfig.org/tag/commands" rel="tag">commands</a>, <a href="https://linuxconfig.org/tag/hacking" rel="tag">hacking</a>, <a href="https://linuxconfig.org/tag/security" rel="tag">security</a></span> <nav id="nav-below" class="post-navigation" aria-label="Single Post">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev" title="Previous"><a href="https://linuxconfig.org/how-to-build-an-initramfs-using-dracut-on-linux" rel="prev">How to build an initramfs using Dracut on Linux</a></span></div><div class="nav-next"><span class="gp-icon icon-arrow-right"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 256.001c0 2.266-1.133 4.815-2.832 6.515L43.599 394.509c-1.7 1.7-4.248 2.833-6.514 2.833s-4.816-1.133-6.515-2.833l-14.163-14.162c-1.699-1.7-2.832-3.966-2.832-6.515 0-2.266 1.133-4.815 2.832-6.515l111.317-111.316L16.407 144.685c-1.699-1.7-2.832-4.249-2.832-6.515s1.133-4.815 2.832-6.515l14.163-14.162c1.7-1.7 4.249-2.833 6.515-2.833s4.815 1.133 6.514 2.833l131.994 131.993c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" /></svg></span><span class="next" title="Next"><a href="https://linuxconfig.org/how-to-create-temporary-files-using-mktemp-on-linux" rel="next">How to create temporary files using mktemp on Linux</a></span></div> </nav>
</footer>
<hr>
<center>

<div data-fuse="22198552927" class="incontent_ads"></div>
</center>
<hr>
<center><font size=6><strong>Comments and Discussions</strong></font><br><img src="https://linuxconfig.org/wp-content/uploads/2021/07/linuxconfig-forum-logo-1.png" alt="Linux Forum" width="250" height="46"></center>
<div id='discourse-comments'></div>
<script type="text/javascript">
  DiscourseEmbed = { discourseUrl: 'https://forum.linuxconfig.org/',
                     discourseEmbedUrl: document.querySelector("link[rel='canonical']").getAttribute("href") };

  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>
</div>
</article>
</main>
</div>
<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
<div class="inside-right-sidebar">
<aside id="block-31" class="widget inner-padding widget_block"><div data-fuse="22189504221" class="sticky_ads"></div>
<hr style="margin: 2px" ;>
<div data-fuse="22189277162" class="sticky_ads"></div></aside> </div>
</div>
</div>
</div>
<div class="site-footer">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container">
<div class="inside-footer-widgets">
<div class="footer-widget-1">
<aside id="block-12" class="widget inner-padding widget_block">
<h3 id="h-newsletter">NEWSLETTER</h3>
</aside><aside id="block-11" class="widget inner-padding widget_block widget_text">
<p>Subscribe to&nbsp;Linux Career Newsletter&nbsp;to receive latest news, jobs, career advice and featured configuration tutorials.</p>
</aside><aside id="block-25" class="widget inner-padding widget_block"><div class="gb-button-wrapper gb-button-wrapper-47b15502">
<a class="gb-button gb-button-9e8d3737 gb-button-text" href="https://bit.ly/2X5D30q" rel="nofollow">SUBSCRIBE</a>
</div></aside><aside id="block-13" class="widget inner-padding widget_block">
<h3 id="h-write-for-us">WRITE FOR US</h3>
</aside><aside id="block-15" class="widget inner-padding widget_block widget_text">
<p>LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.</p>
</aside><aside id="block-16" class="widget inner-padding widget_block widget_text">
<p>When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month.</p>
</aside><aside id="block-21" class="widget inner-padding widget_block"><div class="gb-button-wrapper gb-button-wrapper-fea23fb6">
<a class="gb-button gb-button-ac59105c gb-button-text" href="https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/" rel="nofollow">APPLY NOW</a>
</div></aside><aside id="block-41" class="widget inner-padding widget_block">
<h3 id="h-contact-us">CONTACT US</h3>
</aside><aside id="block-42" class="widget inner-padding widget_block">web ( at ) linuxconfig ( dot ) org</aside> </div>
<div class="footer-widget-2">
<aside id="tag_cloud-3" class="widget inner-padding widget_tag_cloud"><h2 class="widget-title">TAGS</h2><div class="tagcloud"><a href="https://linuxconfig.org/tag/18-04" class="tag-cloud-link tag-link-75 tag-link-position-1" style="font-size: 16.95652173913pt;" aria-label="18.04 (202 items)">18.04</a>
<a href="https://linuxconfig.org/tag/administration" class="tag-cloud-link tag-link-14 tag-link-position-2" style="font-size: 22pt;" aria-label="administration (777 items)">administration</a>
<a href="https://linuxconfig.org/tag/apache" class="tag-cloud-link tag-link-27 tag-link-position-3" style="font-size: 9.8260869565217pt;" aria-label="apache (30 items)">apache</a>
<a href="https://linuxconfig.org/tag/applications" class="tag-cloud-link tag-link-43 tag-link-position-4" style="font-size: 14.521739130435pt;" aria-label="applications (105 items)">applications</a>
<a href="https://linuxconfig.org/tag/backup" class="tag-cloud-link tag-link-31 tag-link-position-5" style="font-size: 8pt;" aria-label="backup (18 items)">backup</a>
<a href="https://linuxconfig.org/tag/bash" class="tag-cloud-link tag-link-21 tag-link-position-6" style="font-size: 14.95652173913pt;" aria-label="bash (120 items)">bash</a>
<a href="https://linuxconfig.org/tag/beginner" class="tag-cloud-link tag-link-15 tag-link-position-7" style="font-size: 18pt;" aria-label="beginner (269 items)">beginner</a>
<a href="https://linuxconfig.org/tag/browser" class="tag-cloud-link tag-link-74 tag-link-position-8" style="font-size: 10pt;" aria-label="browser (31 items)">browser</a>
<a href="https://linuxconfig.org/tag/centos" class="tag-cloud-link tag-link-61 tag-link-position-9" style="font-size: 10.260869565217pt;" aria-label="centos (34 items)">centos</a>
<a href="https://linuxconfig.org/tag/centos8" class="tag-cloud-link tag-link-86 tag-link-position-10" style="font-size: 14.347826086957pt;" aria-label="centos8 (102 items)">centos8</a>
<a href="https://linuxconfig.org/tag/commands" class="tag-cloud-link tag-link-16 tag-link-position-11" style="font-size: 19.826086956522pt;" aria-label="commands (439 items)">commands</a>
<a href="https://linuxconfig.org/tag/database" class="tag-cloud-link tag-link-56 tag-link-position-12" style="font-size: 12.173913043478pt;" aria-label="database (56 items)">database</a>
<a href="https://linuxconfig.org/tag/debian" class="tag-cloud-link tag-link-20 tag-link-position-13" style="font-size: 10.173913043478pt;" aria-label="debian (33 items)">debian</a>
<a href="https://linuxconfig.org/tag/desktop" class="tag-cloud-link tag-link-24 tag-link-position-14" style="font-size: 18.434782608696pt;" aria-label="desktop (303 items)">desktop</a>
<a href="https://linuxconfig.org/tag/development" class="tag-cloud-link tag-link-42 tag-link-position-15" style="font-size: 18.434782608696pt;" aria-label="development (302 items)">development</a>
<a href="https://linuxconfig.org/tag/docker" class="tag-cloud-link tag-link-68 tag-link-position-16" style="font-size: 8.8695652173913pt;" aria-label="docker (23 items)">docker</a>
<a href="https://linuxconfig.org/tag/fedora" class="tag-cloud-link tag-link-30 tag-link-position-17" style="font-size: 9.5652173913043pt;" aria-label="fedora (28 items)">fedora</a>
<a href="https://linuxconfig.org/tag/filesystem" class="tag-cloud-link tag-link-17 tag-link-position-18" style="font-size: 15.652173913043pt;" aria-label="filesystem (143 items)">filesystem</a>
<a href="https://linuxconfig.org/tag/firewall" class="tag-cloud-link tag-link-46 tag-link-position-19" style="font-size: 9.4782608695652pt;" aria-label="firewall (27 items)">firewall</a>
<a href="https://linuxconfig.org/tag/gaming" class="tag-cloud-link tag-link-60 tag-link-position-20" style="font-size: 12.173913043478pt;" aria-label="gaming (57 items)">gaming</a>
<a href="https://linuxconfig.org/tag/gnome" class="tag-cloud-link tag-link-63 tag-link-position-21" style="font-size: 10.869565217391pt;" aria-label="gnome (40 items)">gnome</a>
<a href="https://linuxconfig.org/tag/hardware" class="tag-cloud-link tag-link-47 tag-link-position-22" style="font-size: 9.5652173913043pt;" aria-label="Hardware (28 items)">Hardware</a>
<a href="https://linuxconfig.org/tag/installation" class="tag-cloud-link tag-link-40 tag-link-position-23" style="font-size: 16.260869565217pt;" aria-label="installation (169 items)">installation</a>
<a href="https://linuxconfig.org/tag/java" class="tag-cloud-link tag-link-76 tag-link-position-24" style="font-size: 9.0434782608696pt;" aria-label="java (24 items)">java</a>
<a href="https://linuxconfig.org/tag/kali" class="tag-cloud-link tag-link-73 tag-link-position-25" style="font-size: 11.913043478261pt;" aria-label="kali (53 items)">kali</a>
<a href="https://linuxconfig.org/tag/manjaro" class="tag-cloud-link tag-link-84 tag-link-position-26" style="font-size: 9.8260869565217pt;" aria-label="manjaro (30 items)">manjaro</a>
<a href="https://linuxconfig.org/tag/multimedia" class="tag-cloud-link tag-link-32 tag-link-position-27" style="font-size: 15.652173913043pt;" aria-label="multimedia (144 items)">multimedia</a>
<a href="https://linuxconfig.org/tag/networking" class="tag-cloud-link tag-link-36 tag-link-position-28" style="font-size: 15.217391304348pt;" aria-label="networking (129 items)">networking</a>
<a href="https://linuxconfig.org/tag/nvidia" class="tag-cloud-link tag-link-67 tag-link-position-29" style="font-size: 11.04347826087pt;" aria-label="nvidia (42 items)">nvidia</a>
<a href="https://linuxconfig.org/tag/programming" class="tag-cloud-link tag-link-45 tag-link-position-30" style="font-size: 14.95652173913pt;" aria-label="programming (119 items)">programming</a>
<a href="https://linuxconfig.org/tag/python" class="tag-cloud-link tag-link-66 tag-link-position-31" style="font-size: 10.521739130435pt;" aria-label="python (36 items)">python</a>
<a href="https://linuxconfig.org/tag/redhat" class="tag-cloud-link tag-link-58 tag-link-position-32" style="font-size: 11.913043478261pt;" aria-label="redhat (53 items)">redhat</a>
<a href="https://linuxconfig.org/tag/rhel8" class="tag-cloud-link tag-link-85 tag-link-position-33" style="font-size: 14.434782608696pt;" aria-label="rhel8 (104 items)">rhel8</a>
<a href="https://linuxconfig.org/tag/scripting" class="tag-cloud-link tag-link-22 tag-link-position-34" style="font-size: 13.652173913043pt;" aria-label="scripting (85 items)">scripting</a>
<a href="https://linuxconfig.org/tag/security" class="tag-cloud-link tag-link-26 tag-link-position-35" style="font-size: 15.826086956522pt;" aria-label="security (151 items)">security</a>
<a href="https://linuxconfig.org/tag/server" class="tag-cloud-link tag-link-39 tag-link-position-36" style="font-size: 15.826086956522pt;" aria-label="server (150 items)">server</a>
<a href="https://linuxconfig.org/tag/ssh" class="tag-cloud-link tag-link-35 tag-link-position-37" style="font-size: 9.0434782608696pt;" aria-label="ssh (24 items)">ssh</a>
<a href="https://linuxconfig.org/tag/storage" class="tag-cloud-link tag-link-19 tag-link-position-38" style="font-size: 11.565217391304pt;" aria-label="storage (48 items)">storage</a>
<a href="https://linuxconfig.org/tag/terminal" class="tag-cloud-link tag-link-38 tag-link-position-39" style="font-size: 14.260869565217pt;" aria-label="terminal (100 items)">terminal</a>
<a href="https://linuxconfig.org/tag/ubuntu" class="tag-cloud-link tag-link-23 tag-link-position-40" style="font-size: 20.521739130435pt;" aria-label="ubuntu (521 items)">ubuntu</a>
<a href="https://linuxconfig.org/tag/ubuntu-20-04" class="tag-cloud-link tag-link-90 tag-link-position-41" style="font-size: 17.739130434783pt;" aria-label="ubuntu 20.04 (248 items)">ubuntu 20.04</a>
<a href="https://linuxconfig.org/tag/video" class="tag-cloud-link tag-link-92 tag-link-position-42" style="font-size: 8.1739130434783pt;" aria-label="video (19 items)">video</a>
<a href="https://linuxconfig.org/tag/virtualization" class="tag-cloud-link tag-link-54 tag-link-position-43" style="font-size: 10.521739130435pt;" aria-label="virtualization (36 items)">virtualization</a>
<a href="https://linuxconfig.org/tag/webapp" class="tag-cloud-link tag-link-50 tag-link-position-44" style="font-size: 10.521739130435pt;" aria-label="webapp (36 items)">webapp</a>
<a href="https://linuxconfig.org/tag/webserver" class="tag-cloud-link tag-link-25 tag-link-position-45" style="font-size: 13.826086956522pt;" aria-label="webserver (88 items)">webserver</a></div>
</aside> </div>
<div class="footer-widget-3">
<aside id="block-36" class="widget inner-padding widget_block">
<h3 id="h-featured-tutorials">FEATURED TUTORIALS</h3>
</aside><aside id="block-37" class="widget inner-padding widget_block"><ul>
<li>
<a href="https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to install the NVIDIA drivers on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/bash-scripting-tutorial-for-beginners" target="_blank">Bash Scripting Tutorial for Beginners</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-check-centos-version" target="_blank">How to check CentOS version</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-find-my-ip-address-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to find my IP address on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/ubuntu-20-04-remote-desktop-access-from-windows-10" target="_blank">Ubuntu 20.04 Remote Desktop Access from Windows 10</a>
</li>
<li>
<a href="https://linuxconfig.org/howto-mount-usb-drive-in-linux" target="_blank">Howto mount USB drive in Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-missing-ifconfig-command-on-debian-linux" target="_blank">How to install missing ifconfig command on Debian Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/amd-radeon-ubuntu-20-04-driver-installation" target="_blank">AMD Radeon Ubuntu 20.04 Driver Installation</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-configure-static-ip-address-on-ubuntu-18-10-cosmic-cuttlefish-linux" target="_blank">Ubuntu Static IP configuration</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-use-arrays-in-bash-script" target="_blank">How to use bash array in a shell script</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-turn-on-off-ip-forwarding-in-linux" target="_blank">Linux IP forwarding – How to Disable/Enable</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-tweak-tool-on-ubuntu-20-04-lts-focal-fossa-linux" target="_blank">How to install Tweak Tool on Ubuntu 20.04 LTS Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-enable-disable-firewall-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">How to enable/disable firewall on Ubuntu 18.04 Bionic Beaver Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-configure-static-ip-address-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">Netplan static IP on Ubuntu configuration</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-change-from-default-to-alternative-python-version-on-debian-linux" target="_blank">How to change from default to alternative Python version on Debian Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-enable-root-login-on-kali-linux" target="_blank">Set Kali root password and enable root login</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-adobe-acrobat-reader-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to Install Adobe Acrobat Reader on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-check-nvidia-driver-version-on-your-linux-system" target="_blank">How to check NVIDIA driver version on your Linux system</a>
</li>
<li>
<a href="https://linuxconfig.org/nvidia-rtx-3080-eth-hashrate-and-overclock-settings-on-hiveos" target="_blank">Nvidia RTX 3080 Ethereum Hashrate and Mining Overclock settings on HiveOS Linux</a>
</li>
</ul></aside> </div>
<div class="footer-widget-4">
<aside id="block-40" class="widget inner-padding widget_block">
<h3 class="gb-headline gb-headline-3c90cba8 gb-headline-text">LATEST TUTORIALS</h3>
</aside><aside id="block-38" class="widget inner-padding widget_block widget_recent_entries"><ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a href="https://linuxconfig.org/introduction-to-mysql-storage-engines">Introduction to MySQL storage engines</a></li>
<li><a href="https://linuxconfig.org/introduction-to-crypttab-with-examples">Introduction to crypttab with examples</a></li>
<li><a href="https://linuxconfig.org/how-to-create-temporary-files-using-mktemp-on-linux">How to create temporary files using mktemp on Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-crash-linux">How to crash Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-build-an-initramfs-using-dracut-on-linux">How to build an initramfs using Dracut on Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-uncompress-and-list-an-initramfs-content-on-linux">How to uncompress and list an initramfs content on Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-install-pipewire-on-ubuntu-linux">How to install PipeWire on Ubuntu Linux</a></li>
<li><a href="https://linuxconfig.org/ubuntu-22-04-kernel-version">Ubuntu 22.04 kernel version</a></li>
<li><a href="https://linuxconfig.org/ubuntu-22-04-network-configuration">Ubuntu 22.04 network configuration</a></li>
<li><a href="https://linuxconfig.org/ubuntu-22-04-minimum-requirements">Ubuntu 22.04 minimum requirements</a></li>
<li><a href="https://linuxconfig.org/ubuntu-22-04-change-hostname">Ubuntu 22.04 change hostname</a></li>
<li><a href="https://linuxconfig.org/how-to-install-docker-on-ubuntu-22-04">How to install Docker on Ubuntu 22.04</a></li>
<li><a href="https://linuxconfig.org/introduction-to-ansible-prompts-and-runtime-variables">Introduction to Ansible prompts and runtime variables</a></li>
<li><a href="https://linuxconfig.org/how-to-create-and-extract-cpio-archives-on-linux-examples">How to create and extract cpio archives on Linux Examples</a></li>
<li><a href="https://linuxconfig.org/how-to-hash-passwords-on-linux">How to hash passwords on Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-perform-administration-operations-with-ansible-modules">How to perform administration operations with Ansible modules</a></li>
<li><a href="https://linuxconfig.org/introduction-to-wake-on-lan">Introduction to Wake On Lan</a></li>
<li><a href="https://linuxconfig.org/introduction-to-yaml-with-examples">Introduction to YAML with Examples</a></li>
<li><a href="https://linuxconfig.org/hardening-kali-linux">Hardening Kali Linux</a></li>
<li><a href="https://linuxconfig.org/how-to-manipulate-excel-spreadsheets-with-python-and-openpyxl">How to manipulate Excel spreadsheets with Python and openpyxl</a></li>
</ul></aside> </div>
</div>
</div>
</div>
<footer class="site-info" aria-label="Site" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container">
<div class="copyright-bar">
&copy; 2021 TOSID Group Pty Ltd - LinuxConfig.org </div>
</div>
</footer>
</div>
<a title="Scroll back to top" aria-label="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<span class="gp-icon icon-arrow-up"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M305.863 314.916c0 2.266-1.133 4.815-2.832 6.514l-14.157 14.163c-1.699 1.7-3.964 2.832-6.513 2.832-2.265 0-4.813-1.133-6.512-2.832L164.572 224.276 53.295 335.593c-1.699 1.7-4.247 2.832-6.512 2.832-2.265 0-4.814-1.133-6.513-2.832L26.113 321.43c-1.699-1.7-2.831-4.248-2.831-6.514s1.132-4.816 2.831-6.515L158.06 176.408c1.699-1.7 4.247-2.833 6.512-2.833 2.265 0 4.814 1.133 6.513 2.833L303.03 308.4c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" /></svg></span>
</a> <nav id="generate-slideout-menu" class="main-navigation slideout-navigation do-overlay" itemtype="https://schema.org/SiteNavigationElement" itemscope style="display: none;">
<div class="inside-navigation grid-container grid-parent">
<button class="slideout-exit has-svg-icon"><span class="gp-icon pro-close">
<svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" />
</svg>
</span> <span class="screen-reader-text">Close</span></button><div class="main-nav"><ul id="menu-top-main-menu-1" class=" slideout-menu"><li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9640"><a href="https://linuxconfig.org/linux-tutorials">Linux Tutorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8425"><a href="https://linuxconfig.org/system-administration-configuration">System Admin</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8426"><a href="https://linuxconfig.org/programming-scripting">Programming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8427"><a href="https://linuxconfig.org/multimedia-games">Multimedia</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8525"><a rel="nofollow noopener noreferrer" href="https://forum.linuxconfig.org/">Forum</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9641"><a href="https://linuxconfig.org/linux-commands">Linux Commands</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8526"><a rel="nofollow noopener noreferrer" href="https://linuxconfig.org/linuxcareers-com-linux-job-portal">Linux Jobs</a></li>
</ul></div> </div>
</nav>
<script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><script id='generate-offside-js-extra'>
var offSide = {"side":"left"};
</script>
<script src='https://linuxconfig.org/wp-content/plugins/gp-premium/menu-plus/functions/js/offside.min.js?ver=2.1.1' id='generate-offside-js'></script>
<!--[if lte IE 11]>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.0' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.0' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.1.0' id='generate-navigation-search-js'></script>
<script id='generate-back-to-top-js-extra'>
var generatepressBackToTop = {"smooth":"1"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/back-to-top.min.js?ver=3.1.0' id='generate-back-to-top-js'></script>
<script src='https://linuxconfig.org/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6c5a6c32598159c2","token":"1637300d8a394c64a4b8ffff41ff1ca8","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>
