<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<script src="/cdn-cgi/apps/head/YOL-SRJ3QyGF0loqZQH8Y5oWm1Q.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">

<title>How to backup and restore an xfs filesystem using xfsdump and xfsrestore - Linux Tutorials - Learn Linux Configuration</title>
<meta name="description" content="In this tutorial we see how to create and restore XFS backups using the xfsdump and xfsrestore utilities on Linux." />
<link rel="canonical" href="https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to backup and restore an xfs filesystem using xfsdump and xfsrestore" />
<meta property="og:description" content="In this tutorial we see how to create and restore XFS backups using the xfsdump and xfsrestore utilities on Linux." />
<meta property="og:url" content="https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore" />
<meta property="og:site_name" content="Linux Tutorials - Learn Linux Configuration" />
<meta property="article:modified_time" content="2022-11-25T08:06:29+00:00" />
<meta property="og:image" content="https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="801" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Egidio Docile" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Egidio Docile" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="8 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#article","isPartOf":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore"},"author":{"name":"Egidio Docile","@id":"https://linuxconfig.org/#/schema/person/6685c8c3ecd1c9bb7b2949d189fdaf55"},"headline":"How to backup and restore an xfs filesystem using xfsdump and xfsrestore","datePublished":"2022-11-23T09:49:26+00:00","dateModified":"2022-11-25T08:06:29+00:00","mainEntityOfPage":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore"},"wordCount":1273,"publisher":{"@id":"https://linuxconfig.org/#organization"},"image":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#primaryimage"},"thumbnailUrl":"https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg","keywords":["backup","filesystem","restore"],"articleSection":["Commands","System Administration"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore","url":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore","name":"How to backup and restore an xfs filesystem using xfsdump and xfsrestore - Linux Tutorials - Learn Linux Configuration","isPartOf":{"@id":"https://linuxconfig.org/#website"},"primaryImageOfPage":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#primaryimage"},"image":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#primaryimage"},"thumbnailUrl":"https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg","description":"In this tutorial we see how to create and restore XFS backups using the xfsdump and xfsrestore utilities on Linux.","breadcrumb":{"@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#primaryimage","url":"https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg","contentUrl":"https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg","width":1200,"height":801,"caption":"How to backup and restore an XFS filesystem with xfsbackup and xfsrestore"},{"@type":"BreadcrumbList","@id":"https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://linuxconfig.org/"},{"@type":"ListItem","position":2,"name":"How to backup and restore an xfs filesystem using xfsdump and xfsrestore"}]},{"@type":"WebSite","@id":"https://linuxconfig.org/#website","url":"https://linuxconfig.org/","name":"Linux Tutorials - Learn Linux Configuration","description":"LinuxConfig.org","publisher":{"@id":"https://linuxconfig.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://linuxconfig.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://linuxconfig.org/#organization","name":"Linux Tutorials - Learn Linux Configuration","url":"https://linuxconfig.org/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://linuxconfig.org/#/schema/logo/image/","url":"https://linuxconfig.org/wp-content/uploads/2021/07/logo-lc.png","contentUrl":"https://linuxconfig.org/wp-content/uploads/2021/07/logo-lc.png","width":250,"height":70,"caption":"Linux Tutorials - Learn Linux Configuration"},"image":{"@id":"https://linuxconfig.org/#/schema/logo/image/"}},{"@type":"Person","@id":"https://linuxconfig.org/#/schema/person/6685c8c3ecd1c9bb7b2949d189fdaf55","name":"Egidio Docile","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://linuxconfig.org/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/bd1e4513ccb77c15a87dc7223e633f58?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/bd1e4513ccb77c15a87dc7223e633f58?s=96&d=mm&r=g","caption":"Egidio Docile"},"url":"https://linuxconfig.org/author/egidio"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; Feed" href="https://linuxconfig.org/feed" />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; Comments Feed" href="https://linuxconfig.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Linux Tutorials - Learn Linux Configuration &raquo; How to backup and restore an xfs filesystem using xfsdump and xfsrestore Comments Feed" href="https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore/feed" />
<script>
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxconfig.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Source+Serif+Pro:regular,600,700|Oswald:200,300,regular,500,600,700' media='all' />
<link rel='stylesheet' id='crp-style-text-only-css' href='https://linuxconfig.org/wp-content/plugins/contextual-related-posts/css/text-only.min.css?ver=3.2.3' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css' href='https://linuxconfig.org/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.1.3' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://linuxconfig.org/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.1.3' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='generate-blog-images-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/blog/functions/css/featured-images.min.css?ver=2.1.1' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/secondary-nav/functions/css/main.min.css?ver=2.1.1' media='all' />
<style id='generate-secondary-nav-inline-css'>
.secondary-navigation{background-color:#636363;}.secondary-nav-below-header .secondary-navigation .inside-navigation.grid-container, .secondary-nav-above-header .secondary-navigation .inside-navigation.grid-container{padding:0px;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;font-weight:bold;font-size:14px;line-height:27px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;font-size:14px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:40px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:13px;}.secondary-navigation .main-nav ul li:not([class*="current-menu-"]):hover > a, .secondary-navigation .main-nav ul li:not([class*="current-menu-"]):focus > a, .secondary-navigation .main-nav ul li.sfHover:not([class*="current-menu-"]) > a, .secondary-menu-bar-items .menu-bar-item:hover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):hover > a,.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):focus > a,.secondary-navigation .main-nav ul ul li.sfHover:not([class*="current-menu-"]) > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a{color:#222222;background-color:#ffffff;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#474747;}.secondary-navigation.toggled .dropdown-menu-toggle:before{display:none;}@media (max-width: 1040px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/secondary-nav/functions/css/main-mobile.min.css?ver=2.1.1' media='all' />
<link rel='stylesheet' id='generate-offside-css' href='https://linuxconfig.org/wp-content/plugins/gp-premium/menu-plus/functions/css/offside.min.css?ver=2.1.1' media='all' />
<style id='generate-offside-inline-css'>
.slideout-navigation.main-navigation{background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul li a{color:#ffffff;font-weight:500;text-transform:none;font-size:18px;}.slideout-navigation.main-navigation ul ul{background-color:#222222;}.slideout-navigation.main-navigation .main-nav ul ul li a{color:#ffffff;}.slideout-navigation.main-navigation.do-overlay .main-nav ul ul li a{font-size:1em;font-size:17px;}@media (max-width:768px){.slideout-navigation.main-navigation .main-nav ul li a{font-size:18px;}.slideout-navigation.main-navigation .main-nav ul ul li a{font-size:17px;}}.slideout-navigation.main-navigation .main-nav ul li:not([class*="current-menu-"]):hover > a, .slideout-navigation.main-navigation .main-nav ul li:not([class*="current-menu-"]):focus > a, .slideout-navigation.main-navigation .main-nav ul li.sfHover:not([class*="current-menu-"]) > a{color:#f7f7f7;background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul ul li:not([class*="current-menu-"]):hover > a, .slideout-navigation.main-navigation .main-nav ul ul li:not([class*="current-menu-"]):focus > a, .slideout-navigation.main-navigation .main-nav ul ul li.sfHover:not([class*="current-menu-"]) > a{color:#fafafa;background-color:#222222;}.slideout-navigation.main-navigation .main-nav ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#e0314f;}.slideout-navigation.main-navigation .main-nav ul ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#222222;}.slideout-navigation, .slideout-navigation a{color:#ffffff;}.slideout-navigation button.slideout-exit{color:#ffffff;padding-left:20px;padding-right:20px;}.slide-opened nav.toggled .menu-toggle:before{display:none;}@media (max-width: 1040px){.menu-bar-item.slideout-toggle{display:none;}}
</style>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxconfig.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxconfig.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://linuxconfig.org/?p=16822' />
<link rel="alternate" type="application/json+oembed" href="https://linuxconfig.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconfig.org%2Fhow-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxconfig.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconfig.org%2Fhow-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore&#038;format=xml" />
<link rel="pingback" href="https://linuxconfig.org/xmlrpc.php">
<style id="generateblocks-css">.gb-button-wrapper{display:flex;flex-wrap:wrap;align-items:flex-start;justify-content:flex-start;clear:both;}.gb-icon{display:inline-flex;line-height:0;}.gb-icon svg{height:1em;width:1em;fill:currentColor;}.gb-button-wrapper .gb-button{display:inline-flex;align-items:center;justify-content:center;text-align:center;text-decoration:none;transition:.2s background-color ease-in-out, .2s color ease-in-out, .2s border-color ease-in-out, .2s opacity ease-in-out, .2s box-shadow ease-in-out;}.gb-button-wrapper .gb-button .gb-icon{align-items:center;}.gb-button-wrapper a.gb-button-ac59105c,.gb-button-wrapper a.gb-button-ac59105c:visited{background-color:#0366d6;color:#ffffff;padding:15px 20px;}.gb-button-wrapper a.gb-button-ac59105c:hover,.gb-button-wrapper a.gb-button-ac59105c:active,.gb-button-wrapper a.gb-button-ac59105c:focus{background-color:#222222;color:#ffffff;}.gb-button-wrapper a.gb-button-9e8d3737,.gb-button-wrapper a.gb-button-9e8d3737:visited{background-color:#0366d6;color:#ffffff;padding:15px 20px;}.gb-button-wrapper a.gb-button-9e8d3737:hover,.gb-button-wrapper a.gb-button-9e8d3737:active,.gb-button-wrapper a.gb-button-9e8d3737:focus{background-color:#222222;color:#ffffff;}.gb-button-wrapper a.gb-button-6841cab3,.gb-button-wrapper a.gb-button-6841cab3:visited{background-color:#0366d6;color:#ffffff;padding:15px 20px;}.gb-button-wrapper a.gb-button-6841cab3:hover,.gb-button-wrapper a.gb-button-6841cab3:active,.gb-button-wrapper a.gb-button-6841cab3:focus{background-color:#222222;color:#ffffff;}.gb-highlight{background:none;color:unset;}</style><BASE href="/">
<script async src="https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js"></script><style>
.posted-on .updated:before {
content: "Last Updated: ";
}
</style><link rel="icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://linuxconfig.org/wp-content/uploads/2021/08/cropped-android-chrome-512x512-1-270x270.png" />
<style id="wp-custom-css">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</style>
</head>
<body class="post-template-default single single-post postid-16822 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-left slideout-enabled slideout-mobile sticky-menu-slide page-id-16822 right-sidebar nav-float-right one-container nav-search-enabled header-aligned-left dropdown-hover" itemtype="https://schema.org/Blog" itemscope>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <nav id="secondary-navigation" class="secondary-navigation grid-container" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
<div class="inside-navigation grid-container grid-parent">
<button class="menu-toggle secondary-menu-toggle">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span> </button>
<div class="main-nav"><ul id="menu-top-bar-menu" class=" secondary-menu sf-menu"><li id="menu-item-9806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9806"><a href="https://linuxconfig.org/ubuntu">Ubuntu<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-9807" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9807"><a href="https://linuxconfig.org/ubuntu-20-04-guide">Ubuntu 20.04 Guide</a></li>
<li id="menu-item-9814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9814"><a href="https://linuxconfig.org/ubuntu-18-04">Ubuntu 18.04</a></li>
</ul>
</li>
<li id="menu-item-9808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9808"><a href="https://linuxconfig.org/debian">Debian</a></li>
<li id="menu-item-9809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9809"><a href="https://linuxconfig.org/redhat">Redhat / CentOS / AlmaLinux</a></li>
<li id="menu-item-9817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9817"><a href="https://linuxconfig.org/fedora">Fedora</a></li>
<li id="menu-item-9810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9810"><a href="https://linuxconfig.org/kali-linux">Kali Linux</a></li>
</ul></div> </div>
</nav>
<header class="site-header has-inline-mobile-toggle" id="masthead" aria-label="Site" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container">
<div class="site-logo">
<a href="https://linuxconfig.org/" title="Linux Tutorials &#8211; Learn Linux Configuration" rel="home">
<img class="header-image is-logo-image" alt="Linux Tutorials &#8211; Learn Linux Configuration" src="https://linuxconfig.org/wp-content/uploads/2021/07/logo-lc.png" title="Linux Tutorials &#8211; Learn Linux Configuration" width="250" height="70" />
</a>
</div> <nav class="main-navigation mobile-menu-control-wrapper" id="mobile-menu-control-wrapper" aria-label="Mobile Toggle">
<div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div> <button data-nav="site-navigation" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
</nav>
<nav class="main-navigation has-menu-bar-items sub-menu-right" id="site-navigation" aria-label="Primary" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation">
<form method="get" class="search-form navigation-search" action="https://linuxconfig.org/">
<input type="search" class="search-field" value="" name="s" title="Search" />
</form> <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-top-main-menu" class=" menu sf-menu"><li id="menu-item-9640" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9640"><a href="https://linuxconfig.org/linux-tutorials">Linux Tutorials</a></li>
<li id="menu-item-8425" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8425"><a href="https://linuxconfig.org/system-administration-configuration">System Admin</a></li>
<li id="menu-item-8426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8426"><a href="https://linuxconfig.org/programming-scripting">Programming</a></li>
<li id="menu-item-8427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8427"><a href="https://linuxconfig.org/multimedia-games">Multimedia</a></li>
<li id="menu-item-8525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8525"><a rel="nofollow noopener noreferrer" href="https://forum.linuxconfig.org/">Forum</a></li>
<li id="menu-item-9641" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9641"><a href="https://linuxconfig.org/linux-commands">Linux Commands</a></li>
<li id="menu-item-8526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8526"><a rel="nofollow noopener noreferrer" href="https://linuxconfig.org/linuxcareers-com-linux-job-portal">Linux Jobs</a></li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div><div class="leaderboard-ad-wrapper" data-fuse="22413944646"></div> </div>
</nav>
<div class="header-widget">
</div>
</div>
</header>
<div class="site grid-container container hfeed" id="page">
<div class="site-content" id="content">
<div class="content-area" id="primary">
<main class="site-main" id="main">
<article id="post-16822" class="post-16822 post type-post status-publish format-standard has-post-thumbnail hentry category-commands category-system-administration-configuration tag-backup tag-filesystem tag-restore wpautop" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header" aria-label="Content">
<h1 class="entry-title" itemprop="headline">How to backup and restore an xfs filesystem using xfsdump and xfsrestore</h1> <div class="entry-meta">
<span class="posted-on"><time class="entry-date updated-date" datetime="2022-11-25T19:06:29+11:00" itemprop="dateModified">25 November 2022</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://linuxconfig.org/author/egidio" title="View all posts by Egidio Docile" rel="author" itemprop="url"><span class="author-name" itemprop="name">Egidio Docile</span></a></span></span> </div>
<div data-fuse="22189504503" class="incontent_ads"></div>
</header>
<div class="entry-content" itemprop="text">
<p>XFS is a journaled filesystem originally developed by Silicon Graphics in 1993; it was released under the GPL license in the year 2000 and ported to  the Linux kernel in 2001. Due to its high scalability and performances, XFS became the default filesystem in recent versions of Red Hat Enterprise Linux and its clones.</p>
<p><span id="more-16822"></span></p>
<p>In this tutorial we see how to create and restore XFS backups using the xfsdump and xfsrestore utilities on Linux.</p>
<p><strong>In this tutorial you will learn:</strong></p>
<ul>
<li>How to create and restore full and incremental backups of an XFS filesystem</li>
<li>How to exclude/include only a subset of files in a backup</li>
<li>How to list files included in a backup</li>
</ul>
<figure id="attachment_16829" aria-describedby="caption-attachment-16829" style="width: 1190px" class="wp-caption alignnone"><img class="size-full wp-image-16829" src="https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg" alt="How to backup and restore an xfs filesystem with xfsbackup and xfsrestore" width="1200" height="801" srcset="https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore.jpg 1200w, https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore-300x200.jpg 300w, https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore-1024x684.jpg 1024w, https://linuxconfig.org/wp-content/uploads/2022/11/00-how-to-backup-and-restore-an-xfs-filesystem-with-xfsbackup-and-xfsrestore-768x513.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption id="caption-attachment-16829" class="wp-caption-text">How to backup and restore an XFS filesystem with xfsbackup and xfsrestore</figcaption></figure>
<p>&nbsp;</p>
<table class="uk-table uk-table-striped uk-table-condensed">
<caption>Software requirements and conventions used</caption>
<thead>
<tr>
<th>Category</th>
<th>Requirements, Conventions or Software Version Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>Distribution independent</td>
</tr>
<tr>
<td>Software</td>
<td>xfsdump, xfsrestore</td>
</tr>
<tr>
<td>Other</td>
<td>None</td>
</tr>
<tr>
<td>Conventions</td>
<td># &#8211; requires given <a href="linux-commands">linux-commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command $ &#8211; requires given <a href="linux-commands">linux-commands</a> to be executed as a regular non-privileged user</td>
</tr>
</tbody>
</table>
<h2>Installation</h2>
<p>The <code>xfsdump</code> and <code>xfsrestore</code> utilities are packaged and included in the official repositories of all the major Linux distributions, therefore we can simply install it with their respective package managers. On distribution which are part of the Red Hat family, such as Fedora or Rocky Linux, for example, we can perform the installation with <code>dnf</code>. Both utilities are included in the “xfsdump” package:</p>
<pre>$ sudo dnf install xfsdump</pre>
<p>On Debian and Debian-based distributions, instead, we can  use <code>apt</code>:</p>
<pre>$ sudo apt install xfsdump</pre>
<p>If we are using Archlinux, instead, we can perform the same operation using <code>pacman</code>:</p>
<pre>$ sudo pacman -S xfsdump</pre>
<p>Once the installation is performed, we can create our first backup. Let’s see how.</p>
<h2>Creating a backup with xfsdump</h2>
<p>Xfsdump can save backups as files or write to tape devices. In this article we will explore the former approach. Creating a backup of an XFS filesystem with xfsdump is quite simple. In the most basic case we invoke the utility and provide <strong>the mountpoint of the filesystem we want to backup</strong> (the filesystem must be mounted) and the backup destination. The latter is specified via the <code>-f</code> option, the former is passed as argument to the command.</p>
<p><hr><div class="incontent_ads" data-fuse="22189504506"></div><hr> Suppose we want to create a backup of the boot filesystem, mounted at <code>/boot</code>, to the <code>/data/boot.xfsdump</code>file (name and extensions are arbitrary). With administrative privileges, we would launch the following command:</p>
<pre>$ sudo xfsdump -f /data/boot.xfsdump /boot</pre>
<p>As soon as we issue the command, we will be prompted to provide a <strong>label</strong> to identify the dump session, and another one to identify the media we are performing the backup on. Labels are recorded in the backup inventory (more on this later), and are especially useful when creating backups on tape drives. For the sake of this example we just use the &#8220;session_0&#8221; label to identify our session and datapart as media label:</p>
<pre> ============================= dump label dialog ==============================

please enter label for this dump session (timeout in 300 sec)
 -&gt; session_0

</pre>
<pre>============================ media label dialog =============================

please enter label for media in drive 0 (timeout in 300 sec)
 -&gt; datapart
</pre>
<p>To make the task non-interactive, we can simply provide the session and media labels as arguments to the <code>-L</code>and <code>-M</code> options, respectively:</p>
<pre>$ sudo xfsdump -L session_0 -M datapart -f /data/boot.xfsdump /boot</pre>
<h3>Creating incremental backups</h3>
<p>The command we saw in the previous examples produces a full or <strong>level 0</strong> backup, which includes all the files in the filesystem. By using xfsdump, however, we can also create <strong>incremental backups</strong>. An incremental backup includes only changes occurred since the previous backup (full or incremental itself) was performed. For this reason they are usually performed very quickly.</p>
<p>To create an incremental backup, all we have to do is to specify the backup level (0-9) by passing it as argument to the <code>-l</code> option when invoking xfsdump. If the option is omitted, as we saw, a level 0 backup is created. To perform a level 1 backup, we would run:</p>
<pre>$ sudo xfsdump -l 1 -L session_1 -M datapart -f /data/boot.xfsdump1 /boot</pre>
<p>The level 1 backup is performed against the last level 0 backup recorded in the inventory. It goes by itself that backup levels must be incremented gradually. We can&#8217;t, for example, create a level 3 backup if a level 2 backup doesn&#8217;t exist.</p>
<h3>Excluding files from a backup</h3>
<p>Sometimes we may want to include only a subset of files in our backups. In order to achieve our goal we can basically use three strategies:</p>
<ol>
<li>Exclude files over a specific size</li>
<li>Exclude files tagged with the “no dump” attribute.</li>
<li>Include only files contained in a specific directory</li>
</ol>
<h4>Excluding files bigger than a specific size</h4>
<p>To exclude files which exceed a specific size from the filesystem backup, we use the <code>-z</code> option, and pass the size threshold expressed in kilobytes as argument. With the following command we exclude files bigger than 10 Megabytes (10000 Kilobytes):</p>
<pre>$ sudo xfsrestore -t -f /data/boot.xfsdump</pre>
<h4>Excluding arbitrary files</h4>
<p>To exclude arbitrary files from the filesystem backup, instead, we must tag them with the <code>no dump</code> attribute. As we discussed in our tutorial about <a href="https://linuxconfig.org/how-to-list-and-manage-files-attributes-on-linux">managing filesystem attributes on Linux</a>, we can perform such task by using the <code>chattr</code> utility. Suppose, for example, we want to exclude the <code>/boot/excludeme</code> file from our backup. To set the “no dump” attribute on it, we would run:</p>
<pre>$ sudo chattr +d /boot/excludeme</pre>
<p><hr><div class="incontent_ads" data-fuse="22189504224"></div><hr>The “no dump” attribute is identified by a <code>d</code>. The &#8220;+&#8221; sign in front of it we used in the command, means we want to activate the attribute. Now, to exclude tagged files from a backup, all we have to do is to invoke xfsdump with the <code>-e</code> option:</p>
<pre>$ sudo xfsdump -e -f /data/boot.xfsdump /boot</pre>
<h4>Including only files in a specific directory</h4>
<p>In order to include only files contained in specific directories in our backup, we use the <code>-s</code> option. For each directory we want to include we must repeat the option, and pass the path of the directory as argument. The path of the directory must be <strong>relative to the filesystem mountpoint</strong>. Just as an example, to include only the <code>/boot/efi</code> directory and its content in our backup, we would run:</p>
<pre>$ sudo xfsdump -s efi -f /data/boot/xfsdump /boot</pre>
<h2>Restoring a backup with xfsrestore</h2>
<p>The xfsrestore utility is used to restore backups created with xfsdump. When invoked with the<code>-I</code> option, xfsdump displays the backups available in the <strong>inventory</strong>, which is saved in the <code>/var/lib/xfsdump/inventory</code> directory. As you can see below, the output produced by the command includes the backups we performed in the previous examples:</p>
<pre>$ xfsrestore -I
file system 0:
        fs id:          e65721d2-d766-4556-85e2-60c36022aea7
        session 0:
                mount point:    localhost.localdomain:/boot
                device:         localhost.localdomain:/dev/vda1
                time:           Wed Nov 23 10:49:56 2022
                session label:  "session_0"
                session id:     8e7bf8a3-ef36-4dbe-ae3c-1b31e6361596
                level:          0
                resumed:        NO
                subtree:        NO
                streams:        1
                stream 0:
                        pathname:       /data/boot.xfsdump
                        start:          ino 133 offset 0
                        end:            ino 1573039 offset 0
                        interrupted:    NO
                        media files:    1
                        media file 0:
                                mfile index:    0
                                mfile type:     data
                                mfile size:     164174336
                                mfile start:    ino 133 offset 0
                                mfile end:      ino 1573039 offset 0
                                media label:    "datapart"
                                media id:       82475520-22d8-40e7-9304-04136f90f680
        session 1:
                mount point:    localhost.localdomain:/boot
                device:         localhost.localdomain:/dev/vda1
                time:           Wed Nov 23 10:52:06 2022
                session label:  "session_1"
                session id:     2d0697d1-9058-4d42-a6b9-5981402013ce
                level:          1
                resumed:        NO
                subtree:        NO
                streams:        1
                stream 0:
                        pathname:       /data/boot.xfsdump1
                        start:          ino 0 offset 0
                        end:            ino 1 offset 0
                        interrupted:    NO
                        media files:    1
                        media file 0:
                                mfile index:    0
                                mfile type:     data
                                mfile size:     20736
                                mfile start:    ino 0 offset 0
                                mfile end:      ino 1 offset 0
                                media label:    "datapart"
                                media id:       2b2414ca-8f16-46bf-bfd7-016220aff8c3
xfsrestore: Restore Status: SUCCESS
</pre>
<h3>Listing the content of a backup</h3>
<p>Before proceeding to restore a backup we may want to take a look at its content. To perform such action, we invoke xfsdump with the <code>-t</code> option, and, as usual, we reference the backup by passing its path as argument to <code>-f</code>. To list the content of the backup saved as <code>/data/boot.xfsdump</code>, we would run:</p>
<pre>$ xfsrestore -t -f /data/boot.xfsdump</pre>
<h3>Restoring a full backup</h3>
<p>To restore a <strong>full backup</strong>, we invoke xfsdump and specify the path to the backup and the location we want to restore the filesystem to. For example, to restore the full backup we performed in this article to the <code>/test</code> directory, we would run:</p>
<pre>$ sudo xfsrestore -f /data/boot.xfsdump /test</pre>
<p><hr><div class="incontent_ads" data-fuse="22189504509"></div><hr>Once the operation is completed, we can see the <code>/test</code> directory contains the files which were part of the backup. As you can see, extended file attributes, as the SELinux context, are preserved:</p>
<pre>$ ls -Z /test
      system_u:object_r:boot_t:s0 config-5.14.0-70.13.1.el9_0.x86_64
      system_u:object_r:boot_t:s0 efi
      system_u:object_r:boot_t:s0 grub2
      system_u:object_r:boot_t:s0 initramfs-0-rescue-f533a7d261374b28b305da65ada0f15f.img
      system_u:object_r:boot_t:s0 initramfs-5.14.0-70.13.1.el9_0.x86_64.img
      system_u:object_r:boot_t:s0 initramfs-5.14.0-70.13.1.el9_0.x86_64kdump.img
      system_u:object_r:boot_t:s0 loader
      system_u:object_r:boot_t:s0 symvers-5.14.0-70.13.1.el9_0.x86_64.gz
system_u:object_r:system_map_t:s0 System.map-5.14.0-70.13.1.el9_0.x86_64
      system_u:object_r:boot_t:s0 vmlinuz-0-rescue-f533a7d261374b28b305da65ada0f15f
      system_u:object_r:boot_t:s0 vmlinuz-5.14.0-70.13.1.el9_0.x86_64
</pre>
<h3>Restoring an incremental backup</h3>
<p>Restoring an incremental backup requires the restoration of all backups performed before it, starting from the last full backup. When using this strategy, each time we restore a backup, we must use the <code>-r</code> option, which enables the so called “cumulative” mode. Suppose, for example, we want to restore the state of the filesystem as it was when we performed the first incremental backup (level 1). As a first thing we restore the level 0 or full backup, this time adding <code>-r</code> to the command:</p>
<pre>$ sudo xfsrestore -r -f /data/boot.xfsdump /test</pre>
<p>Than, we proceed to restore the incremental, level 1 backup:</p>
<pre>$ sudo xfsrestore -r -f /data/boot.xfsdump1 /test</pre>
<h2>Conclusions</h2>
<p>In this tutorial we learned how to create and restore XFS filesystems backups by using the xfsdump and xfsrestore utilities. We saw how to create full and incremental backups, how to proceed when we want to restore them, and how to exclude/include only a subset of files in our backups.</p>
<div class="crp_related     crp-text-only"><h3>Related Linux Tutorials:</h3><ul><li><a href="https://linuxconfig.org/things-to-install-on-ubuntu-20-04" target="_blank" class="crp_link post-2035"><span class="crp_title">Things to install on Ubuntu 20.04</span></a></li><li><a href="https://linuxconfig.org/how-to-create-incremental-and-differential-backups-with-tar" target="_blank" class="crp_link post-14227"><span class="crp_title">How to create incremental and differential backups with tar</span></a></li><li><a href="https://linuxconfig.org/things-to-do-after-installing-ubuntu-20-04-focal-fossa-linux" target="_blank" class="crp_link post-2072"><span class="crp_title">Things to do after installing Ubuntu 20.04 Focal Fossa Linux</span></a></li><li><a href="https://linuxconfig.org/ubuntu-22-04-system-backup-and-restore" target="_blank" class="crp_link post-13260"><span class="crp_title">Ubuntu 22.04 System Backup and Restore</span></a></li><li><a href="https://linuxconfig.org/linux-download" target="_blank" class="crp_link post-2124"><span class="crp_title">Linux Download</span></a></li><li><a href="https://linuxconfig.org/mint-20-better-than-ubuntu-and-microsoft-windows" target="_blank" class="crp_link post-2441"><span class="crp_title">Mint 20: Better Than Ubuntu and Microsoft Windows?</span></a></li><li><a href="https://linuxconfig.org/ubuntu-20-04-system-backup-and-restore" target="_blank" class="crp_link post-1977"><span class="crp_title">Ubuntu 20.04 System Backup and Restore</span></a></li><li><a href="https://linuxconfig.org/how-to-create-incremental-backups-using-rsync-on-linux" target="_blank" class="crp_link post-2192"><span class="crp_title">How to create incremental backups using rsync on Linux</span></a></li><li><a href="https://linuxconfig.org/how-to-create-incremental-system-backups-with-timeshift-on-linux" target="_blank" class="crp_link post-15283"><span class="crp_title">How to create incremental system backups with Timeshift on&hellip;</span></a></li><li><a href="https://linuxconfig.org/ubuntu-20-04-tricks-and-things-you-might-not-know" target="_blank" class="crp_link post-2089"><span class="crp_title">Ubuntu 20.04 Tricks and Things you Might not Know</span></a></li></ul><div class="crp_clear"></div></div> </div>
<footer class="entry-meta" aria-label="Entry meta">
<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://linuxconfig.org/commands" rel="category tag">Commands</a>, <a href="https://linuxconfig.org/system-administration-configuration" rel="category tag">System Administration</a></span> <span class="tags-links"><span class="gp-icon icon-tags"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M20 39.5c-8.836 0-16 7.163-16 16v176c0 4.243 1.686 8.313 4.687 11.314l224 224c6.248 6.248 16.378 6.248 22.626 0l176-176c6.244-6.244 6.25-16.364.013-22.615l-223.5-224A15.999 15.999 0 00196.5 39.5H20zm56 96c0-13.255 10.745-24 24-24s24 10.745 24 24-10.745 24-24 24-24-10.745-24-24z" /><path d="M259.515 43.015c4.686-4.687 12.284-4.687 16.97 0l228 228c4.686 4.686 4.686 12.284 0 16.97l-180 180c-4.686 4.687-12.284 4.687-16.97 0-4.686-4.686-4.686-12.284 0-16.97L479.029 279.5 259.515 59.985c-4.686-4.686-4.686-12.284 0-16.97z" /></svg></span><span class="screen-reader-text">Tags </span><a href="https://linuxconfig.org/tag/backup" rel="tag">backup</a>, <a href="https://linuxconfig.org/tag/filesystem" rel="tag">filesystem</a>, <a href="https://linuxconfig.org/tag/restore" rel="tag">restore</a></span> <nav id="nav-below" class="post-navigation" aria-label="Single Post">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev" title="Previous"><a href="https://linuxconfig.org/ubuntu-pro-vs-ubuntu-free" rel="prev">Ubuntu Pro vs Ubuntu Free</a></span></div> </nav>
</footer>
<hr>
<center>

<div data-fuse="22198552927" class="incontent_ads"></div>
</center>
<hr>
<center><font size=6><strong>Comments and Discussions</strong></font><br><img src="https://linuxconfig.org/wp-content/uploads/2021/07/linuxconfig-forum-logo-1.png" alt="Linux Forum" width="250" height="46"></center>
<div id='discourse-comments'></div>
<script type="text/javascript">
  DiscourseEmbed = { discourseUrl: 'https://forum.linuxconfig.org/',
                     discourseEmbedUrl: document.querySelector("link[rel='canonical']").getAttribute("href") };

  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>
</div>
</article>
</main>
</div>
<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
<div class="inside-right-sidebar">
<aside id="block-31" class="widget inner-padding widget_block"><div data-fuse="22189504221" class="sticky_ads"></div>
<hr style="margin: 2px" ;>
<div data-fuse="22189277162" class="sticky_ads"></div></aside> </div>
</div>
</div>
</div>
<div class="site-footer">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container">
<div class="inside-footer-widgets">
<div class="footer-widget-1">
<aside id="block-12" class="widget inner-padding widget_block">
<h3 id="h-newsletter">NEWSLETTER</h3>
</aside><aside id="block-11" class="widget inner-padding widget_block widget_text">
<p>Subscribe to&nbsp;Linux Career Newsletter&nbsp;to receive latest news, jobs, career advice and featured configuration tutorials.</p>
</aside><aside id="block-25" class="widget inner-padding widget_block"><div class="gb-button-wrapper gb-button-wrapper-47b15502">
<a class="gb-button gb-button-9e8d3737 gb-button-text" href="https://bit.ly/2X5D30q" rel="nofollow">SUBSCRIBE</a>
</div></aside><aside id="block-13" class="widget inner-padding widget_block">
<h3 id="h-write-for-us">WRITE FOR US</h3>
</aside><aside id="block-15" class="widget inner-padding widget_block widget_text">
<p>LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.</p>
</aside><aside id="block-16" class="widget inner-padding widget_block widget_text">
<p>When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month.</p>
</aside><aside id="block-21" class="widget inner-padding widget_block"><div class="gb-button-wrapper gb-button-wrapper-fea23fb6">
<a class="gb-button gb-button-ac59105c gb-button-text" href="https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/" rel="nofollow">APPLY NOW</a>
</div></aside> </div>
<div class="footer-widget-2">
<aside id="tag_cloud-3" class="widget inner-padding widget_tag_cloud"><h2 class="widget-title">TAGS</h2><div class="tagcloud"><a href="https://linuxconfig.org/tag/18-04" class="tag-cloud-link tag-link-75 tag-link-position-1" style="font-size: 15.748427672956pt;" aria-label="18.04 (202 items)">18.04</a>
<a href="https://linuxconfig.org/tag/administration" class="tag-cloud-link tag-link-14 tag-link-position-2" style="font-size: 22pt;" aria-label="administration (1,036 items)">administration</a>
<a href="https://linuxconfig.org/tag/apache" class="tag-cloud-link tag-link-27 tag-link-position-3" style="font-size: 8.9685534591195pt;" aria-label="apache (34 items)">apache</a>
<a href="https://linuxconfig.org/tag/applications" class="tag-cloud-link tag-link-43 tag-link-position-4" style="font-size: 14.691823899371pt;" aria-label="applications (154 items)">applications</a>
<a href="https://linuxconfig.org/tag/backup" class="tag-cloud-link tag-link-31 tag-link-position-5" style="font-size: 8.2641509433962pt;" aria-label="backup (28 items)">backup</a>
<a href="https://linuxconfig.org/tag/bash" class="tag-cloud-link tag-link-21 tag-link-position-6" style="font-size: 15.396226415094pt;" aria-label="bash (185 items)">bash</a>
<a href="https://linuxconfig.org/tag/beginner" class="tag-cloud-link tag-link-15 tag-link-position-7" style="font-size: 17.509433962264pt;" aria-label="beginner (324 items)">beginner</a>
<a href="https://linuxconfig.org/tag/browser" class="tag-cloud-link tag-link-74 tag-link-position-8" style="font-size: 9.5849056603774pt;" aria-label="browser (40 items)">browser</a>
<a href="https://linuxconfig.org/tag/centos" class="tag-cloud-link tag-link-61 tag-link-position-9" style="font-size: 9.4088050314465pt;" aria-label="centos (38 items)">centos</a>
<a href="https://linuxconfig.org/tag/centos8" class="tag-cloud-link tag-link-86 tag-link-position-10" style="font-size: 13.106918238994pt;" aria-label="centos8 (102 items)">centos8</a>
<a href="https://linuxconfig.org/tag/commands" class="tag-cloud-link tag-link-16 tag-link-position-11" style="font-size: 19.446540880503pt;" aria-label="commands (539 items)">commands</a>
<a href="https://linuxconfig.org/tag/database" class="tag-cloud-link tag-link-56 tag-link-position-12" style="font-size: 11.522012578616pt;" aria-label="database (66 items)">database</a>
<a href="https://linuxconfig.org/tag/debian" class="tag-cloud-link tag-link-20 tag-link-position-13" style="font-size: 9.8490566037736pt;" aria-label="debian (43 items)">debian</a>
<a href="https://linuxconfig.org/tag/desktop" class="tag-cloud-link tag-link-24 tag-link-position-14" style="font-size: 18.213836477987pt;" aria-label="desktop (384 items)">desktop</a>
<a href="https://linuxconfig.org/tag/development" class="tag-cloud-link tag-link-42 tag-link-position-15" style="font-size: 17.861635220126pt;" aria-label="development (352 items)">development</a>
<a href="https://linuxconfig.org/tag/docker" class="tag-cloud-link tag-link-68 tag-link-position-16" style="font-size: 8pt;" aria-label="docker (26 items)">docker</a>
<a href="https://linuxconfig.org/tag/fedora" class="tag-cloud-link tag-link-30 tag-link-position-17" style="font-size: 9.1446540880503pt;" aria-label="fedora (35 items)">fedora</a>
<a href="https://linuxconfig.org/tag/filesystem" class="tag-cloud-link tag-link-17 tag-link-position-18" style="font-size: 15.044025157233pt;" aria-label="filesystem (170 items)">filesystem</a>
<a href="https://linuxconfig.org/tag/firewall" class="tag-cloud-link tag-link-46 tag-link-position-19" style="font-size: 9.4968553459119pt;" aria-label="firewall (39 items)">firewall</a>
<a href="https://linuxconfig.org/tag/gaming" class="tag-cloud-link tag-link-60 tag-link-position-20" style="font-size: 11.433962264151pt;" aria-label="gaming (65 items)">gaming</a>
<a href="https://linuxconfig.org/tag/gnome" class="tag-cloud-link tag-link-63 tag-link-position-21" style="font-size: 11.081761006289pt;" aria-label="gnome (59 items)">gnome</a>
<a href="https://linuxconfig.org/tag/hardware" class="tag-cloud-link tag-link-47 tag-link-position-22" style="font-size: 9.937106918239pt;" aria-label="Hardware (44 items)">Hardware</a>
<a href="https://linuxconfig.org/tag/installation" class="tag-cloud-link tag-link-40 tag-link-position-23" style="font-size: 16.805031446541pt;" aria-label="installation (267 items)">installation</a>
<a href="https://linuxconfig.org/tag/java" class="tag-cloud-link tag-link-76 tag-link-position-24" style="font-size: 8pt;" aria-label="java (26 items)">java</a>
<a href="https://linuxconfig.org/tag/kali" class="tag-cloud-link tag-link-73 tag-link-position-25" style="font-size: 10.729559748428pt;" aria-label="kali (54 items)">kali</a>
<a href="https://linuxconfig.org/tag/manjaro" class="tag-cloud-link tag-link-84 tag-link-position-26" style="font-size: 8.5283018867925pt;" aria-label="manjaro (30 items)">manjaro</a>
<a href="https://linuxconfig.org/tag/multimedia" class="tag-cloud-link tag-link-32 tag-link-position-27" style="font-size: 15.308176100629pt;" aria-label="multimedia (181 items)">multimedia</a>
<a href="https://linuxconfig.org/tag/networking" class="tag-cloud-link tag-link-36 tag-link-position-28" style="font-size: 14.955974842767pt;" aria-label="networking (164 items)">networking</a>
<a href="https://linuxconfig.org/tag/nvidia" class="tag-cloud-link tag-link-67 tag-link-position-29" style="font-size: 10.11320754717pt;" aria-label="nvidia (46 items)">nvidia</a>
<a href="https://linuxconfig.org/tag/programming" class="tag-cloud-link tag-link-45 tag-link-position-30" style="font-size: 15.220125786164pt;" aria-label="programming (177 items)">programming</a>
<a href="https://linuxconfig.org/tag/python" class="tag-cloud-link tag-link-66 tag-link-position-31" style="font-size: 10.11320754717pt;" aria-label="python (46 items)">python</a>
<a href="https://linuxconfig.org/tag/redhat" class="tag-cloud-link tag-link-58 tag-link-position-32" style="font-size: 11.081761006289pt;" aria-label="redhat (59 items)">redhat</a>
<a href="https://linuxconfig.org/tag/rhel8" class="tag-cloud-link tag-link-85 tag-link-position-33" style="font-size: 13.194968553459pt;" aria-label="rhel8 (104 items)">rhel8</a>
<a href="https://linuxconfig.org/tag/scripting" class="tag-cloud-link tag-link-22 tag-link-position-34" style="font-size: 14.339622641509pt;" aria-label="scripting (140 items)">scripting</a>
<a href="https://linuxconfig.org/tag/security" class="tag-cloud-link tag-link-26 tag-link-position-35" style="font-size: 15.48427672956pt;" aria-label="security (191 items)">security</a>
<a href="https://linuxconfig.org/tag/server" class="tag-cloud-link tag-link-39 tag-link-position-36" style="font-size: 15.572327044025pt;" aria-label="server (196 items)">server</a>
<a href="https://linuxconfig.org/tag/ssh" class="tag-cloud-link tag-link-35 tag-link-position-37" style="font-size: 9.3207547169811pt;" aria-label="ssh (37 items)">ssh</a>
<a href="https://linuxconfig.org/tag/storage" class="tag-cloud-link tag-link-19 tag-link-position-38" style="font-size: 10.905660377358pt;" aria-label="storage (57 items)">storage</a>
<a href="https://linuxconfig.org/tag/terminal" class="tag-cloud-link tag-link-38 tag-link-position-39" style="font-size: 14.51572327044pt;" aria-label="terminal (148 items)">terminal</a>
<a href="https://linuxconfig.org/tag/ubuntu" class="tag-cloud-link tag-link-23 tag-link-position-40" style="font-size: 20.327044025157pt;" aria-label="ubuntu (670 items)">ubuntu</a>
<a href="https://linuxconfig.org/tag/ubuntu-20-04" class="tag-cloud-link tag-link-90 tag-link-position-41" style="font-size: 16.540880503145pt;" aria-label="ubuntu 20.04 (248 items)">ubuntu 20.04</a>
<a href="https://linuxconfig.org/tag/video" class="tag-cloud-link tag-link-92 tag-link-position-42" style="font-size: 8pt;" aria-label="video (26 items)">video</a>
<a href="https://linuxconfig.org/tag/virtualization" class="tag-cloud-link tag-link-54 tag-link-position-43" style="font-size: 10.025157232704pt;" aria-label="virtualization (45 items)">virtualization</a>
<a href="https://linuxconfig.org/tag/webapp" class="tag-cloud-link tag-link-50 tag-link-position-44" style="font-size: 9.2327044025157pt;" aria-label="webapp (36 items)">webapp</a>
<a href="https://linuxconfig.org/tag/webserver" class="tag-cloud-link tag-link-25 tag-link-position-45" style="font-size: 12.842767295597pt;" aria-label="webserver (95 items)">webserver</a></div>
</aside><aside id="block-50" class="widget inner-padding widget_block"><div class="gb-button-wrapper gb-button-wrapper-aa8d8e65">
<a class="gb-button gb-button-6841cab3 gb-button-text" href="/about-us">ABOUT US</a>
</div></aside> </div>
<div class="footer-widget-3">
<aside id="block-36" class="widget inner-padding widget_block">
<h3 id="h-featured-tutorials">FEATURED TUTORIALS</h3>
</aside><aside id="block-37" class="widget inner-padding widget_block"><ul>
<li>
<a href="https://linuxconfig.org/vim-tutorial" target="_blank">VIM tutorial for beginners</a>
</li> 
<li>
<a href="https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to install the NVIDIA drivers on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/bash-scripting-tutorial-for-beginners" target="_blank">Bash Scripting Tutorial for Beginners</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-check-centos-version" target="_blank">How to check CentOS version</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-find-my-ip-address-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to find my IP address on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/ubuntu-20-04-remote-desktop-access-from-windows-10" target="_blank">Ubuntu 20.04 Remote Desktop Access from Windows 10</a>
</li>
<li>
<a href="https://linuxconfig.org/howto-mount-usb-drive-in-linux" target="_blank">Howto mount USB drive in Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-missing-ifconfig-command-on-debian-linux" target="_blank">How to install missing ifconfig command on Debian Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/amd-radeon-ubuntu-20-04-driver-installation" target="_blank">AMD Radeon Ubuntu 20.04 Driver Installation</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-configure-static-ip-address-on-ubuntu-18-10-cosmic-cuttlefish-linux" target="_blank">Ubuntu Static IP configuration</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-use-arrays-in-bash-script" target="_blank">How to use bash array in a shell script</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-turn-on-off-ip-forwarding-in-linux" target="_blank">Linux IP forwarding – How to Disable/Enable</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-tweak-tool-on-ubuntu-20-04-lts-focal-fossa-linux" target="_blank">How to install Tweak Tool on Ubuntu 20.04 LTS Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-enable-disable-firewall-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">How to enable/disable firewall on Ubuntu 18.04 Bionic Beaver Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-configure-static-ip-address-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">Netplan static IP on Ubuntu configuration</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-change-from-default-to-alternative-python-version-on-debian-linux" target="_blank">How to change from default to alternative Python version on Debian Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-enable-root-login-on-kali-linux" target="_blank">Set Kali root password and enable root login</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-adobe-acrobat-reader-on-ubuntu-20-04-focal-fossa-linux" target="_blank">How to Install Adobe Acrobat Reader on Ubuntu 20.04 Focal Fossa Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux" target="_blank">How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</a>
</li>
<li>
<a href="https://linuxconfig.org/how-to-check-nvidia-driver-version-on-your-linux-system" target="_blank">How to check NVIDIA driver version on your Linux system</a>
</li>
<li>
<a href="https://linuxconfig.org/nvidia-rtx-3080-eth-hashrate-and-overclock-settings-on-hiveos" target="_blank">Nvidia RTX 3080 Ethereum Hashrate and Mining Overclock settings on HiveOS Linux</a>
</li>
</ul></aside> </div>
<div class="footer-widget-4">
<aside id="block-40" class="widget inner-padding widget_block">
<h3 class="gb-headline gb-headline-3c90cba8 gb-headline-text">LATEST TUTORIALS</h3>
</aside><aside id="block-38" class="widget inner-padding widget_block widget_recent_entries"><ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-backup-and-restore-an-xfs-filesystem-using-xfsdump-and-xfsrestore">How to backup and restore an xfs filesystem using xfsdump and xfsrestore</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/ubuntu-pro-vs-ubuntu-free">Ubuntu Pro vs Ubuntu Free</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/qemu-vs-virtualbox-whats-the-difference">QEMU vs VirtualBox: What&#8217;s the difference?</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/qemu-vs-kvm-hypervisor-whats-the-difference">QEMU vs KVM hypervisor: What&#8217;s the difference?</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/share-your-desktop-screen-with-vnc-on-linux">Share your desktop screen with VNC on Linux</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-install-kde-plasma-desktop-on-fedora-linux">How to install KDE plasma Desktop on Fedora Linux</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/kubuntu-vs-fedora-kde-plasma-desktop">Kubuntu vs Fedora KDE plasma desktop</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/curl-command-not-found">Curl command not found</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-clone-a-linux-system">How to clone a Linux system</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-add-new-disk-to-existing-linux-system">How to add new disk to existing Linux system</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-format-data-with-column-in-linux">How to format data with Column in Linux</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-keep-configuration-files-under-version-control-with-etckeeper">How to keep configuration files under version control with Etckeeper</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/introduction-to-curl">Curl command basics tutorial with examples</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-upgrade-ubuntu-from-22-04-to-22-10">How to upgrade Ubuntu from 22.04 to 22.10</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-integrate-dialog-boxes-in-shell-scripts-with-whiptail">How to integrate dialog boxes in shell scripts with Whiptail</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/how-to-list-and-manage-files-attributes-on-linux">How to list and manage files attributes on Linux</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/check-rpm-package-dependencies-on-rhel-centos-rocky">Check RPM package dependencies on Rhel/Centos/Rocky</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/check-deb-package-dependencies-on-ubuntu-debian">Check DEB package dependencies on Ubuntu / Debian</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/full-disk-encryption-with-veracrypt-on-ubuntu-linux">Full disk Encryption with VeraCrypt on Ubuntu Linux</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://linuxconfig.org/usb-drive-benchmark-test-on-linux">USB Drive benchmark test on Linux</a></li>
</ul></aside> </div>
</div>
</div>
</div>
<footer class="site-info" aria-label="Site" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container">
<div class="copyright-bar">
&copy; 2022 TOSID Group Pty Ltd - LinuxConfig.org </div>
</div>
</footer>
</div>
<a title="Scroll back to top" aria-label="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<span class="gp-icon icon-arrow-up"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M305.863 314.916c0 2.266-1.133 4.815-2.832 6.514l-14.157 14.163c-1.699 1.7-3.964 2.832-6.513 2.832-2.265 0-4.813-1.133-6.512-2.832L164.572 224.276 53.295 335.593c-1.699 1.7-4.247 2.832-6.512 2.832-2.265 0-4.814-1.133-6.513-2.832L26.113 321.43c-1.699-1.7-2.831-4.248-2.831-6.514s1.132-4.816 2.831-6.515L158.06 176.408c1.699-1.7 4.247-2.833 6.512-2.833 2.265 0 4.814 1.133 6.513 2.833L303.03 308.4c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" /></svg></span>
</a> <nav id="generate-slideout-menu" class="main-navigation slideout-navigation do-overlay" itemtype="https://schema.org/SiteNavigationElement" itemscope style="display: none;">
<div class="inside-navigation grid-container grid-parent">
<button class="slideout-exit has-svg-icon"><span class="gp-icon pro-close">
<svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" />
</svg>
</span> <span class="screen-reader-text">Close</span></button><div class="main-nav"><ul id="menu-top-main-menu-1" class=" slideout-menu"><li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9640"><a href="https://linuxconfig.org/linux-tutorials">Linux Tutorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8425"><a href="https://linuxconfig.org/system-administration-configuration">System Admin</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8426"><a href="https://linuxconfig.org/programming-scripting">Programming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8427"><a href="https://linuxconfig.org/multimedia-games">Multimedia</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8525"><a rel="nofollow noopener noreferrer" href="https://forum.linuxconfig.org/">Forum</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9641"><a href="https://linuxconfig.org/linux-commands">Linux Commands</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8526"><a rel="nofollow noopener noreferrer" href="https://linuxconfig.org/linuxcareers-com-linux-job-portal">Linux Jobs</a></li>
</ul></div> </div>
</nav>
<script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><script id='generate-offside-js-extra'>
var offSide = {"side":"left"};
</script>
<script src='https://linuxconfig.org/wp-content/plugins/gp-premium/menu-plus/functions/js/offside.min.js?ver=2.1.1' id='generate-offside-js'></script>
<!--[if lte IE 11]>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.1.3' id='generate-navigation-search-js'></script>
<script id='generate-back-to-top-js-extra'>
var generatepressBackToTop = {"smooth":"1"};
</script>
<script src='https://linuxconfig.org/wp-content/themes/generatepress/assets/js/back-to-top.min.js?ver=3.1.3' id='generate-back-to-top-js'></script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/vaafb692b2aea4879b33c060e79fe94621666317369993" integrity="sha512-0ahDYl866UMhKuYcW078ScMalXqtFJggm7TmlUtp0UlD4eQk0Ixfnm5ykXKvGJNFjLMoortdseTfsRT8oCfgGA==" data-cf-beacon='{"rayId":"771aabbfcd0b17b8","version":"2022.11.3","r":1,"token":"1637300d8a394c64a4b8ffff41ff1ca8","si":100}' crossorigin="anonymous"></script>
</body>
</html>
