<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log /><meta name=keywords content="analyze, Webserver, Apache, Log, format, logging, forensic, how, linux, modules, loglevel, verbose" /><meta name=author content="Korbin Brown" /><meta name=description content="How to analyze and interpret Apache Webserver Log" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>How to analyze and interpret Apache Webserver Log - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/8IL00A6ZVvn8kLikKDuxLCbm0rA.js"></script><link href="https://linuxconfig.org/component/search/?Itemid=2728&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style><link rel=preload href=/media/plg_jchoptimize/cache/css/e5cb114958b8c7dc1c8fc3fd2f2ed830_0.css as=style onload="this.onload=null;this.rel='stylesheet'"><noscript><link rel=stylesheet href=/media/plg_jchoptimize/cache/css/e5cb114958b8c7dc1c8fc3fd2f2ed830_0.css></noscript> <script>(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){};}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload");}catch(e){ret=false;}
return function(){return ret;};})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener){link.removeEventListener("load",enableStylesheet);}else if(link.attachEvent){link.detachEvent("onload",enableStylesheet);}
link.setAttribute("onload",null);link.media=finalMedia;}
if(link.addEventListener){link.addEventListener("load",enableStylesheet);}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet);}
setTimeout(function(){link.rel="stylesheet";link.media="only x";});setTimeout(enableStylesheet,3000);};rp.poly=function(){if(rp.support()){return;}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",true);rp.bindMediaToggle(link);}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run);});}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run);});}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS;}
else{w.loadCSS=loadCSS;}}(typeof global!=="undefined"?global:this));</script><noscript><style>.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2728 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> <a href=https://bit.ly/2X5D30q rel=nofollow data-uk-tooltip="{pos:'bottom'}">Newsletter </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-55"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" /><noscript><img src=https://linuxconfig.org//images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /></noscript></a> </div></div><div class="g-block hidden-phone size-45"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <a href=https://bit.ly/linux-job-alert alt="Linux Jobs" rel=nofollow target=_blank><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png><noscript><img src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 data-src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png class=jch-lazyload width=468 height=60 /><noscript><img src=https://linuxconfig.org/images/banners/linuxcareers-get-alert_optim.png width=468 height=60 /></noscript></noscript></a></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org//images/new-badge-red-30.png alt="Linux Jobs" /><noscript><img src=https://linuxconfig.org//images/new-badge-red-30.png alt="Linux Jobs" width=30 height=30 /></noscript> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <span class=g-menu-item-content> <span class=g-menu-item-title>Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/how-to-analyze-and-interpret-apache-webserver-log method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=2728 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> How to analyze and interpret Apache Webserver Log </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Korbin Brown</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration</span> </dd><dd class=published> <time datetime=2019-12-19T09:38:35+11:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>19 December 2019	</time> </dd> </dl><div class=article-position> <center><div id=div-gpt-ad-1407836039689-0> </center> </div> </div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h1-software-requirements-and-conventions-used class='toclink toclink-h1'>1.&nbsp;Software Requirements and Conventions Used</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h2-apache-log-files-and-their-location class='toclink toclink-h1'>2.&nbsp;Apache log files and their location</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h3-apache-log-formatting class='toclink toclink-h1'>3.&nbsp;Apache log formatting</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h4-apache-log-configuration class='toclink toclink-h1'>4.&nbsp;Apache log configuration</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h5-log-directives class='toclink toclink-h1'>5.&nbsp;Log directives</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h6-apache-logging-modules class='toclink toclink-h1'>6.&nbsp;Apache logging modules</a></li><li><a href=https://linuxconfig.org/how-to-analyze-and-interpret-apache-webserver-log#h7-conclusion class='toclink toclink-h1'>7.&nbsp;Conclusion</a></li></ul></li></ul></div><div itemprop=articleBody> Apache web servers can generate a lot of logs. These logs contain information such as the HTTP requests that Apache has handled and responded to, and other activities that are specific to Apache. Analyzing the logs is an important part of administering Apache and ensuring that it runs as expected.<br><br> In this guide, we’ll go over the different logging options present in Apache and how to interpret this log data. You’ll learn how to analyze the logs that Apache produces and how to configure the logging settings to give you the most relevant data about what Apache is doing. <br><br><strong>In this tutorial you will learn:</strong> <ul> <li>Configure and understand Apache webserver logging </li> <li>What are Apache log levels</li> <li>How to interpret Apache log formatting and its meaning</li> <li>What are the most common Apache log configuration files </li> <li>How to extend logging configuration to include forensic data </li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/01-how-to-analyze-and-interpret-apache-log.png data-lightbox-type=image data-uk-lightbox={group:group1} title="How to analyze and interpret Apache Log"><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/01-how-to-analyze-and-interpret-apache-log.png alt="How to analyze and interpret Apache Log"><noscript><img src=https://linuxconfig.org/images/01-how-to-analyze-and-interpret-apache-log.png alt="How to analyze and interpret Apache Log" width=1200 height=696 /></noscript></a> <div class=uk-thumbnail-caption>How to analyze and interpret Apache Webserver Log</div></div></div><h2 id=h1-software-requirements-and-conventions-used>Software Requirements and Conventions Used</h2><table class="uk-table uk-table-striped uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption> <thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Ubuntu, Debian, CentOS, RHEL, Fedora</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>Apache Webserver</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>Privileged access to your Linux system as root or via the <code>sudo</code> command.</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td> <b>#</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command</br> <b>$</b> - requires given <a href=/linux-commands target=_blank>linux commands</a> to be executed as a regular non-privileged user </td> </tbody> </table><h2 id=h2-apache-log-files-and-their-location>Apache log files and their location</h2>Apache produces two different log files: <ul> <li><strong>access.log</strong> stores information about all the incoming connection requests to Apache. Every time a user visits your website, it will be logged here. Each page a user requests will also be logged as a separate entry.</li> <li><strong>error.log</strong> stores information about errors that Apache encounters throughout its operation. Ideally, this file should remain relatively empty.</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <a href=/images/02-how-to-analyze-and-interpret-apache-log.png data-lightbox-type=image data-uk-lightbox={group:group1} title="Apache default Log configuration on Ubuntu Linux server"><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/02-how-to-analyze-and-interpret-apache-log.png alt="Apache default Log configuration on Ubuntu Linux server"><noscript><img src=https://linuxconfig.org/images/02-how-to-analyze-and-interpret-apache-log.png alt="Apache default Log configuration on Ubuntu Linux server" width=1433 height=893 /></noscript></a> <div class=uk-thumbnail-caption>Apache default Log configuration on Ubuntu Linux server </div></div></div>The location of the log files may depend on which version of Apache you are running and what Linux distribution it’s on. Apache can also be configured to store these files in some other non-default location. <br><br>But, by default, you should be able to find the access and error logs in one of these directories: <ul> <li><b>/var/log/apache/</b></li> <li><b>/var/log/apache2/</b></li> <li><b>/etc/httpd/logs/</b></li> </ul><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to Linux Career <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><h2 id=h3-apache-log-formatting>Apache log formatting</h2>Apache allows you to customize what information is logged and how each log entry is presented, which we will cover later in this tutorial.<br><br> The usual format that Apache follows for presenting log entries is: <pre>"%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\""</pre> Here’s how to interpret this formatting: <ul> <li><strong>%h</strong> – The IP address of the client.</li> <li><strong>%l</strong> – This is the ‘identd’ on the client, which is used to identify them. This field is usually empty, and presented as a hyphen.</li> <li><strong>%u</strong> – The user ID of the client, if HTTP authentication was used. If not, the log entry won’t show anything for this field.</li> <li><strong>%t</strong> – Timestamp of the log entry.</li> <li><strong>\%r\</strong> – The request line from the client. This will show what HTTP method was used (such as GET or POST), what file was requested, and what HTTP protocol was used.</li> <li><strong>%>s</strong> – The status code that was returned to the client. Codes of 4xx (such as 404, page not found) indicate client errors and codes of 5xx (such as 500, internal server error) indicate server errors. Other numbers should indicate success (such as 200, OK) or something else like redirection (such as 301, permanently moved).</li> <li><strong>%O</strong> – The size of the file (including headers), in bytes, that was requested.</li> <li><strong> \"%{Referer}i\"</strong> – The referring link, if applicable. This tells you how the user navigated to your page (either from an internal or external link).</li> <li><strong>\"%{User-Agent}i\"</strong> – This contains information about the connecting client’s web browser and operating system.</li> </ul> A typical entry in the access log will look something like this: <pre>
10.10.220.3 - - [17/Dec/2019:23:05:32 -0500] "GET /products/index.php HTTP/1.1" 200 5015 "http://example.com/products/index.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.79 Safari/537.36"</pre> The error log is a bit more straightforward and easy to interpret. Here’s what a typical entry may look like: <pre>
[Mon Dec 16 06:29:16.613789 2019] [php7:error] [pid 2095] [client 10.10.244.61:24145] script '/var/www/html/settings.php' not found or unable to stat
</pre> This is a good way to see how many <code>404</code> errors your visitors are encountering, and may clue you in to some dead links on your site. More importantly, it can alert you to missing resources or potential server problems. The example above shows a <code>*.php</code> page that was requested but missing. <div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><h2 id=h4-apache-log-configuration>Apache log configuration</h2>Apache’s logging is highly customizable and can be adjusted from a couple configuration files. On Ubuntu and Debian, the main configuration file for Apache’s logging is located here: <ul> <li><b>/etc/apache2/apache2.conf</b></li> </ul> Since you can run multiple websites (referred to as <code>Virtual Hosts</code>) from a single Apache instance, you can also configure each of them to have separate access and error logs. To define how these separate log files should be named and where to save them, configure this file: <ul> <li><b>/etc/apache2/sites-available/000-default.conf</b></li> </ul> On CentOS, RHEL, and Fedora, the two configuration files are found, respectively, in these locations: <ul> <li><b>/etc/httpd/conf/httpd.conf</b></li> <li><b>/etc/httpd/conf.d/</b> (place additional VirtualHost configurations in this directory)</li> </ul><h2 id=h5-log-directives>Log directives</h2>There are quite a few different directives that can be configured inside these files, but these are the main ones you should concern yourself with if you wish to customize Apache’s logging: <ul> <li><strong>CustomLog</strong> – Defines where the access log file is stored.</li> <li><strong>ErrorLog</strong> – Defines where the error log file is stored.</li> <li><strong>LogLevel</strong> – Defines how severe an event must be in order to be logged (read below for more information).</li> <li><strong>LogFormat</strong> – Define how each entry in the access log should be formatted (read below for more information).</li> </ul> <strong>LogLevel</strong> is set to <code>warn</code> by default, which means that it will write to the error log on warning conditions or more serious events. If your error log is getting filled with loads of innocuous warning messages, you can bump it up to <code>error</code> which will only report errors or more serious problems.<br><br> Other options include (in order of severity) <code>crit</code>, <code>alert</code>, and <code>emerg</code>. Apache recommends using a level of at least crit. For debugging purposes, you can temporarily set <strong>LogLevel</strong> to <code>debug</code>, but be aware that you can end up with an unwieldy amount of entries in your error log. <br><br> <strong>LogFormat</strong> allows you to adjust what the entries inside the access log look like. If you find the example entry in <code>access.log</code> (from the <a href=#h3-apache-log-formatting>Apache log formatting</a> section above) to be a little confusing, you’re not alone. Apache allows you to customize the format of log entries, so you can set them up in a more logical way. You could also use this customization to exclude certain information that you may find irrelevant. <div class=moduletable><div class=custom><hr><ins class=adsbygoogle style="display:block; text-align:center;" data-ad-layout=in-article data-ad-format=fluid data-ad-client=ca-pub-4906753266448300 data-ad-slot=5703296903></ins><hr></div></div><h2 id=h6-apache-logging-modules>Apache logging modules</h2>The logging configuration we’ve displayed in this guide so far pertains to the <code>mod_log_config</code> Apache module. To extend logging functionality even further, you can load other logging modules into Apache. This can provide some more capabilities that aren’t available with default settings.<br><br> <strong>mod_log_forensic</strong> begins logging before a request (when the headers are first received), and logs again after the request. That means two log entries are created for each request, allowing an administrator to measure response times with more precision.<br><br> Define the location of your forensic log with the <code>CustomLog</code> directive. For example: <pre>CustomLog ${APACHE_LOG_DIR}/forensic.log forensic</pre> <strong>mod_logio</strong> logs the number of bytes sent to and received from each request. It provides very accurate information because it also counts the data present in the header and body of each request, as well as the extra data that’s required for SSL/TLS encrypted connections.<br><br> Append the <code>%I</code> and <code>O%</code> placeholders to the <code>LogFormat</code> directive in order to make use of the extra data provided by this module. Other modules exist; these are just two of the most useful. <h2 id=h7-conclusion>Conclusion</h2>In this article we saw how to analyze and interpret the access and error logs of Apache. We also learned how to customize the logging in Apache’s configuration files to make the log data more relevant. Armed with this knowledge, you will be able to isolate problems more quickly and troubleshoot issues with Apache.<br><br> Remember that Apache’s logging functionality can be further extended through other logging modules, though this is only necessary in edge cases that require advanced debugging. </div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>ARE YOU LOOKING FOR A LINUX JOB?</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel=nofollow>RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel=nofollow>JOB ALERT</a> or subscribe to <a href=https://www.linuxcareers.com/jobs/rss/ rel=nofolow>RSS</a> feed on LinuxCareers.com.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel=nofollow>NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank>LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/how-to-benchmark-webserver-with-apache-bench> How to benchmark Webserver with Apache Bench </a> </li> <li> <a href=/how-to-setup-nginx-reverse-proxy> How to setup Nginx Reverse Proxy </a> </li> <li> <a href=/filtering-packets-in-wireshark-on-kali-linux> Filtering Packets In Wireshark on Kali Linux </a> </li> <li> <a href=/installing-apache-on-linux-redhat-8> How to install Apache on RHEL 8 / CentOS 8 Linux </a> </li> </ul> </div> </div></div><div class=platform-content><div class="moduletable "><div class=custom><h3 class=g-title><span>You may also be interested in:</span></h3><center> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-4906753266448300 data-ad-slot=5538448164></ins><hr><div id=div-gpt-ad-1407836042106-0> </div> </center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=https://linuxconfig.org/plugins/system/lazyloadforjoomla/assets/images/blank.gif data-src=https://linuxconfig.org/images/linuxconfig-forum-logo.png < img><noscript><img src=https://linuxconfig.org/images/linuxconfig-forum-logo.png </img width=250 height=46 /></noscript></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div id=div-gpt-ad-1407836095114-0> </div><hr style="margin: 3px" ;><div id=div-gpt-ad-1407836250753-0> </div> </span> <div id=endad style="position: absolute;bottom: 1400px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <b>Linux Career Newsletter </b>to receive latest news, jobs, career advice and featured configuration tutorials.<br><br><script src=/media/plg_jchoptimize/cache/js/b1acbb37b3ef21c201d91b7663145324_0.js></script> <script src=https://www.google.com/recaptcha/api.js></script><form action=https://newsletter.linuxcareer.com/subscribe method=POST accept-charset=utf-8> <input type=text name=name id=name placeholder="Full Name" /> <br /> <input type=email name=email id=email placeholder=Email /><br /><br /> <input type=checkbox name=gdpr id=gdpr /> <span><strong>GDPR permission</strong>: I give my consent to be in touch with me via email using the information I have provided in this form for the purpose of news and updates.</span> <br /><br /> <center><p class=g-recaptcha data-sitekey=6LepfZ0UAAAAAOsFhqM6rFjtzl-U1-4fVn84kdCu data-size=compact></p><div style=display:none;> <label for=hp>HP</label><br /> <input type=text name=hp id=hp /> </div></center> <input type=hidden name=list value=11MnO7RM7nLdgY8N9uKGNg /> <input type=hidden name=subform value=yes /> <input class=button type=submit name=submit id=submit value="Subscribe to Newsletter" /> </form></div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/how-to-install-apache-tomcat-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install apache tomcat on Linux RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/installing-apache-on-linux-redhat-8 itemprop=url> <span itemprop=name>How to install Apache on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/install-ssh-server-on-redhat-8 itemprop=url> <span itemprop=name>Install ssh server on CentOS 8 / RHEL 8</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-visual-studio-code-on-ubuntu-20-04-desktop itemprop=url> <span itemprop=name> How to install Visual Studio Code on Ubuntu 20.04 Desktop </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/install-python-2-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> Install Python 2 on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/ubuntu-20-04-python-version-switch-manager itemprop=url> <span itemprop=name> Ubuntu 20.04 Python version switch manager </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/ubuntu-20-04-reset-root-password itemprop=url> <span itemprop=name> Ubuntu 20.04 reset root password </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/install-wine-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> Install Wine on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/sync-google-drive-on-ubuntu-20-04-focal-fossa-gnome-desktop itemprop=url> <span itemprop=name> Sync Google Drive on Ubuntu 20.04 Focal Fossa Gnome Desktop </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-matlab-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to install MATLAB on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-configure-samba-server-share-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> How to configure Samba Server share on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-firefox-developer-edition-on-linux itemprop=url> <span itemprop=name> How to install Firefox Developer Edition on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/ubuntu-20-04-remote-desktop-access-from-windows-10 itemprop=url> <span itemprop=name> Ubuntu 20.04 Remote Desktop Access from Windows 10 </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/ubuntu-20-04-software-version-check itemprop=url> <span itemprop=name> Ubuntu 20.04 Software Version Check </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/remote-desktop-sharing-with-nomachine-on-ubuntu-20-04-focal-fossa itemprop=url> <span itemprop=name> Remote desktop sharing with NoMachine on Ubuntu 20.04 Focal Fossa </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/remote-desktop-sharing-with-anydesk-on-ubuntu-20-04-focal-fossa itemprop=url> <span itemprop=name> Remote desktop sharing with AnyDesk on Ubuntu 20.04 Focal Fossa </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/remote-desktop-sharing-on-ubuntu-20-04-focal-fossa itemprop=url> <span itemprop=name> Remote desktop sharing on Ubuntu 20.04 Focal Fossa </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/configure-sudo-without-password-on-ubuntu-20-04-focal-fossa-linux itemprop=url> <span itemprop=name> Configure sudo without password on Ubuntu 20.04 Focal Fossa Linux </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2020 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/plg_jchoptimize/cache/js/b1acbb37b3ef21c201d91b7663145324_1.js></script> </body> </html>