<!DOCTYPE html><html lang=en-gb dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/fedora-vs-ubuntu /><meta name=keywords content="fedora vs ubuntu, ubuntu vs fedora, fedora or ubuntu, ubuntu or fedora, is fedora better than ubuntu, compare fedora and ubuntu, difference between fedora and ubuntu" /><meta name=author content="Nick Congleton" /><meta name=description content="What is the difference between fedora and ubuntu?" /><meta name=generator content="Joomla! - Open Source Content Management" /><title>Fedora vs Ubuntu - LinuxConfig.org</title><script src="/cdn-cgi/apps/head/Z5PasXR-fPuifc46MUXKfGsI3fg.js"></script><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--><style>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</style> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-2275 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242 g-standard  "> <a class=g-menu-item-container href=/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=/write-for-us data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" /> </a> </div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-95"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Home</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2279 g-standard  "> <a class=g-menu-item-container href=https://forum.linuxconfig.org> <img src=/images/new-badge-red-30.png alt=Forums /> <span class=g-menu-item-content> <span class=g-menu-item-title>Forums</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-heading g-menu-item-1766 g-parent g-standard  "><div class=g-menu-item-container data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class=g-menu-item-title>Linux Distros</span> </span> <span class=g-menu-parent-indicator></span> </div><ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1767  "> <a class=g-menu-item-container href=/linux-distros/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1768  "> <a class=g-menu-item-container href=/linux-distros/centos> <span class=g-menu-item-content> <span class=g-menu-item-title>CentOS</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1769  "> <a class=g-menu-item-container href=/linux-distros/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1771  "> <a class=g-menu-item-container href=/linux-distros/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1770  "> <a class=g-menu-item-container href=/linux-distros/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>Redhat</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1785 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Administration</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1784 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming &amp; Scripting</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-5"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/fedora-vs-ubuntu method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=2275 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> Fedora vs Ubuntu </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Nick Congleton</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration &amp; Configuration</span> </dd><dd class=published> <time datetime=2018-05-25T12:16:13+10:00 itemprop=datePublished data-uk-tooltip title="Published Date"> <i class="fa fa-clock-o"></i>25 May 2018	</time> </dd> </dl><div class=article-position> <center><div id=div-gpt-ad-1407836025306-0> </center> </div> </div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h1-introduction class='toclink toclink-h1'>1.&nbsp;Introduction</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h2-lineage class='toclink toclink-h1'>2.&nbsp;Lineage</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h3-package-managers class='toclink toclink-h1'>3.&nbsp;Package Managers</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h4-installers class='toclink toclink-h1'>4.&nbsp;Installers</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h5-repositories class='toclink toclink-h1'>5.&nbsp;Repositories</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h6-release-cycles class='toclink toclink-h1'>6.&nbsp;Release Cycles</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h7-corporate-backing class='toclink toclink-h1'>7.&nbsp;Corporate Backing</a></li><li><a href=https://linuxconfig.org/fedora-vs-ubuntu#h8-closing-thoughts class='toclink toclink-h1'>8.&nbsp;Closing Thoughts</a></li></ul></li></ul></div><div itemprop=articleBody><h2 id=h1-introduction>Introduction</h2>Ubuntu and Fedora are both among the top desktop Linux distributions, but they are very different. Fedora is Redhat's testing ground, and it's geared more towards developers and system administrators. On the other hand, Ubuntu <em>is</em> Canonical's primary product, and it tries to please everyone. <h2 id=h2-lineage>Lineage</h2>Both Ubuntu and Fedora descend from titans in the Linux world. Ubuntu is the child of Debian, and Fedora is a clone of Redhat Linux, which evolved into Redhat Enterprise Linux(RHEL). Both distributions still carry many of the hallmarks of their family trees. <br><br> They both have their respective families' package managers, package formats, repository formats, and filesystem structures. All of those things differ greatly between the Debian family tree and the Redhat one. <h2 id=h3-package-managers>Package Managers</h2>Ubuntu and Fedora have very different package managers and packaging formats. They're both very good, but they function differently. <br><br> Ubuntu uses Apt, the Advanced Package Tool, which it inherited from Debian. Apt is one of the larger and more powerful Linux package managers out there, and it's been around for a while. Apt works with the <code>.deb</code> package format. <code>.deb</code> packages archive their files in format specific for Debian based distributions. <br><br> Apt can do a lot of things, but it usually requires explicit instruction. When you want to update your repositories, for example, you need to tell Apt to update.<br><br> <pre><code class=language-bash>$ sudo apt update
$ sudo apt install firefox</code></pre> Fedora initially used Yum, the Yellowdog Update Manager, which the Redhat distributions got from the now defunct Yellowdog Linux to manage their <code>.rpm</code> packages. <br><br> Newer versions of Fedora use the DNF package manager. It functions exactly the same way that Yum did, but with the <code>dnf</code> command. Under the hood, there are some reliability, speed, and usability improvements that DNF a logical evolution from Yum. <br><br> Both DNF and Yum are more automated and intuitive. Whenever you install a package with DNF, it automatically updates repository data to pull the latest version available. <pre># dnf install firefox</pre><h2 id=h4-installers>Installers</h2>Ubuntu and Fedora have very different installer. That said, they're both among the most modern installers in the tech world as a whole, not just Linux.<br><br><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <center><a href=/images/ubuntu-bionic-installer-2.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="Ubuntu Bionic Installer"><img src=/images/ubuntu-bionic-installer-2.jpg alt="Ubuntu Bionic Installer"></a></center><div class=uk-thumbnail-caption>Ubuntu Bionic Installer</div></div></div>Ubuntu's installer was one of the original features that set it apart from Debian. Ubuntu's installer is designed to simplify and streamline the process of getting up and running with Ubuntu, and it excels at just that.<br><br><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"> <center><a href=/images/fedora-installer-1.jpg data-lightbox-type=image data-uk-lightbox={group:group1} title="Fedora 28 Installer"><img src=/images/fedora-installer-1.jpg alt="Fedora 28 Installer"></a></center><div class=uk-thumbnail-caption>Fedora 28 Installer</div></div></div>Fedora shares its Anaconda installer with the rest of Redhat's operating systems, but Fedora always has the latest version. The Anaconda installer allows for a lot of flexibility. If you don't want to get too far into things, Anaconda can be simple.<br><br> However, if you want to totally customize your system during the install, Anaconda lets you do just about anything. In fact, Anaconda is one of the only Linux installers that lets you choose from loads of software and pre-arranged bundles to install with the rest of the system. This way, your system is ready to use the second it first boots up. <h2 id=h5-repositories>Repositories</h2>Compared to Ubuntu's Fedora's repositories are tiny. There's just no getting around it. Fedora doesn't offer nearly as much software as Ubuntu does. This is partly because Fedora has a strict "free software only" policy, but it's also because there just isn't as much software packaged for Fedora by default. <br><br> There is an excellent community around Fedora that packages for third party repositories, but Ubuntu still has more. <br><br> If you're a developer, or you only need a core set of software that you know Fedora has, great. Otherwise, you might run into trouble getting what you need. <h2 id=h6-release-cycles>Release Cycles</h2>At first, it would seem like Ubuntu and Fedora have roughly the same release cycles. Both try to release a new version every six months, but there are a lot more details to take into account that actually separate the two quite a lot. <br><br> Ubuntu releases it's regular desktop versions once every six months. Those versions include incremental upgrades to just about everything on the system, and they're intended mostly for desktop users. Every fifth release is an LTS version of Ubuntu. Those are supported officially for five years, and they're intended mostly for servers and workstations. LTS releases receive mostly security updates and bug fixes, rather than software upgrades. <br><br> Fedora also releases about once every six months, but they're notorious for missing their release schedule just about every time. Fedora releases always contain the absolute latest software, and can be somewhat buggy and unstable at first. Fedora only really targets desktop and workstation users, so stability takes a back seat to new and cool features. Fedora will continually upgrade software, including core system components, for the duration of the release. In a way, it works like a rolling release distribution. <h2 id=h7-corporate-backing>Corporate Backing</h2>Both Fedora and Ubuntu are backed by huge corporations. Fedora has Redhat behind it, and Ubuntu has Canonical. These different distributions don't quite fit into the same place within their respective corporation's ecosystem, though. <br><br> Fedora is the testing ground for Redhat. All of the latest features that Redhat is developing for it's server distributions and the Linux ecosystem as a whole make their appearance in Fedora first. Redhat doesn't offer official support for Fedora. Instead they refer to it as a community project. <br><br> Ubuntu is Canonical's primary product. Everything that Canonical develops revolves around Ubuntu. They do offer commercial support for the LTS Ubuntu releases and work with hardware partners for support and certification. <h2 id=h8-closing-thoughts>Closing Thoughts</h2>Both Ubuntu and Fedora make excellent desktop distributions. Their use cases and ecosystems are somewhat different, though. <br><br> Ubuntu comes from the Debian family, and it's the primary operating system developed by Canonical. Ubuntu's varied release cycle makes it somewhat of a jack of all trades, and it can fit nearly any use case. <br><br> Fedora is Redhat's testbed, and it's a great choice for developers and administrators working with Redhat systems. It has a much narrower ecosystem, and would feel out of place on anything but a desktop or workstation. </div></article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-4906753266448300 data-ad-slot=5538448164></ins><hr><div id=div-gpt-ad-1407836165832-0> </div> </center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=/images/linuxconfig-forum-logo.png?5b176c9a < img></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div id=div-gpt-ad-1407836227367-0> </div><hr style="margin: 3px" ;><div id=div-gpt-ad-1407836280129-0> </div> </span> <div id=endad style="position: absolute;bottom: 1050px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Support Us</span></h3><div class=g-particle> <center><b>Bitcoin (BTC) Address:</b><br><font size=2.5>1PyYJEVtxkokkYtLkRw9BA7Fr4xEAXJn3U</font><br><br> <img src=/images/banners/btc-qr.png alt="Linux Config Support"> <br><br><br><b>Litecoin (LTC) Address:</b><br><font size=2.5>LXvDNUcdKuh3Svge358rNanXfXMKcPkxCo</font><br><br> <img src=/images/banners/ltc-qr.png alt="Linux Config Support"><br><br>Thank You
</center> </div> </div><div class=platform-content><div class="moduletable "><ul class=latestnews> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-imagemagick-7-on-ubuntu-18-04-linux itemprop=url> <span itemprop=name> How to install ImageMagick 7 on Ubuntu 18.04 Linux </span> </a> </li> </ul> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=/floss-technical-writer-linuxconfig-org>Read More...</a> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><ul class=mostread> <li itemscope itemtype=https://schema.org/Article> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-skype-on-ubuntu-16-04-xenial-xerus-linux-64-bit itemprop=url> <span itemprop=name> How to install Skype on Ubuntu 16.04 Xenial Xerus Linux 64-bit </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-steam-on-ubuntu-16-04-xenial-xerus itemprop=url> <span itemprop=name> How to install Steam on Ubuntu 16.04 Xenial Xerus </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-stop-start-and-disable-enable-firewall-on-redhat-7-linux-system itemprop=url> <span itemprop=name> How to stop/start and disable/enable Firewall on Redhat 7 Linux system </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-setup-and-use-ftp-server-in-ubuntu-linux itemprop=url> <span itemprop=name> How to setup and use FTP Server in Ubuntu Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-mount-partition-with-ntfs-file-system-and-read-write-access itemprop=url> <span itemprop=name> How to mount partition with ntfs file system and read write access </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-install-the-latest-nvidia-drivers-on-ubuntu-16-04-xenial-xerus itemprop=url> <span itemprop=name> How to install the latest Nvidia drivers on Ubuntu 16.04 Xenial Xerus </span> </a> </li> </ul> </div></div><div class=platform-content><div class="moduletable "><div class=custom><ul><li><a href=/how-to-upgrade-to-ubuntu-18-04-lts-bionic-beaver>How To Upgrade From 16.04 and 17.10 To Ubuntu 18.04 LTS Bionic Beaver</a></li> <li><a href=/how-to-install-ubuntu-18-04-bionic-beaver>How to install Ubuntu 18.04 Bionic Beaver</a></li> </ul> </div> </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>About</span></h3><div class=g-particle> LinuxConfig.org team is determined to provide you with simple to follow Linux tutorials, various tips, tricks and programming guides as well as with GNU/Linux system administration tutorials in general to help you to learn Linux faster and use it with ease. <br><br>
Any comments, constructive feedback or your <a href=floss-technical-writer-linuxconfig-org><b>involvement</b></a> is welcome. <br><br>
Contact: </div></div><div class="moduletable "><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2018 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel=nofollow> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script>var cb=function(){var l=document.createElement('link');l.rel='stylesheet';l.href='/media/plg_jchoptimize/assets2/jscss.php?f=afcbdc98949cc891af0137c857d94dad&type=css&gz=gz&i=0';var h=document.getElementsByTagName('head')[0];h.appendChild(l);};var raf=requestAnimationFrame||mozRequestAnimationFrame||webkitRequestAnimationFrame||msRequestAnimationFrame;if(raf)raf(cb);else window.addEventListener('load',cb);</script><noscript><link rel=stylesheet property=stylesheet href="/media/plg_jchoptimize/assets2/jscss.php?f=afcbdc98949cc891af0137c857d94dad&amp;type=css&amp;gz=gz&amp;i=0"/></noscript> <script src="/media/plg_jchoptimize/assets2/jscss.php?f=301a00ddc2ac62d05fc1084eb77007e6&amp;type=js&amp;gz=gz&amp;i=0"></script> </body> </html>