<!DOCTYPE html><html lang=en-gb dir=ltr><head><script src="/cdn-cgi/apps/head/bXa8n0uUCb2a0SzvaCENH28oqao.js"></script><link rel=preconnect href=https://fonts.gstatic.com crossorigin /><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge" /><meta charset=utf-8 /><base href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux /><meta name=keywords content="ansible, tutorial, beginner, linux, introduction, examples" /><meta name=author content="Egidio Docile" /><meta name=description content="In this tutorial we see how to install ansible and learn the basic concepts behind its usage." /><meta name=generator content="Joomla! - Open Source Content Management" /><title>Ansible tutorial for beginners on Linux - LinuxConfig.org</title><link href="https://linuxconfig.org/component/search/?Itemid=3356&amp;format=opensearch" rel=search title="Search LinuxConfig.org" type=application/opensearchdescription+xml /><link href=/templates/it_headlines/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js"></script>
        <![endif]--> <script src=/media/plg_jchoptimize/cache/js/7598340cc594fdd954e07cf373904da4.js></script> <script async src=https://cdn.fuseplatform.net/publift/tags/2/2224/fuse.js></script><link rel=preload as=style href="//fonts.googleapis.com/css?family=Open Sans:300,300italic,600,600italic,700,700italic,400,400italic&display=swap" onload="this.onload=null;this.rel='stylesheet'" /><style>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</style> <script>function onUserInteract(callback){window.addEventListener('load',function(){if(window.pageYOffset!==0){callback()}});window.addEventListener('scroll',function(){callback()});document.addEventListener('DOMContentLoaded',function(){let b=document.getElementsByTagName('body')[0];b.addEventListener('mouseenter',function(){callback()});});}</script><script>(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){};}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload");}catch(e){ret=false;}
return function(){return ret;};})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener){link.removeEventListener("load",enableStylesheet);}else if(link.attachEvent){link.detachEvent("onload",enableStylesheet);}
link.setAttribute("onload",null);link.media=finalMedia;}
if(link.addEventListener){link.addEventListener("load",enableStylesheet);}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet);}
setTimeout(function(){link.rel="stylesheet";link.media="only x";});setTimeout(enableStylesheet,3000);};rp.poly=function(){if(rp.support()){return;}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",true);rp.bindMediaToggle(link);}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run);});}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run);});}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS;}
else{w.loadCSS=loadCSS;}}(typeof global!=="undefined"?global:this));</script><script>let loaded=false;onUserInteract(function(){var css_urls=["\/media\/plg_jchoptimize\/cache\/css\/76e2792bdd9f344d7f01269c560cdb1f.css"];if(!loaded){css_urls.forEach(function(url,index){let l=document.createElement('link');l.rel='stylesheet';l.href=url;let h=document.getElementsByTagName('head')[0];h.append(l);});loaded=true;}});</script><noscript><link rel=stylesheet href=/media/plg_jchoptimize/cache/css/76e2792bdd9f344d7f01269c560cdb1f.css /></noscript><noscript><style>img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="gantry site com_content view-article no-layout no-task dir-ltr itemid-3356 outline-25 g-offcanvas-left g-default g-style-preset5"><div id=g-offcanvas data-g-offcanvas-swipe=0 data-g-offcanvas-css3=1><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div id=g-mobilemenu-container data-g-menu-breakpoint=60rem></div></div></div></div></div><div id=g-page-surround><div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle><i class="fa fa-fw fa-bars"></i></div><section id=g-container-site class=g-wrapper><div class=g-container><section id=g-top><div class=g-grid><div class="g-block size-60"><div class=g-content><div class="moduletable "><div class=g-particle> <nav class=g-main-nav role=navigation data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-2324 g-parent g-standard g-menu-item-link-parent "> <a class=g-menu-item-container href=/ubuntu> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu</span> </span> <span class=g-menu-parent-indicator data-g-menuparent=""></span> </a> <ul class="g-dropdown g-inactive g-fade g-dropdown-right"> <li class=g-dropdown-column><div class=g-grid><div class="g-block size-100"><ul class=g-sublevel> <li class="g-level-1 g-go-back"> <a class=g-menu-item-container href=# data-g-menuparent=""><span>Back</span></a> </li> <li class="g-menu-item g-menu-item-type-url g-menu-item-2944  "> <a class=g-menu-item-container href=/ubuntu-20-04-guide> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 20.04</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2242  "> <a class=g-menu-item-container href=/ubuntu/ubuntu-18-04> <span class=g-menu-item-content> <span class=g-menu-item-title>Ubuntu 18.04</span> </span> </a> </li> </ul> </div> </div> </li> </ul> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2326 g-standard  "> <a class=g-menu-item-container href=/debian> <span class=g-menu-item-content> <span class=g-menu-item-title>Debian</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2327 g-standard  "> <a class=g-menu-item-container href=/redhat> <span class=g-menu-item-content> <span class=g-menu-item-title>RHEL / CentOS / AlmaLinux</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2328 g-standard  "> <a class=g-menu-item-container href=/fedora> <span class=g-menu-item-content> <span class=g-menu-item-title>Fedora</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2340 g-standard  "> <a class=g-menu-item-container href=/kali> <span class=g-menu-item-content> <span class=g-menu-item-title>Kali</span> </span> </a> </li> </ul> </nav> </div> </div> </div> </div><div class="g-block hidden-phone size-40"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/contact-us data-uk-tooltip="{pos:'bottom'}">Contact Us</a> <a href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Write For Us</a> <a href=https://bit.ly/2X5D30q rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Newsletter </a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="noreferrer noopener nofollow"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div><div class=g-container> <header id=g-header><div class=g-grid><div class="g-block size-30"><div class="g-content g-particle"> <a href=/ title="Linux Tutorials - Learn Linux Configuration" rel=home class="g-logo "> <img src=/images/linuxconfig_logo.png alt="Linux Tutorials - Learn Linux Configuration" width=250 height=46 /> </a> </div></div><div class="g-block hidden-phone size-70"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div data-fuse=22413944646 class=incontent_ads></div></div></div></div></div></div></div></header> </div><div class=g-container><section id=g-navigation data-uk-sticky=&#x7B;media&#x3A;&#x20;&#x27;&#x28;max-width&#x3A;&#x20;768px&#x29;&#x27;&#x7D;><div class=g-grid><div class="g-block size-94"><div class="g-content g-particle"> <nav class=g-main-nav role=navigation data-g-mobile-target data-g-hover-expand=true><ul class=g-toplevel> <li class="g-menu-item g-menu-item-type-component g-menu-item-435 g-standard  "> <a class="g-menu-item-container jsn-icon-home" href=/ title="Start here"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Guides</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1786 g-standard  "> <a class=g-menu-item-container href=/linux-tutorials> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Tutorials</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2988 g-standard  "> <a class=g-menu-item-container href=/system-administration> <span class=g-menu-item-content> <span class=g-menu-item-title>System Admin</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-2997 g-standard  "> <a class=g-menu-item-container href=/programming-scripting> <span class=g-menu-item-content> <span class=g-menu-item-title>Programming</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-3001 g-standard  "> <a class=g-menu-item-container href=/multimedia-games> <span class=g-menu-item-content> <span class=g-menu-item-title>Multimedia</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1777 g-standard  "> <a class=g-menu-item-container href=/linux-commands> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Commands</span> </span> </a> </li> <li class="g-menu-item g-menu-item-type-component g-menu-item-1766 g-standard  "> <a class=g-menu-item-container href=/linux-jobs title="Linux Jobs"> <span class=g-menu-item-content> <span class=g-menu-item-title>Linux Jobs</span> </span> </a> </li> </ul> </nav> </div> </div><div class="g-block size-6"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-search-login><div class=g-buttons><div class=g-search-button> <a id=header-search-toggle href=/ data-uk-tooltip title=Search> <i class="fa fa-search"></i> </a> </div></div><div id=header-search><div class=g-block><div class=g-content> <a class=uk-close></a> <div class=moduletable><div class="search mod_search93"><form action=/ansible-tutorial-for-beginners-on-linux method=post class=form-inline> <label for=mod-search-searchword class=element-invisible>Search ...</label> <input autocomplete=off name=searchword id=mod-search-searchword maxlength=200 class="inputbox search-query" type=search size=20 placeholder="Search ..." /> <input type=hidden name=task value=search /> <input type=hidden name=option value=com_search /> <input type=hidden name=Itemid value=3356 /> </form></div></div></div></div></div></div></div></div></div></div></div></section></div><div class=g-container><section id=g-system-messages><div class=g-grid><div class="g-block size-100"><div class=g-system-messages> </div> </div> </div> </section> </div><div class=g-container><section id=g-container-main class=g-wrapper><div class=g-grid><div class="g-block size-67"><section id=g-mainbody><div class=g-grid><div class="g-block size-100"><div class=g-content><div class="platform-content row-fluid"><div class=span12><article class="item item-page" itemscope itemtype=https://schema.org/Article><meta itemprop=inLanguage content=en-GB /><div class=g-article-header><div class=page-header><h1 itemprop=name> Ansible tutorial for beginners on Linux </h1></div><dl class="article-info muted"> <dt class=article-info-term> Details </dt><dd class=createdby itemprop=author itemscope itemtype=http://schema.org/Person> <span itemprop=name data-uk-tooltip title="Written by "><i class="fa fa-user"></i>Egidio Docile</span> </dd><dd class=category-name> <span itemprop=genre itemprop=genre data-uk-tooltip title="Article Category"><i class="fa fa-folder-open-o"></i>System Administration</span> </dd><dd class=modified> <time datetime=2021-06-04T10:59:22+10:00 itemprop=dateModified data-uk-tooltip title="Modified Date"> <i class="fa fa-clock-o"></i>04 June 2021	</time> </dd> </dl><div data-fuse=22189504503 class=incontent_ads></div></div><div class=autotoc style=float:right;><span>Contents</span><ul><li><ul><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h1-software-requirements-and-conventions-used class='toclink toclink-h1'>1.&nbsp;Software requirements and conventions used</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h2-installing-ansible class='toclink toclink-h1'>2.&nbsp;Installing Ansible</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-introducing-ansible class='toclink toclink-h1'>3.&nbsp;Introducing Ansible</a><ul><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-1-the-ansible-configuration-file class='toclink toclink-h2'>3.1.&nbsp;The Ansible configuration file</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-2-the-ldquo-hosts-rdquo-or-ldquo-inventory-rdquo-file class='toclink toclink-h2'>3.2.&nbsp;The &ldquo;hosts&rdquo; or &ldquo;inventory&rdquo; file</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-3-ansible-modules class='toclink toclink-h2'>3.3.&nbsp;Ansible modules</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-4-using-modules-from-the-command-line class='toclink toclink-h2'>3.4.&nbsp;Using modules from the command line</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-5-ansible-playbooks class='toclink toclink-h2'>3.5.&nbsp;Ansible playbooks</a></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h3-6-running-a-playbook class='toclink toclink-h2'>3.6.&nbsp;Running a playbook</a></li></ul></li><li><a href=https://linuxconfig.org/ansible-tutorial-for-beginners-on-linux#h4-conclusions class='toclink toclink-h1'>4.&nbsp;Conclusions</a></li></ul></li></ul></div><div itemprop=articleBody><p>A <a href=https://www.linuxcareers.com/jobs/job-search-results/kw-system-administrator/ target=_blank>system administrator</a>, in the vast majority of cases, has to take care of more than one server, so he often has to perform repetitive tasks on all of them. In these cases automation is a must. Ansible is an open source software owned by Red Hat; it is written in the Python programming lanaguage, and it is a provisioning and configuration management software which help us in the aforementioned cases. In this tutorial we will see how to install it and the basic concepts behind its usage.</p><p><strong>In this tutorial you will learn</strong>:</p><ul> <li>How to install Ansible on the most used Linux distributions</li> <li>How to configure Ansible</li> <li>What is the Ansible inventory</li> <li>What are the Ansible modules</li> <li>How to run a module from the command line</li> <li>How to create and run a playbook</li> </ul><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"><a data-lightbox-type=image data-uk-lightbox="{group:'group1'}" href=/images/00-introduction-to-ansible.png?60b9748e><img class=jch-lazyload alt=ansible-logo src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAwIiBoZWlnaHQ9IjgwMCI+PC9zdmc+ data-src=/images/00-introduction-to-ansible.png?60b9748e width=1200 height=800 /><noscript><img alt=ansible-logo src=/images/00-introduction-to-ansible.png?60b9748e width=1200 height=800 /></noscript></a></div></div><h2 id=h1-software-requirements-and-conventions-used>Software requirements and conventions used</h2><table class="uk-table uk-table-strIPed uk-table-condensed"><caption>Software Requirements and Linux Command Line Conventions</caption><thead> <tr> <th>Category</th> <th>Requirements, Conventions or Software Version Used</th> </tr> </thead> <tbody> <tr> <td class="uk-text-primary uk-text-bold">System</td> <td>Distribution independent</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Software</td> <td>Ansible, Python</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Other</td> <td>None</td> </tr> <tr> <td class="uk-text-primary uk-text-bold">Conventions</td> <td># - requires given <a href=/linux-commands>linux-commands</a> to be executed with root privileges either directly as a root user or by use of <code>sudo</code> command<br>$ - requires given <a href=/linux-commands>linux-commands</a> to be executed as a regular non-privileged user<br></td> </tr> </tbody> </table><h2 id=h2-installing-ansible>Installing Ansible</h2><p>The Ansible package is contained in the official repositories of the most used Linux distributions so it can be easily installed using their native package managers. To install it on Debian we can run:</p><pre><code>$ sudo apt-get update &amp;&amp; apt-get install ansible
</code></pre><p>To install Ansible on Fedora, instead:</p><pre><code>$ sudo dnf install ansible
</code></pre><p>Ansible is in the Archlinux &ldquo;Community&rdquo; repository; we can install it using pacman:</p><pre><code>$ sudo pacman -Sy ansible
</code></pre><p>If we want to install Ansible on CentOS8, we have to add the <strong>epel-release</strong> software source to our system, since the package is not available in the default repositories. To do so we run the following command:</p><pre><code>$ sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
</code></pre><p>After that, we can simply run:</p><pre><code>$ sudo dnf install ansible
</code></pre><p>For other distribution-specific installation instructions we can consult the <a href=https://docs.ansible.com/ansible/latest/installation_guide/intro_installation.html>dedicated page</a> of the Ansible official documentation.</p><div class=moduletable><div class=custom><hr><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-alert"> <i><center><b>SUBSCRIBE TO NEWSLETTER</b><br>Subscribe to our <a href=https://bit.ly/2X5D30q target=_blank rel="noreferrer noopener nofollow">NEWSLETTER</a> and receive latest Linux news, jobs, career advice and tutorials. </i></center></div></div></div><hr><div data-fuse=22189504506 class=incontent_ads></div><hr></div></div><h2 id=h3-introducing-ansible>Introducing Ansible</h2><p>The fundamental peculiarity of Ansible is that it is an <strong>agentless</strong> provisioning system. This means that we don&rsquo;t need to install any agent or software daemon on the servers we want to control. All we need is to install and configure Ansible on the so called <strong>control machine</strong>. The <strong>tasks</strong> we configure will be performed, in the vast majority of cases, via a simple <strong>ssh</strong> connection.</p><div class=uk-margin><div class="uk-thumbnail uk-thumbnail-expand"><a data-lightbox-type=image data-uk-lightbox="{group:'group1'}" href=/images/01-introduction-to-ansible.png?60b9748e><img class=jch-lazyload alt=ansible-scheme src=data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAwIiBoZWlnaHQ9IjY3MSI+PC9zdmc+ data-src=/images/01-introduction-to-ansible.png?60b9748e width=1200 height=671 /><noscript><img alt=ansible-scheme src=/images/01-introduction-to-ansible.png?60b9748e width=1200 height=671 /></noscript></a></div></div><h3 id=h3-1-the-ansible-configuration-file>The Ansible configuration file</h3><p>Ansible can be configured by specifying parameters and their values in one or more configuration files. The application, in order of priority, looks for the following files:</p><ol> <li>The file specified via the ANSIBLE_CONFIG variable</li> <li>The <code>ansible.cfg</code> file in the current working directory</li> <li>The <code>.ansible.cfg</code> file in the user home directory</li> <li>The <code>/etc/ansible/ansible.cfg</code> file</li> </ol><p>The <code>/etc/ansible/ansible.cfg</code> is the last one, so it is used as a fallback and the default. For obvious reasons, this is not the appropriate place to describe all the possible parameters which can be specified in a configuration file, however, here is an excerpt of the file content:</p><pre><code>[defaults]

# some basic default values...

#inventory      = /etc/ansible/hosts
#library        = /usr/share/my_modules/
#module_utils   = /usr/share/my_module_utils/
#remote_tmp     = ~/.ansible/tmp
#local_tmp      = ~/.ansible/tmp
#plugin_filters_cfg = /etc/ansible/plugin_filters.yml
#forks          = 5
#poll_interval  = 15
#sudo_user      = root
#ask_sudo_pass = True
#ask_pass      = True
#transport      = smart
#remote_port    = 22
#module_lang    = C
#module_set_locale = False
</code></pre><p>The ones in the example are commented parameters which are defined with their default values. Among them, you can see the <code>inventory</code> parameters, which has the <code>/etc/ansible/hosts</code> value. We will see what this is in the next section.</p><h3 id=h3-2-the-ldquo-hosts-rdquo-or-ldquo-inventory-rdquo-file>The &ldquo;hosts&rdquo; or &ldquo;inventory&rdquo; file</h3><p>The ansible &ldquo;hosts&rdquo; file, is where we basically set the IP address or the hostnames of the machines we want to control with Ansible (this is the &ldquo;inventory&rdquo; in the Ansible jargon). On a standard installation, the file is located in the <code>/etc/ansible</code> directory. Inside the inventory file, hosts can be <strong>grouped</strong> or <strong>ungrouped</strong>. We can specify an host by itself, for example:</p><pre><code>server1
</code></pre><p>When we want to perform operations on more than one host, however, it is very useful to put hosts in groups, created, for example, using their &ldquo;role&rdquo; as criteria. Supposing the hosts we are dealing with are all used as webservers, we could write:</p><pre><code>[webservers]
server1
server2
</code></pre><h3 id=h3-3-ansible-modules>Ansible modules</h3><p>Ansible modules are basically small programs used to perform the tasks we need; each of them is designed to perform a single basic operation, in order to ensure granularity. They can be executed from the command line or inside <strong>playbooks</strong>. The complete list of all modules can be found on the <a href=https://docs.ansible.com/ansible/2.9/modules/list_of_all_modules.html>dedicated page</a> of the official documentation. Again, here we cannot examine all the modules, but here are some examples.</p><p>The <a href=https://docs.ansible.com/ansible/latest/collections/ansible/builtin/apt_module.html>apt</a>, <a href=https://docs.ansible.com/ansible/latest/collections/ansible/builtin/dnf_module.html>dnf</a> and <a href=https://docs.ansible.com/ansible/latest/collections/ansible/builtin/yum_module.html>yum</a> modules are used to manage packages with the file managers the take their name from. The <a href=https://docs.ansible.com/ansible/latest/collections/ansible/posix/seboolean_module.html>seboolean</a> module is used to manager the status of <a href=https://linuxconfig.org/introduction-to-selinux-concepts-and-management>SELinux booleans</a>, the <a href=https://docs.ansible.com/ansible/latest/collections/ansible/builtin/user_module.html>user</a> module is used to manage user accounts, etc.</p><div class=moduletable><div class=custom><hr><div data-fuse=22189504224 class=incontent_ads></div><hr></div></div><h3 id=h3-4-using-modules-from-the-command-line>Using modules from the command line</h3><p>As we said in the previous section, modules can be used from the command line or from playbooks. We will focus on the latter in the next section; here we will demonstrate how to use a module from the command line, with the <code>ansible</code> command. In this example we will use the <strong>ping</strong> module. This module has nothing to do with the ping command, but it is used to check that we can login on the remote servers, and that a Python interpreter is installed on them. The module returns the &ldquo;pong&rdquo; value on success:</p><pre><code>$ ansible webservers -m ping --ask-pass
</code></pre><p>We invoked the ansible command specifying that we want to run the task on the hosts members of the &ldquo;webservers&rdquo; group and with the <code>-m</code> option we passed the name of the module we want to use. We also used the <code>--ask-pass</code> option, why? Although I previously added the remote servers fingerprint to the control machine ssh &ldquo;known hosts&rdquo; file, I didn&rsquo;t configure ssh access via public key, so an ssh password should be provided when we run a task. The <code>--ask-pass</code> option makes so that the password is asked interactively. Here is the output of the command above:</p><pre><code>SSH password:
server2 | SUCCESS =&gt; {
    &quot;ansible_facts&quot;: {
        &quot;discovered_interpreter_python&quot;: &quot;/usr/bin/python&quot;
    },
    &quot;changed&quot;: false,
    &quot;ping&quot;: &quot;pong&quot;
}
server1 | SUCCESS =&gt; {
    &quot;ansible_facts&quot;: {
        &quot;discovered_interpreter_python&quot;: &quot;/usr/bin/python&quot;
    },
    &quot;changed&quot;: false,
    &quot;ping&quot;: &quot;pong&quot;
}
</code></pre><h3 id=h3-5-ansible-playbooks>Ansible playbooks</h3><p>What is a playbook? Ansible <a href="https://docs.ansible.com/ansible/latest/user_guide/playbooks_intro.html?extIdCarryOver=true&amp;sc_cid=701f2000001OH7EAAW">playbooks</a> are no other than <a href="https://docs.ansible.com/ansible/latest/user_guide/playbooks_intro.html?extIdCarryOver=true&amp;sc_cid=701f2000001OH7EAAW">YAML</a> files where we specify the tasks we want to perform using Ansible, and the hosts they should be performed on. Let&rsquo;s see a playbook example. In the following file we setup a task to ensure the Vim text editor is installed and at the latest available version:</p><pre><code>---

- name: Update webservers
  hosts: webservers
  remote_user: egdoc
  become: yes

  tasks:
    - name: Ensure Vim is installed and at the latest version
      dnf:
        name: vim
        state: latest

...
</code></pre><p>Let&rsquo;s analyze the above. The <code>---</code> and <code>...</code> we can see, respectively at the beginning and at the end of the file, are part of the standard YAML syntax: they are <strong>optional</strong> and mark the beginning and the end of the file. The instructions and their values are represented in a dictionary format, as <code>key: value</code> pairs.</p><p>A playbook can contain multiple so-called <strong>plays</strong>; in this case we just defined one. Indeed the first thing we did was to specify its <code>name</code>, which in this example is &ldquo;Update webservers&rdquo;. The second key we used is <code>hosts</code>: with it we can define the host group the tasks should be performed on. In this case we specified <code>webservers</code> as value, which comprehends the machines we defined in the previous examples (server1 and server2).</p><p>The next key we used was <code>remote_user</code>. With it, we can specify what is the user we should login as, via ssh, in the remote servers. After that, we used the <code>become</code> key. This key accepts a boolean value and with it we specify whether <strong>privilege escalation</strong> should used to perform the tasks or not. In this case, since we login in the remote machines using the &ldquo;egdoc&rdquo; user, and we need root privileges to install a package, we set it to <code>yes</code>. It&rsquo;s important to notice that privilege escalation are configured in the <code>/etc/ansible/ansible.cfg</code> configuration file, in the dedicated section. In this case the default values are the following:</p><pre><code>[privilege_escalation]
#become=True
#become_method=sudo
#become_user=root
#become_ask_pass=False
</code></pre><div class=moduletable><div class=custom><hr><div data-fuse=22189504509 class=incontent_ads></div><hr></div></div><p>After defining the <strong>play</strong> information, we started to specify our list of tasks. To do so we used the <code>tasks</code> keyword. Each task has a <code>name</code> which is used for documentation and in task handlers.</p><p>With <code>dnf:</code> we specified that we want to use the &ldquo;dnf&rdquo; module, which, as we saw before, is used to manage packages using the default package manager in the Red Hat family of distributions. Inside this section, with the <code>name</code> keyword we specified the packages name. In this example we are interested only in a single package, but multiple packages can be specified using a list. For example:</p><pre><code>dnf:
    name: [vim, nano]
</code></pre><p>With the <code>state</code> keyword of the <code>dnf</code> module we basically specify what we want to do with the specified package(s). In this case we used <code>latest</code> as the value: with it we ensure that the package is installed and at the latest available version on the distribution used on the remote machine. Other possible values we can use are <code>remove</code> or <code>absent</code>, which causes the package(s) to be uninstalled, or <code>present</code> which just ensure the package is installed. I recommend you to check the <a href=https://docs.ansible.com/ansible/latest/collections/ansible/builtin/dnf_module.html>official module documentation</a> for the complete list of keys and values that can be used with the module.</p><p>Here we go, we just defined our first playbook. How can we run it?</p><h3 id=h3-6-running-a-playbook>Running a playbook</h3><p>To run a playbook we use the dedicated <code>ansible-playbook</code> command. The command accepts a series of options, and takes one or more playbook files as arguments. To run the playbook we defined in the previous section, for example we would run the following command:</p><pre><code>$ ansible-playbook --ask-pass ---ask-become-pass  /path/to/playbook.yml
</code></pre><p>You can notice that in this case we invoked the command with the <code>--ask-become-pass</code> options. This option is needed because in the playbook file we assigned the <code>yes</code> value to the <code>become</code> key, since we need privilege escalation in order to install packages on the remote machines. The <code>--ask-become-pass</code> option makes so that the <code>sudo</code> password is asked when we run the playbook. In this case, since we used also <code>--ask-pass</code>, the SSH password will be used as the default password for privilege escalation. Here is the output we receive when we run the playbook:</p><pre><code>SSH password:
BECOME password[defaults to SSH password]:

PLAY [Update webservers] *******************************************************************************************************************************************

TASK [Gathering Facts] *********************************************************************************************************************************************
ok: [server1]
ok: [server2]

TASK [Ensure Vim is installed at the latest version] ***************************************************************************************************************
changed: [server1]
changed: [server2]

PLAY RECAP *********************************************************************************************************************************************************
server1                    : ok=2    changed=1    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0
server2                    : ok=2    changed=1    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0
</code></pre><p>First we are asked to provide the &ldquo;SSH&rdquo; password, then the &ldquo;BECOME&rdquo; one. As we already said, the SSH password will be used as the default value in this case. As you can see before the task we specified in the playbook, another task is execute: &ldquo;Gathering Facts&rdquo;. This task is executed by default in order to gather useful variables about remote hosts that can be used in playbooks.</p><p>After the tasks are executed, we get a recap of the play(s) we specified. In this case we can see, that two tasks have been executed correctly (<code>ok=2</code>) and one task has caused a change (<code>changed=1</code>). This makes sense: the change occurred since the vim package has been installed.</p><p>Now, if we try to execute the playbook again, we can see that no changes occur, since vim is already installed and at the last version available:</p><pre><code>PLAY RECAP *********************************************************************************************************************************************************
server1                    : ok=2    changed=0    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0
server2                    : ok=2    changed=0    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0
</code></pre><h2 id=h4-conclusions>Conclusions</h2><p>In this tutorial we learned what Ansible is and what are its peculiarities. We saw how to install it on some of the most used Linux distributions, how to configure it, and some basic concepts: what is an inventory and what are the Ansible modules. We also saw how to run a module from the command line and how to write and run a playbook. This was meant just as an introduction to the Ansible world; get you hands dirty, experiment and read the official documentation for a more in depth knowledge!</p></div><ul class="pager pagenav"> <li class=previous> <a class=hasTooltip title="SSH login without password" aria-label="Previous article: SSH login without password" href=/passwordless-ssh rel=prev> <span class=icon-chevron-left aria-hidden=true></span> <span aria-hidden=true>Prev</span> </a> </li> <li class=next> <a class=hasTooltip title="List all directories and sort by size" aria-label="Next article: List all directories and sort by size" href=/list-all-directories-and-sort-by-size rel=next> <span aria-hidden=true>Next</span> <span class=icon-chevron-right aria-hidden=true></span> </a> </li> </ul> </article></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom><div class=uk-grid><div class=uk-width-1-1><div class="uk-alert uk-alert-danger"> <i><center><b>FIND LATEST <a href=https://www.linuxcareers.com/ target=_blank rel="noreferrer noopener nofollow">LINUX JOBS</a> on LinuxCareers.com</b><br>Submit your <a href=https://www.linuxcareers.com/candidate/register/ target=_blank rel="noreferrer noopener nofollow">RESUME</a>, create a <a href=https://www.linuxcareers.com/jobs/alert/ target=_blank rel="noreferrer noopener nofollow">JOB ALERT</a>.</i></center></div></div></div><div class=uk-grid><div class=uk-width-1-2><div class="uk-alert uk-alert-alert"> <i><center><b>LINUX CAREER NEWSLETTER</b><br>Subscribe to <a href=https://bit.ly/2X5D30q target=_blank rel="noreferrer noopener nofollow">NEWSLETTER</a> and receive latest news, jobs, career advice and tutorials. </i></center></div></div><div class=uk-width-1-2><div class="uk-alert uk-alert-success"> <i><center><b>DO YOU NEED ADDITIONAL HELP?</b><br>Get extra help by visiting our <a href=https://forum.linuxconfig.org target=_blank rel="noreferrer noopener nofollow">LINUX FORUM</a> or simply use comments below.</i></center></div></div></div></div></div></div></div></div></div><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>More on LinuxConfig.org:</span></h3><div class=tagssimilar><ul> <li> <a href=/how-to-append-to-file-on-bash-shell-command-line> How to append to file on bash shell command line </a> </li> <li> <a href=/ubuntu-21-04-download> Ubuntu 21.04 Download </a> </li> <li> <a href=/passwordless-ssh> SSH login without password </a> </li> <li> <a href=/random-entropy-in-bash> Random Entropy in Bash </a> </li> </ul> </div> </div></div><div class=platform-content><div class="moduletable "><div class=custom><hr><center><div data-fuse=22198552927 class=incontent_ads></div></center><hr><center><font size=6><strong>Comments and Discussions</strong></font><br><img src=/images/linuxconfig-forum-logo.png alt="Linux Forum" < img></center><div id=discourse-comments></div></div></div></div></div></div></div></section></div><div class="g-block size-33"><aside id=g-aside><div class=g-grid><div class="g-block size-100"><div class=g-content><div class=platform-content><div class="moduletable "><div class=custom> <span style="margin: 0px; overflow:hidden; padding: 0px;" class=hidden-phone data-uk-sticky="{boundary:'#endad'}"><div data-fuse=22189504221 class=sticky_ads></div><hr style="margin: 3px" ;><div data-fuse=22189277162></div></span> <div id=endad style="position: absolute;bottom: 1120px;"> </div></div></div></div></div></div></div></aside></div></div></section></div><div class=g-container><footer id=g-footer><div class=g-grid><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Newsletter</span></h3><div class=g-particle> Subscribe to <a href=https://bit.ly/2X5D30q rel="noreferrer noopener nofollow" data-uk-tooltip="{pos:'bottom'}">Linux Career Newsletter </a> to receive latest news, jobs, career advice and featured configuration tutorials. </div></div></div></div><div class="g-block size-25"><div class=g-content><div class="moduletable "><h3 class=g-title><span>Write For Us</span></h3><div class=g-particle> LinuxConfig is looking for a technical writer(s) geared towards GNU/Linux and FLOSS technologies. Your articles will feature various GNU/Linux configuration tutorials and FLOSS technologies used in combination with GNU/Linux operating system.
<br><br>
When writing your articles you will be expected to be able to keep up with a technological advancement regarding the above mentioned technical area of expertise. You will work independently and be able to produce at minimum 2 technical articles a month. <br><br> <a class=button href=https://www.linuxcareers.com/jobs/floss-technical-writer-new-york-city-new-york/1-1/ rel=nofollow>APPLY NOW</a><br><br> </div> </div><div class="moduletable "><h3 class=g-title><span>Contact</span></h3><div class=g-particle><div class="g-contacts uk-margin-top"><div class=g-contacts-item> <span class="g-contacts-icon fa fa-envelope-o"></span> <span class=g-contact-value>web ( at ) linuxconfig ( dot ) org</span> </div></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Featured Linux Tutorials</span></h3><div class=custom><ul class=mostread> <li> <a href=/redhat-8-epel-install-guide itemprop=url> <span itemprop=name>How To enable the EPEL Repository on RHEL 8 / CentOS 8 Linux</span> </a> </li> <li> <a href=/bash-scripting-tutorial itemprop=url> <span itemprop=name> Bash scripting Tutorial </span> </a> </li> <li> <a href=/how-to-install-vmware-tools-on-rhel-8-centos-8 itemprop=url> <span itemprop=name>How to install VMware Tools on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/howto-mount-usb-drive-in-linux itemprop=url> <span itemprop=name> Howto mount USB drive in Linux </span> </a> </li> <li> <a href=/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux itemprop=url> <span itemprop=name>How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux</span> </a> </li> <li> <a href=/how-to-update-kali-linux itemprop=url> <span itemprop=name>How to update Kali Linux</span> </a> </li> <li> <a href=/ubuntu-20-04-download itemprop=url> <span itemprop=name>Ubuntu 20.04 Download </span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade Ubuntu To 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/how-to-install-node-js-on-redhat-8-linux itemprop=url> <span itemprop=name>How to install node.js on RHEL 8 / CentOS 8 Linux </span> </a> </li> <li> <a href=/how-to-check-centos-version itemprop=url> <span itemprop=name> How to check CentOS version </span> </a> </li> <li> <a href=/how-to-parse-data-from-json-into-python itemprop=url> <span itemprop=name>How to Parse Data From JSON Into Python</span> </a> </li> <li> <a href=/check-what-debian-version-you-are-running-on-your-linux-system itemprop=url> <span itemprop=name> Check what Debian version you are running on your Linux system </span> </a> </li> <li> <a href=/bash-scripting-tutorial-for-beginners itemprop=url> <span itemprop=name>Bash Scripting Tutorial for Beginners</span> </a> </li> <li> <a href=/ubuntu-20-04-guide itemprop=url> <span itemprop=name>Ubuntu 20.04 Guide</span> </a> </li> <li> <a href=/redhat-8-stop-start-firewall itemprop=url> <span itemprop=name>How to stop/start firewall on RHEL 8 / CentOS 8 </span> </a> </li> <li> <a href=/install-gnome-on-redhat-8 itemprop=url> <span itemprop=name>Install gnome on RHEL 8 / CentOS 8</span> </a> </li> <li> <a href=/linux-download itemprop=url> <span itemprop=name>Linux Download</span> </a> </li> <li> <a href=/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa itemprop=url> <span itemprop=name>How To Upgrade from Ubuntu 18.04 and 19.10 To Ubuntu 20.04 LTS Focal Fossa </span> </a> </li> <li> <a href=/enable-ssh-root-login-on-debian-linux-server itemprop=url> <span itemprop=name> Enable SSH root login on Debian Linux Server </span> </a> </li> </ul></div></div></div></div></div><div class="g-block size-25"><div class=g-content><div class=platform-content><div class="moduletable "><h3 class=g-title><span>Latest Articles</span></h3><ul class="latestnews mod-list"> <li itemscope itemtype=https://schema.org/Article> <a href=/replace-all-tab-characters-with-spaces itemprop=url> <span itemprop=name> Replace all TAB characters with spaces </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/rename-all-files-from-uppercase-to-lowercase-characters itemprop=url> <span itemprop=name> Rename all file names from uppercase to lowercase characters </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/nvidia-geforce-driver-installation-on-fedora-linux-64-bit itemprop=url> <span itemprop=name> NVIDIA GeForce Driver Installation on Fedora Linux 64-bit </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/passwordless-ssh itemprop=url> <span itemprop=name> SSH login without password </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-work-with-dnf-package-groups itemprop=url> <span itemprop=name> How to work with dnf package groups </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/ansible-tutorial-for-beginners-on-linux itemprop=url> <span itemprop=name> Ansible tutorial for beginners on Linux </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/list-all-directories-and-sort-by-size itemprop=url> <span itemprop=name> List all directories and sort by size </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/introduction-to-ranger-file-manager itemprop=url> <span itemprop=name> Introduction to Ranger file manager </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-connect-to-docker-container-via-ssh itemprop=url> <span itemprop=name> How to connect to Docker container via ssh </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/linux-dns-server-bind-configuration itemprop=url> <span itemprop=name> Linux DNS server BIND configuration </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/how-to-share-data-between-a-docker-container-and-host-system-using-volumes itemprop=url> <span itemprop=name> How to share data between a Docker container and host system using volumes </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/creating-a-redhat-package-repository itemprop=url> <span itemprop=name> Creating a Redhat package repository </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/linux-commands-to-backup-and-restore-mysql-database itemprop=url> <span itemprop=name> Linux commands to back up and restore MySQL database </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/docker-container-backup-and-recovery itemprop=url> <span itemprop=name> Docker container: Backup and Restore </span> </a> </li> <li itemscope itemtype=https://schema.org/Article> <a href=/collection-of-basic-linux-firewall-iptables-rules itemprop=url> <span itemprop=name> Collection of basic Linux Firewall iptables rules </span> </a> </li> </ul> </div></div></div></div></div></footer></div><div class=g-container><section id=g-copyright><div class=g-grid><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle> &copy; 2007 - 2021 <a name=rss>LinuxConfig.org</a> </div></div></div></div><div class="g-block size-50"><div class=g-content><div class="moduletable "><div class=g-particle><div class=g-social> <a href=/privacy rel=nofollow target=_blank>Privacy</a> <a target=_blank href=https://twitter.com/linuxconfig data-uk-tooltip="{pos:'bottom'}" rel="nofollow noopener"> <span class="fa fa-twitter fa-fw"></span> <span class=g-social-text> Twitter</span> </a> </div></div></div></div></div></div></section></div></section><div class=g-container><section id=g-to-top><div class=g-grid><div class="g-block size-100"><div class="g-content g-particle"><div class=" g-particle"><div class="g-totop style1"> <a href=# id=g-totop-button rel=nofollow data-uk-smooth-scroll> <i class="fa fa-angle-up"></i> </a> </div></div></div></div></div></section></div></div> <script src=/media/plg_jchoptimize/cache/js/96e2ca0d027f4a053e20ef9bbf18919d.js></script> <script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"65d66df4c9f9cedc","token":"1637300d8a394c64a4b8ffff41ff1ca8","version":"2021.5.2","si":10}'></script>
</body> </html>